[PATCH] gnu: Add ocrfeeder

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Leo Famulari
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 4 years ago
(address . 46393@debbugs.gnu.org)
CAJsg1E-Lm1znYh6N9vhP9Uaa4hEB07WhjpGHqtxS-ppX1kE6Bw@mail.gmail.com
* gnu/packages/gnome.scm (ocrfeeder): New variable
* gnu/packages/python-xyz.scm (python-sane): New variable
---
gnu/packages/gnome.scm | 67 ++++++++++++++++++++++++++++++++++++-
gnu/packages/python-xyz.scm | 25 ++++++++++++++
2 files changed, 91 insertions(+), 1 deletion(-)

Toggle diff (142 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0f0b7c8157..be6e825ddd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -56,7 +56,7 @@
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
-;;; Copyright © 2020 Andy Tai <atai@atai.org>
+;;; Copyright © 2020, 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,6 +149,7 @@
#:use-module (gnu packages ninja)
#:use-module (gnu packages node)
#:use-module (gnu packages nss)
+ #:use-module (gnu packages ocr)
#:use-module (gnu packages openldap)
#:use-module (gnu packages package-management)
#:use-module (gnu packages password-utils)
@@ -12034,3 +12035,67 @@ for the GNOME 3.x platform with many
features. It aims to be a very complete
editing environment for translation issues within the GNU gettext/GNOME desktop
world.")
(license license:gpl3+)))
+
+
+(define-public ocrfeeder
+ (package
+ (name "ocrfeeder")
+ (version "0.8.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/ocrfeeder/"
+ (version-major+minor version) "/"
+ "ocrfeeder-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12f5gnq92ffnd5zaj04df7jrnsdz1zn4zcgpbf5p9qnd21i2y529"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/" "ocrfeeder"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))
+ )))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("xmllint" ,libxml2)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("glib" ,glib)
+ ("goocanvas" ,goocanvas)
+ ("gtk" ,gtk+)
+ ("gtkspell3" ,gtkspell3)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("libraw" ,libraw)
+ ("ocrad" ,ocrad)
+ ("python" ,python-wrapper)
+ ("python-pygobject" ,python-pygobject)
+ ("python-odfpy" ,python-odfpy)
+ ("python-pillow" ,python-pillow)
+ ("python-pyenchant" ,python-pyenchant)
+ ("python-reportlab" ,python-reportlab)
+ ("python-sane" ,python-sane)
+ ("sane-backends" ,sane-backends)
+ ("tesseract-ocr" ,tesseract-ocr)))
+ (home-page "https://wiki.gnome.org/Apps/OCRFeeder")
+ (synopsis "A Complete OCR Suite")
+ (description "OCRFeeder is a complete Optical Character
Recognition and Document Analysis and Recognition program")
+ (license license:gpl3+)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e879742e5f..1c9bb2f77d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -179,6 +180,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages search)
+ #:use-module (gnu packages scanner)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
@@ -23735,3 +23737,26 @@ implementations.")
"Pivy provides python bindings for Coin, a 3D graphics library with an
Application Programming Interface based on the Open Inventor 2.1 API.")
(license license:isc)))
+
+
+
+(define-public python-sane
+ (package
+ (name "python-sane")
+ (version "2.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "1pi597z94n2mkd821ln52fq0g727n2jxfskf280ip3kf7jw8w294"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (inputs
+ `(("sane-backends" ,sane-backends)))
+ (home-page "https://github.com/python-pillow/Sane")
+ (synopsis "Python interface to the SANE scanner")
+ (description "Python interface to the SANE scanner and frame
grabber interface for Linux")
+ (license license:expat)))
\ No newline at end of file
--
2.30.0
Leo Famulari wrote 4 years ago
Re: [bug#46393] [PATCH] gnu: Add ocrfeeder
(name . Andy Tai)(address . atai@atai.org)(address . 46393@debbugs.gnu.org)
YDGqdMyoaVL0qrmQ@jasmine.lan
On Sat, Feb 13, 2021 at 06:40:57PM -0800, Andy Tai wrote:
Toggle quote (3 lines)
> * gnu/packages/gnome.scm (ocrfeeder): New variable
> * gnu/packages/python-xyz.scm (python-sane): New variable

In general, we add packages one commit at a time, so we prefer to
receive this as two patches. First, a patch that adds python-sane, and
then a second patch adding ocrfeeder.

Toggle quote (2 lines)
> +(define-public ocrfeeder

Overall LGTM, thanks!

Toggle quote (2 lines)
> + (synopsis "A Complete OCR Suite")

I would write, simply, "Complete OCR Suite". For some reason, the linter
doesn't complain for me, but it should recommend against starting
synopses with an article. That is, with "a", "an", or "the".


Toggle quote (3 lines)
> + (description "OCRFeeder is a complete Optical Character
> Recognition and Document Analysis and Recognition program")

And make sure to end the sentence with a period "."

Toggle quote (2 lines)
> +(define-public python-sane

Great!

Toggle quote (4 lines)
> + (synopsis "Python interface to the SANE scanner")
> + (description "Python interface to the SANE scanner and frame
> grabber interface for Linux")

We prefer to use complete sentences in the description. You can always
make it simple:

"This package provides Python interface to the SANE scanner and frame
grabber interface for Linux."

Toggle quote (2 lines)
> + (license license:expat)))

I looked in the repo and it doesn't look like the expat license:


I'm not sure what it is? Can you do a little research? That FSF license
directory might help.
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E9dcb45vOxRYP-Jpuw7L9dumnh7mpimx8o5Ltm6aMYXBg@mail.gmail.com
On Sat, Feb 20, 2021 at 4:34 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (9 lines)
>
> On Sat, Feb 13, 2021 at 06:40:57PM -0800, Andy Tai wrote:
> > * gnu/packages/gnome.scm (ocrfeeder): New variable
> > * gnu/packages/python-xyz.scm (python-sane): New variable
>
> In general, we add packages one commit at a time, so we prefer to
> receive this as two patches. First, a patch that adds python-sane, and
> then a second patch adding ocrfeeder.
>
I have made python-sane addition a separate patch,


Toggle quote (12 lines)
>
> > +(define-public python-sane
> > + (description "Python interface to the SANE scanner and frame
> > grabber interface for Linux")
>
> We prefer to use complete sentences in the description. You can always
> make it simple:
>
> "This package provides Python interface to the SANE scanner and frame
> grabber interface for Linux."
>

changed as suggested

Toggle quote (10 lines)
> > + (license license:expat)))
>
> I looked in the repo and it doesn't look like the expat license:
>
> https://directory.fsf.org/wiki/License:Expat
>
> I'm not sure what it is? Can you do a little research? That FSF license
> directory might help.


I double checked and the FSF uses expat to refer to MIT-style license.
I put a comment in the python-sane patch to that effect.

Thanks
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E8CNhONw7iuAo_aYiUKOmAb7H7iDdG5b8nMDO5M9Yy00A@mail.gmail.com
On Sat, Feb 20, 2021 at 4:34 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (8 lines)
> > * gnu/packages/gnome.scm (ocrfeeder): New variable
> > * gnu/packages/python-xyz.scm (python-sane): New variable
>
> In general, we add packages one commit at a time, so we prefer to
> receive this as two patches. First, a patch that adds python-sane, and
> then a second patch adding ocrfeeder.
>

Thus this bug now depends on the separate python-sane patch


Not sure if GNU Debbugs has a way to show dependency

Toggle quote (7 lines)
> > + (synopsis "A Complete OCR Suite")
>
> I would write, simply, "Complete OCR Suite". For some reason, the linter
> doesn't complain for me, but it should recommend against starting
> synopses with an article. That is, with "a", "an", or "the".
>

changed as suggested

Toggle quote (9 lines)
>
> > + (description "OCRFeeder is a complete Optical Character
> > Recognition and Document Analysis and Recognition program")
>
> And make sure to end the sentence with a period "."
>
>

added
Leo Famulari wrote 4 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 46393@debbugs.gnu.org)
YDP3fxAuZoU8meWP@jasmine.lan
On Sat, Feb 20, 2021 at 10:37:27PM -0800, Andy Tai wrote:
Toggle quote (12 lines)
> On Sat, Feb 20, 2021 at 4:34 PM Leo Famulari <leo@famulari.name> wrote:
> > I looked in the repo and it doesn't look like the expat license:
> >
> > https://directory.fsf.org/wiki/License:Expat
> >
> > I'm not sure what it is? Can you do a little research? That FSF license
> > directory might help.
>
>
> I double checked and the FSF uses expat to refer to MIT-style license.
> I put a comment in the python-sane patch to that effect.

Sorry, but this is not the expat license. It's a completely different
text.

In terms of concrete differences, at least, the requirement not to use
the author's name for "advertising" is not part of the expat license.

It's basically a variation on these:


I pushed a followup commit, adjusting the package to use the generic
"non-copyleft" license.
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E-CaF=xpCS+=1WyKLMjpvYV+D_GubysTkiqQdfbme06QA@mail.gmail.com
Thanks for clarifying the license:-)

On Mon, Feb 22, 2021 at 10:27 AM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (29 lines)
>
> On Sat, Feb 20, 2021 at 10:37:27PM -0800, Andy Tai wrote:
> > On Sat, Feb 20, 2021 at 4:34 PM Leo Famulari <leo@famulari.name> wrote:
> > > I looked in the repo and it doesn't look like the expat license:
> > >
> > > https://directory.fsf.org/wiki/License:Expat
> > >
> > > I'm not sure what it is? Can you do a little research? That FSF license
> > > directory might help.
> >
> >
> > I double checked and the FSF uses expat to refer to MIT-style license.
> > I put a comment in the python-sane patch to that effect.
>
> Sorry, but this is not the expat license. It's a completely different
> text.
>
> In terms of concrete differences, at least, the requirement not to use
> the author's name for "advertising" is not part of the expat license.
>
> It's basically a variation on these:
>
> https://www.xfree86.org/4.0.2/LICENSE3.html
>
> I pushed a followup commit, adjusting the package to use the generic
> "non-copyleft" license.



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 民國110年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Leo Famulari wrote 4 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 46393@debbugs.gnu.org)
YDVe6FJ9MRAvV39W@jasmine.lan
On Sat, Feb 20, 2021 at 11:09:19PM -0800, Andy Tai wrote:
Toggle quote (2 lines)
> Not sure if GNU Debbugs has a way to show dependency

Yes. You can mark certain bugs as "blocking" other from being closed.
You do it by sending email to <control@debbugs.gnu.org>. The control
mechanisms are described here:

Leo Famulari wrote 4 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 46393@debbugs.gnu.org)
YDVgJ4EL5+TGkovo@jasmine.lan
On Sat, Feb 20, 2021 at 11:09:19PM -0800, Andy Tai wrote:
Toggle quote (14 lines)
> From ee945305828750c4bf6e1ee010444d705eb9334b Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Sat, 20 Feb 2021 22:58:07 -0800
> Subject: [PATCH] gnu: Add ocrfeeder
>
> * gnu/packages/gnome.scm (ocrfeeder): New variable
> ---
> gnu/packages/gnome.scm | 67 ++++++++++++++++++++++++++++++++++++-
> gnu/packages/ocr.scm | 32 +++++++++---------
> gnu/packages/python-xyz.scm | 24 +++++++++++++
> 3 files changed, 106 insertions(+), 17 deletions(-)

> +(define-public ocrfeeder

Alright, the ocrfeeder package is looking good now.

Toggle quote (5 lines)
> diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
> index c4e965941a..0b46f979ce 100644
> --- a/gnu/packages/ocr.scm
> +++ b/gnu/packages/ocr.scm

Did you mean to include these changes to tesseract-ocr? I just skimmed,
but they only seem to be cosmetic changes, so probably not.

Toggle quote (7 lines)
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index b26fce72a9..1fb9ff60b4 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm

> +(define-public python-sane

Python-sane was already added, in commit f500905ce1baf85a2407c5ccde148ee6c2ea2584

Can you send a revised patch?
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E-oqaS9ADYEO3Ety-=-i+iENMgfT-M7uogPFve4gSST4A@mail.gmail.com
will do

On Tue, Feb 23, 2021 at 12:06 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (1 lines)
> Can you send a revised patch?
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E_B8kXCXsw0Z7tpx+heTyYtCEgGaCufrB-q1cXnTGbzTQ@mail.gmail.com
as attached

Toggle quote (2 lines)
> On Tue, Feb 23, 2021 at 12:06 PM Leo Famulari <leo@famulari.name> wrote:
> > Can you send a revised patch?
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393@debbugs.gnu.org)
CAJsg1E_AiXG9H-6ucf6J-KJ_fAk=ufQhQUzO6o2U31XXb47eVA@mail.gmail.com
sent the wrong one; here is the correct one


On Tue, Feb 23, 2021 at 5:59 PM Andy Tai <atai@atai.org> wrote:
Toggle quote (8 lines)
>
> as attached
>
> > On Tue, Feb 23, 2021 at 12:06 PM Leo Famulari <leo@famulari.name> wrote:
> > > Can you send a revised patch?



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 民國110年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sat, 20 Feb 2021 22:58:07 -0800
Subject: [PATCH] gnu: Add ocrfeeder

* gnu/packages/gnome.scm (ocrfeeder): New variable
---
gnu/packages/gnome.scm | 67 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 66 insertions(+), 1 deletion(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b8634d712a..32cecb75b5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -56,7 +56,7 @@
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
-;;; Copyright © 2020 Andy Tai <atai@atai.org>
+;;; Copyright © 2020, 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -149,6 +149,7 @@
#:use-module (gnu packages ninja)
#:use-module (gnu packages node)
#:use-module (gnu packages nss)
+ #:use-module (gnu packages ocr)
#:use-module (gnu packages openldap)
#:use-module (gnu packages package-management)
#:use-module (gnu packages password-utils)
@@ -12097,3 +12098,67 @@ for the GNOME 3.x platform with many features. It aims to be a very complete
editing environment for translation issues within the GNU gettext/GNOME desktop
world.")
(license license:gpl3+)))
+
+
+(define-public ocrfeeder
+ (package
+ (name "ocrfeeder")
+ (version "0.8.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/ocrfeeder/"
+ (version-major+minor version) "/"
+ "ocrfeeder-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12f5gnq92ffnd5zaj04df7jrnsdz1zn4zcgpbf5p9qnd21i2y529"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/" "ocrfeeder"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("xmllint" ,libxml2)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("glib" ,glib)
+ ("goocanvas" ,goocanvas)
+ ("gtk" ,gtk+)
+ ("gtkspell3" ,gtkspell3)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("libraw" ,libraw)
+ ("ocrad" ,ocrad)
+ ("python" ,python-wrapper)
+ ("python-pygobject" ,python-pygobject)
+ ("python-odfpy" ,python-odfpy)
+ ("python-pillow" ,python-pillow)
+ ("python-pyenchant" ,python-pyenchant)
+ ("python-reportlab" ,python-reportlab)
+ ("python-sane" ,python-sane)
+ ("sane-backends" ,sane-backends)
+ ("tesseract-ocr" ,tesseract-ocr)))
+ (home-page "https://wiki.gnome.org/Apps/OCRFeeder")
+ (synopsis "Complete OCR Suite")
+ (description "OCRFeeder is a complete Optical Character Recognition and
+Document Analysis and Recognition program.")
+ (license license:gpl3+)))
--
2.30.1
Leo Famulari wrote 4 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 46393-done@debbugs.gnu.org)
YDZ6FA3K25GLpQeo@jasmine.lan
On Tue, Feb 23, 2021 at 06:09:59PM -0800, Andy Tai wrote:
Toggle quote (7 lines)
> From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Sat, 20 Feb 2021 22:58:07 -0800
> Subject: [PATCH] gnu: Add ocrfeeder
>
> * gnu/packages/gnome.scm (ocrfeeder): New variable

Thanks! Pushed as 02e0aa255933197d6c95ab9b66251ef0885b237e
Closed
Andy Tai wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46393-done@debbugs.gnu.org)
CAJsg1E8weci5qqKrHWoh-M=JU+vC-SM92iriz3fSx+k5jYg7Zg@mail.gmail.com
Thanks!

On Wed, Feb 24, 2021 at 8:08 AM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (13 lines)
>
> On Tue, Feb 23, 2021 at 06:09:59PM -0800, Andy Tai wrote:
> > From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
> > From: Andy Tai <atai@atai.org>
> > Date: Sat, 20 Feb 2021 22:58:07 -0800
> > Subject: [PATCH] gnu: Add ocrfeeder
> >
> > * gnu/packages/gnome.scm (ocrfeeder): New variable
>
> Thanks! Pushed as 02e0aa255933197d6c95ab9b66251ef0885b237e



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 民國110年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46393@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46393
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help