Guix says it will download an output that is already downloaded

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • pkill9
Owner
unassigned
Submitted by
pkill9
Severity
normal

Debbugs page

pkill9 wrote 4 years ago
(address . bug-guix@gnu.org)
20210208215531.35967610@runbox.com
I had qtbase downloaded to the store as a reference for another store
path, but `guix build qtbase` said it will download it, but it only
downloaded the debug output of qtbase, plus the other dependencies, so
maybe guix doesn't omit package outputs that have already been
downloaded?
Ludovic Courtès wrote 4 years ago
(name . pkill9)(address . pkill9@runbox.com)(address . 46389@debbugs.gnu.org)
878s7xtw4h.fsf@gnu.org
Hi,

pkill9 <pkill9@runbox.com> skribis:

Toggle quote (6 lines)
> I had qtbase downloaded to the store as a reference for another store
> path, but `guix build qtbase` said it will download it, but it only
> downloaded the debug output of qtbase, plus the other dependencies, so
> maybe guix doesn't omit package outputs that have already been
> downloaded?

‘guix build qtbase’ said it would download both the “out” and the
“debug” output of qtbase, is that correct?

It would be ideal if you could send precisely what’s on your terminal.

Thanks,
Ludo’.
pkill9 wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46389@debbugs.gnu.org)
20210209195605.2a6419a9@runbox.com
Toggle quote (3 lines)
> ‘guix build qtbase’ said it would download both the “out” and the
> “debug” output of qtbase, is that correct?

Yep

Toggle quote (5 lines)
> It would be ideal if you could send precisely what’s on your terminal.
>
> Thanks,
> Ludo’.

In this example, I've checked the store path
"/gnu/store/vpvnd6593mjncvyir2rbgp3k83cr7w0a-qtbase-5.15.2" exists, and
I've run `guix gc --delete
/gnu/store/f2s8ql1x9d9890qrrf9qq4nix3f5aii3-qtbase-5.15.2-debug`:

```
itsme@antelope ~> guix build -n qtbase
209.5 MB would be downloaded:
/gnu/store/f2s8ql1x9d9890qrrf9qq4nix3f5aii3-qtbase-5.15.2-debug
/gnu/store/vpvnd6593mjncvyir2rbgp3k83cr7w0a-qtbase-5.15.2
```
I can't test it with `guix build qtbase` because my internet keeps
cutting off while downloading qtbase-5.15.2-debug, but iirc
after it downloads the debug output, it just returns both store paths.
Maxim Cournoyer wrote 3 years ago
(name . pkill9)(address . pkill9@runbox.com)(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46389@debbugs.gnu.org)
87sfr9xs1q.fsf@gmail.com
Hello,

pkill9 <pkill9@runbox.com> writes:

Toggle quote (25 lines)
>> ‘guix build qtbase’ said it would download both the “out” and the
>> “debug” output of qtbase, is that correct?
>
> Yep
>
>> It would be ideal if you could send precisely what’s on your terminal.
>>
>> Thanks,
>> Ludo’.
>
> In this example, I've checked the store path
> "/gnu/store/vpvnd6593mjncvyir2rbgp3k83cr7w0a-qtbase-5.15.2" exists, and
> I've run `guix gc --delete
> /gnu/store/f2s8ql1x9d9890qrrf9qq4nix3f5aii3-qtbase-5.15.2-debug`:
>
> ```
> itsme@antelope ~> guix build -n qtbase
> 209.5 MB would be downloaded:
> /gnu/store/f2s8ql1x9d9890qrrf9qq4nix3f5aii3-qtbase-5.15.2-debug
> /gnu/store/vpvnd6593mjncvyir2rbgp3k83cr7w0a-qtbase-5.15.2
> ```
> I can't test it with `guix build qtbase` because my internet keeps
> cutting off while downloading qtbase-5.15.2-debug, but iirc
> after it downloads the debug output, it just returns both store paths.

I think it's a minor UI issue:

Toggle snippet (38 lines)
$ guix build ada-ed
substitute: updating substitutes from 'http://127.0.0.1:8181'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
0.8 MB will be downloaded:
/gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug
/gnu/store/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2
substituting /gnu/store/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2...
downloading from https://ci.guix.gnu.org/nar/lzip/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2 ...
ada-ed-1.11.2 337KiB 585KiB/s 00:01 [##################] 100.0%

substituting /gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug...
downloading from https://ci.guix.gnu.org/nar/lzip/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug ...
ada-ed-1.11.2-debug 486KiB 1.1MiB/s 00:00 [##################] 100.0%

/gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug
/gnu/store/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2
maxim@hurd ~/src/guix-master [env]$ guix gc -D /gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug
finding garbage collector roots...
[...]
deleting `/gnu/store/trash'
deleting unused links...

note: currently hard linking saves 70907.58 MiB

$ guix build ada-ed
substitute: updating substitutes from 'http://127.0.0.1:8181'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
0.8 MB will be downloaded:
/gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug
/gnu/store/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2
substituting /gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug...
downloading from https://ci.guix.gnu.org/nar/lzip/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug ...
ada-ed-1.11.2-debug 486KiB 832KiB/s 00:01 [##################] 100.0%

/gnu/store/kq9px99x5wnnx44px5z426gqw07afih7-ada-ed-1.11.2-debug
/gnu/store/s4rz0x57m1ashz99jnfg7a5622ff06v1-ada-ed-1.11.2

We can see that it listed *both* output about to be downloaded, then
proceeded to download only the one missing (the debug output).

Thanks,

Maxim
Ludovic Courtès wrote 3 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 46389@debbugs.gnu.org)(name . pkill9)(address . pkill9@runbox.com)
875yo3g36j.fsf@gnu.org
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (3 lines)
> We can see that it listed *both* output about to be downloaded, then
> proceeded to download only the one missing (the debug output).

That could be a bug in ‘derivation-build-plan’, the procedure that
computes what needs to be built and substituted.

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 46389@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46389
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help