[PATCH] gnu: tesseract-ocr: update to 4.1.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Jelle Licht
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 8 Feb 2021 07:42
(address . guix-patches@gnu.org)
CAJsg1E9Te_+5BRnss9kYBezHNibd_eo0D0+cehT0K0niugzdMw@mail.gmail.com
* gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
---
gnu/packages/ocr.scm | 38 +++++++++++++++++++++++++++++++-------
1 file changed, 31 insertions(+), 7 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..7fc3929684 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages image))

@@ -52,25 +58,43 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))

(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version "4.1.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
- (file-name (git-file-name name version))
+ (commit commit)
+ ;; Fetch git submodules otherwise typeshed is not fetched.
+ ;; Typeshed is a collection of Python sources type annotation
+ ;; (data) files.
+ (recursive? #t)))
+ (file-name (string-append name "-" version "-" commit "-checkout"))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("googletest" ,googletest)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ ;; some test, applybox_test fails to build
+ #:tests? #f))
(home-page "https://github.com/tesseract-ocr/tesseract")
(synopsis "Optical character recognition engine")
(description
@@ -79,7 +103,7 @@ high accuracy. It supports many languages, output
text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))

(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
--
2.30.0
A
A
Andy Tai wrote on 8 Feb 2021 07:51
Re: [PATCH] gnu: tesseract-ocr: update to 4.1.1)
(address . 46376@debbugs.gnu.org)
CAJsg1E8Md0KGfH0RHRVrWCVuw7kzwYT2yA9ZOuCWQ1GpzaeBnw@mail.gmail.com
* gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
---
gnu/packages/ocr.scm | 36 +++++++++++++++++++++++++++++-------
1 file changed, 29 insertions(+), 7 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..b666ec5aab 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages image))

@@ -52,25 +58,41 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))

(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version "4.1.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
- (file-name (git-file-name name version))
+ (commit commit)
+ ;; Fetch git submodules
+ (recursive? #t)))
+ (file-name (string-append name "-" version "-" commit "-checkout"))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("googletest" ,googletest)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ ;; some test, applybox_test fails to build
+ #:tests? #f))
(home-page "https://github.com/tesseract-ocr/tesseract")
(synopsis "Optical character recognition engine")
(description
@@ -79,7 +101,7 @@ high accuracy. It supports many languages, output
text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))

(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
--
2.30.0
J
J
Jelle Licht wrote on 8 Feb 2021 22:36
Re: [bug#46376] [PATCH] gnu: tesseract-ocr: update to 4.1.1)
86a6sep7h0.fsf@posteo.net
Hello Andy,

Thanks for working on this package! I was not able to cleanly apply any
of the patches, but that problem might be on my end though.

Something did seem to go wrong though, as I notice three patches that do
the same (from a quick glance).

I have some nitpicks, some of them more serious than others;

Andy Tai <atai@atai.org> writes:

Toggle quote (1 lines)
> * gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
^ This is usually capitalised.
Toggle quote (8 lines)
> [snip]
> (define-public tesseract-ocr
> + ;; some useful commits beyond last official stable release in release branch
> + (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
> (package
> (name "tesseract-ocr")
> - (version "3.04.01")
> + (version "4.1.1")
^ Since we are not _actually_ using version 4.1.1, but a
later commit, you could use
`(git-version "4.1.1" revision commit)' here instead


Toggle quote (11 lines)
> (source
> (origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/tesseract-ocr/tesseract")
> - (commit version)))
> - (file-name (git-file-name name version))
> + (commit commit)
> + ;; Fetch git submodules
> + (recursive? #t)))

Instead of stating what the code does, would you consider adding a
comment why this is needed?

Toggle quote (1 lines)
> + (file-name (string-append name "-" version "-" commit "-checkout"))
^ You can use `(git-file-name name version)' here.

Toggle quote (24 lines)
> (sha256
> - (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
> + (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
> (build-system gnu-build-system)
> (inputs
> - `(("leptonica" ,leptonica)))
> + `( ("cairo" ,cairo)
> + ("icu" ,icu4c)
> + ("leptonica" ,leptonica)
> + ("pango" ,pango)))
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("autoconf-archive" ,autoconf-archive)
> + ("automake" ,automake)
> + ("googletest" ,googletest)
> + ("libtool" ,libtool)
> + ("pkg-config" ,pkg-config)))
> (arguments
> '(#:configure-flags
> (let ((leptonica (assoc-ref %build-inputs "leptonica")))
> - (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
> + (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
> + ;; some test, applybox_test fails to build
> + #:tests? #f))
2 nits: Is it possible to patch or disable only the failing tests?
Is there a reason googletest is added if testing is subsequently disabled?

Thanks,
- Jelle
A
A
Andy Tai wrote on 9 Feb 2021 00:14
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E_GNDOpWfHd-nUPVk7VuAgfSFcUnG-tEZQGy-utzrPcTA@mail.gmail.com
updated patch attached


On Mon, Feb 8, 2021 at 1:36 PM Jelle Licht <jlicht@posteo.net> wrote:
Toggle quote (5 lines)
>
>
> > * gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
> ^ This is usually capitalised.

capitalized

Toggle quote (12 lines)
> > [snip]
> > (define-public tesseract-ocr
> > + ;; some useful commits beyond last official stable release in release branch
> > + (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
> > (package
> > (name "tesseract-ocr")
> > - (version "3.04.01")
> > + (version "4.1.1")
> ^ Since we are not _actually_ using version 4.1.1, but a
> later commit, you could use
> `(git-version "4.1.1" revision commit)' here instead

changed as suggested
Toggle quote (16 lines)
>
> > (source
> > (origin
> > (method git-fetch)
> > (uri (git-reference
> > (url "https://github.com/tesseract-ocr/tesseract")
> > - (commit version)))
> > - (file-name (git-file-name name version))
> > + (commit commit)
> > + ;; Fetch git submodules
> > + (recursive? #t)))
>
> Instead of stating what the code does, would you consider adding a
> comment why this is needed?
>

commented as suggested

Toggle quote (4 lines)
> > + (file-name (string-append name "-" version "-" commit "-checkout"))
> ^ You can use `(git-file-name name version)' here.
>

changed as suggested

Toggle quote (26 lines)
> > (sha256
> > - (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
> > + (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
> > (build-system gnu-build-system)
> > (inputs
> > - `(("leptonica" ,leptonica)))
> > + `( ("cairo" ,cairo)
> > + ("icu" ,icu4c)
> > + ("leptonica" ,leptonica)
> > + ("pango" ,pango)))
> > + (native-inputs
> > + `(("autoconf" ,autoconf)
> > + ("autoconf-archive" ,autoconf-archive)
> > + ("automake" ,automake)
> > + ("googletest" ,googletest)
> > + ("libtool" ,libtool)
> > + ("pkg-config" ,pkg-config)))
> > (arguments
> > '(#:configure-flags
> > (let ((leptonica (assoc-ref %build-inputs "leptonica")))
> > - (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
> > + (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
> > + ;; some test, applybox_test fails to build
> > + #:tests? #f))
> 2 nits: Is it possible to patch or disable only the failing tests?

tests failing to build probably due to some issue with parallel
builds; did not dig into it as probably will take much time; will be
TODO if time allows)

Toggle quote (3 lines)
> Is there a reason googletest is added if testing is subsequently disabled?
>

removed

Toggle quote (5 lines)
> Thanks,
> - Jelle



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
From 7ab7fcbb95d933f6a7ba3e688131caa0435bdfdd Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 7 Feb 2021 22:23:47 -0800
Subject: [PATCH] gnu: tesseract-ocr: Update to 4.1.1

* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1
---
gnu/packages/ocr.scm | 34 ++++++++++++++++++++++++++++------
1 file changed, 28 insertions(+), 6 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..0d357726b2 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages image))
@@ -52,25 +58,41 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))
(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df")
+ (revision "1"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version (git-version "4.1.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
+ (commit commit)
+ ;; source git repo with submodules; ensure they are fetched
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ ;; some test, applybox_test fails to build
+ #:tests? #f))
(home-page "https://github.com/tesseract-ocr/tesseract")
(synopsis "Optical character recognition engine")
(description
@@ -79,7 +101,7 @@ high accuracy. It supports many languages, output text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
--
2.30.0
J
J
Jelle Licht wrote on 9 Feb 2021 12:56
(name . Andy Tai)(address . atai@atai.org)(address . 46376@debbugs.gnu.org)
867dnhpi85.fsf@posteo.net
Hello Andy,

I have some additional questions about your updated patch.

Andy Tai <atai@atai.org> writes:

Toggle quote (12 lines)
> updated patch attached
>> > - (file-name (git-file-name name version))
>> > + (commit commit)
>> > + ;; Fetch git submodules
>> > + (recursive? #t)))
>>
>> Instead of stating what the code does, would you consider adding a
>> comment why this is needed?
>>
>
> commented as suggested

I was unclear in my message: Of course there are some submodules that
are being fetched; why should we fetch them in the first place? From
a cursory glance, they seem required to do stuff such as running the
tests, which in this iteration of the patch are not being run.

FWIW, leaving out the `recursive? #t' still allows me to build
tesseract-ocr: could you try and see if it makes a difference in your
use of tesseract?

Toggle quote (7 lines)
>> > (inputs
>> > - `(("leptonica" ,leptonica)))
>> > + `( ("cairo" ,cairo)
>> > + ("icu" ,icu4c)
>> > + ("leptonica" ,leptonica)
>> > + ("pango" ,pango)))

I just built the package: no references are made to cairo, icu4c and
pango, and tesseract seems to build fine without them: is there a
specific reason why these were added to the inputs?

Toggle quote (20 lines)
>> > + (native-inputs
>> > + `(("autoconf" ,autoconf)
>> > + ("autoconf-archive" ,autoconf-archive)
>> > + ("automake" ,automake)
>> > + ("googletest" ,googletest)
>> > + ("libtool" ,libtool)
>> > + ("pkg-config" ,pkg-config)))
>> > (arguments
>> > '(#:configure-flags
>> > (let ((leptonica (assoc-ref %build-inputs "leptonica")))
>> > - (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
>> > + (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
>> > + ;; some test, applybox_test fails to build
>> > + #:tests? #f))
>> 2 nits: Is it possible to patch or disable only the failing tests?
>
> tests failing to build probably due to some issue with parallel
> builds; did not dig into it as probably will take much time; will be
> TODO if time allows)

I'll defer to someone with more experience with tesseract, as I have no
experience to speak of on whether this leads to us having a (subtly)
broken package.

Adding the following arguments might help to validate your assumption:
`#:make-flags (list "-j" "1")'.

Thanks,
- Jelle
A
A
Andy Tai wrote on 9 Feb 2021 17:22
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E_usROdu14HbS2SV2hjrOggwdyKr=KmFxuVRGinJwyOMg@mail.gmail.com
Hi, I updated the patch to only build in serial, with "-j 1"

and with this, everything, including tests, builds successfully.

Not sure if there is a way to specify only building the tests with "-j 1"

In any case, the updated patch is attached

Thanks

On Tue, Feb 9, 2021 at 3:56 AM Jelle Licht <jlicht@posteo.net> wrote:
Toggle quote (6 lines)
>
> Adding the following arguments might help to validate your assumption:
> `#:make-flags (list "-j" "1")'.
>
> Thanks,
> - Jelle
From 5fde44f0d89660af23672ce16c640df7a9947fa2 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Tue, 9 Feb 2021 08:16:30 -0800
Subject: [PATCH] gnu: tesseract-ocr: Update to 4.1.1)

* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1
---
gnu/packages/ocr.scm | 34 ++++++++++++++++++++++++++++------
1 file changed, 28 insertions(+), 6 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..37b6771db5 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages image))
@@ -52,23 +58,39 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))
(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df")
+ (revision "1"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version (git-version "4.1.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
+ (commit commit)
+ ;; source git repo with submodules; ensure they are fetched
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("googletest" ,googletest)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
- '(#:configure-flags
+ '(#:make-flags (list "-j" "1") ;; some test, applybox_test fails to build if built in parallel
+ #:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
(list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
(home-page "https://github.com/tesseract-ocr/tesseract")
@@ -79,7 +101,7 @@ high accuracy. It supports many languages, output text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
--
2.30.0
J
J
Jelle Licht wrote on 9 Feb 2021 23:43
(name . Andy Tai)(address . atai@atai.org)(address . 46376@debbugs.gnu.org)
86sg6450cl.fsf@posteo.net
Hi Andy,

Andy Tai <atai@atai.org> writes:

Toggle quote (4 lines)
> Hi, I updated the patch to only build in serial, with "-j 1"
>
> and with this, everything, including tests, builds successfully.

No such luck, for me at least. Are you certain you got it to build on
your end? Could you try with `--check`?

I've had to work out the following things:

- Patched out "<tesseract/baseapi.h>" and "<tesseract/helpers.h>" to
refer to "baseapi.h" and "helpers.h" in "unittest/pagesegmode_test.cc".

- Make sure the check phase takes place after running "make training" in
a phase.

I still ended up with several failing tests, courtesy of it running
unsupported instructions on my cpu (educated guess: avx etc). Nothing
comes easy, I guess.

Thanks,
- Jelle
A
A
Andy Tai wrote on 9 Feb 2021 23:53
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E8ifSy8PP18g51bJPBp+itMnbsG-kSWM7NAhKJURJrZ5w@mail.gmail.com
Strange. I did use --check to build, And I need to make no changes
to the checked out sources. So our environment seems to have
significant differences?

That under guix makes no sense.

On Tue, Feb 9, 2021 at 2:43 PM Jelle Licht <jlicht@posteo.net> wrote:
Toggle quote (29 lines)
>
> Hi Andy,
>
> Andy Tai <atai@atai.org> writes:
>
> > Hi, I updated the patch to only build in serial, with "-j 1"
> >
> > and with this, everything, including tests, builds successfully.
>
> No such luck, for me at least. Are you certain you got it to build on
> your end? Could you try with `--check`?
>
> I've had to work out the following things:
>
> - Patched out "<tesseract/baseapi.h>" and "<tesseract/helpers.h>" to
> refer to "baseapi.h" and "helpers.h" in "unittest/pagesegmode_test.cc".
>
> - Make sure the check phase takes place after running "make training" in
> a phase.
>
> I still ended up with several failing tests, courtesy of it running
> unsupported instructions on my cpu (educated guess: avx etc). Nothing
> comes easy, I guess.
>
> Thanks,
> - Jelle



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
A
A
Andy Tai wrote on 10 Feb 2021 08:52
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E9H14+5jU674DOZW9g=HfB0cmAEa8KgGiDoo8ga+7JKOg@mail.gmail.com
updated patch, now tests build in parallel... the build order has to
be explicitly set to make the training target built first

also added some other optional dependencies; built in a GuixSD VM to
ensure no dependency on non-Guix tools from host

test run is disabled for now

On Tue, Feb 9, 2021 at 2:43 PM Jelle Licht <jlicht@posteo.net> wrote:
Toggle quote (29 lines)
>
> Hi Andy,
>
> Andy Tai <atai@atai.org> writes:
>
> > Hi, I updated the patch to only build in serial, with "-j 1"
> >
> > and with this, everything, including tests, builds successfully.
>
> No such luck, for me at least. Are you certain you got it to build on
> your end? Could you try with `--check`?
>
> I've had to work out the following things:
>
> - Patched out "<tesseract/baseapi.h>" and "<tesseract/helpers.h>" to
> refer to "baseapi.h" and "helpers.h" in "unittest/pagesegmode_test.cc".
>
> - Make sure the check phase takes place after running "make training" in
> a phase.
>
> I still ended up with several failing tests, courtesy of it running
> unsupported instructions on my cpu (educated guess: avx etc). Nothing
> comes easy, I guess.
>
> Thanks,
> - Jelle



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
From d3287d74861824dc3a7e2b65e11cd33fa0a11b39 Mon Sep 17 00:00:00 2001
From: andy Tai <atai@atai.org>
Date: Tue, 9 Feb 2021 23:44:06 -0800
Subject: [PATCH] gnu: tesseract-ocr: Update to 4.1.1)

* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1
---
gnu/packages/ocr.scm | 53 +++++++++++++++++++++++++++++++++++++++-----
1 file changed, 47 insertions(+), 6 deletions(-)

Toggle diff (107 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..1ea7a94085 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,8 +27,17 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages image))
(define-public ocrad
@@ -52,25 +62,55 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))
(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df")
+ (revision "1"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version (git-version "4.1.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
+ (commit commit)
+ ;; source git repo with submodules; ensure they are fetched
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("googletest" ,googletest)
+ ("libarchive" ,libarchive)
+ ("libcurl" ,curl)
+ ("libtool" ,libtool)
+ ("libtiff" ,libtiff)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("xsltproc" ,libxslt)))
(arguments
'(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-before 'build 'build-training
+ (lambda _
+ (invoke "make" "training")))
+ (add-after 'install 'install-training
+ (lambda _
+ (invoke "make" "training-install")
+ #t)))))
(home-page "https://github.com/tesseract-ocr/tesseract")
(synopsis "Optical character recognition engine")
(description
@@ -79,7 +119,7 @@ high accuracy. It supports many languages, output text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
@@ -151,3 +191,4 @@ that allows us to create any hand-written recognition systems with low-cost.")
#t)))))
(inputs
`(("zinnia" ,zinnia)))))
+
--
2.29.2
A
A
Andy Tai wrote on 11 Feb 2021 01:00
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E8qM-_eRdQy4OBFQMWDkw68gzPv_2xiDrNt0VTdHyYYGQ@mail.gmail.com
updated patch:

unit tests run, with some failures due to illegal instruction and
others succeed, but these requires first manual downloading of the
training data; I am not sure how that can be done as part of Guix
package definition. Help on that is much appreciated. (details
commented in the patch)

On Tue, Feb 9, 2021 at 11:52 PM Andy Tai <atai@atai.org> wrote:
Toggle quote (47 lines)
>
> updated patch, now tests build in parallel... the build order has to
> be explicitly set to make the training target built first
>
> also added some other optional dependencies; built in a GuixSD VM to
> ensure no dependency on non-Guix tools from host
>
> test run is disabled for now
>
> On Tue, Feb 9, 2021 at 2:43 PM Jelle Licht <jlicht@posteo.net> wrote:
> >
> > Hi Andy,
> >
> > Andy Tai <atai@atai.org> writes:
> >
> > > Hi, I updated the patch to only build in serial, with "-j 1"
> > >
> > > and with this, everything, including tests, builds successfully.
> >
> > No such luck, for me at least. Are you certain you got it to build on
> > your end? Could you try with `--check`?
> >
> > I've had to work out the following things:
> >
> > - Patched out "<tesseract/baseapi.h>" and "<tesseract/helpers.h>" to
> > refer to "baseapi.h" and "helpers.h" in "unittest/pagesegmode_test.cc".
> >
> > - Make sure the check phase takes place after running "make training" in
> > a phase.
> >
> > I still ended up with several failing tests, courtesy of it running
> > unsupported instructions on my cpu (educated guess: avx etc). Nothing
> > comes easy, I guess.
> >
> > Thanks,
> > - Jelle
>
>
>
> --
> Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
> Year 2021 ??110?
> ????????????
> ????????????



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
J
J
Jelle Licht wrote on 11 Feb 2021 11:48
(name . Andy Tai)(address . atai@atai.org)(address . 46376@debbugs.gnu.org)
86o8gq517v.fsf@posteo.net
Hey Andy,

Andy Tai <atai@atai.org> writes:

Toggle quote (8 lines)
> updated patch:
>
> unit tests run, with some failures due to illegal instruction and
> others succeed, but these requires first manual downloading of the
> training data; I am not sure how that can be done as part of Guix
> package definition. Help on that is much appreciated. (details
> commented in the patch)

The illegal instruction stuff seems somehow problematic either way. The
training data seems to be generated via a not-really-trivial process, so
my guess is that to properly package this, we would really have to
generate the training data 'from source'. For now, it might make more
sense to have users "BYOTD" (bring your own training data) and leave it
out of the packaging story.

Andy, what would you think about dumbing down your patch so
tesseract-ocr simply doesn't run tests (or try to build them, for that
matter)? So sorry for sending you on this wild goose chase!

I'm willing to adjust and push such a change, unless someone has a
better idea.

Thanks,
- Jelle
A
A
Andy Tai wrote on 11 Feb 2021 19:34
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376@debbugs.gnu.org)
CAJsg1E8k66yKkPN-uV5JVE4WOCxYdyzGkU_ecd6XwEUKtLHtJA@mail.gmail.com
Hi, sure. Since the tests are built, we can just skip running them by
deleting the check phase. That would be minimal change from the
(otherwise working) patch, also with no trouble from the missing
training data.

On Thu, Feb 11, 2021 at 2:48 AM Jelle Licht <jlicht@posteo.net> wrote:
Toggle quote (32 lines)
>
> Hey Andy,
>
> Andy Tai <atai@atai.org> writes:
>
> > updated patch:
> >
> > unit tests run, with some failures due to illegal instruction and
> > others succeed, but these requires first manual downloading of the
> > training data; I am not sure how that can be done as part of Guix
> > package definition. Help on that is much appreciated. (details
> > commented in the patch)
>
> The illegal instruction stuff seems somehow problematic either way. The
> training data seems to be generated via a not-really-trivial process, so
> my guess is that to properly package this, we would really have to
> generate the training data 'from source'. For now, it might make more
> sense to have users "BYOTD" (bring your own training data) and leave it
> out of the packaging story.
>
> Andy, what would you think about dumbing down your patch so
> tesseract-ocr simply doesn't run tests (or try to build them, for that
> matter)? So sorry for sending you on this wild goose chase!
>
> I'm willing to adjust and push such a change, unless someone has a
> better idea.
>
> Thanks,
> - Jelle



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 ??110?
????????????
????????????
J
J
Jelle Licht wrote on 13 Feb 2021 15:34
(name . Andy Tai)(address . atai@atai.org)(address . 46376-done@debbugs.gnu.org)
86lfbs3ul0.fsf@posteo.net
Hey Andy,

Andy Tai <atai@atai.org> writes:

Toggle quote (5 lines)
> Hi, sure. Since the tests are built, we can just skip running them by
> deleting the check phase. That would be minimal change from the
> (otherwise working) patch, also with no trouble from the missing
> training data.

I pushed a slightly modified version of your patch as 822cd628e6 to
master; Instead of building the tests for no reason, I reverted the
recursive git checkout and I removed dependencies that are not required
for building tesseract from a git checkout.

Additionally, the manpages are now generated and installed as well.

Thanks again,
- Jelle
Closed
A
A
Andy Tai wrote on 13 Feb 2021 21:37
(name . Jelle Licht)(address . jlicht@posteo.net)(address . 46376-done@debbugs.gnu.org)
CAJsg1E90__68BhMBUyra05bvFGHEnBP0zGdjPc24ULjCpJxP9w@mail.gmail.com
Thanks!

On Sat, Feb 13, 2021 at 6:34 AM Jelle Licht <jlicht@posteo.net> wrote:

Toggle quote (21 lines)
> Hey Andy,
>
> Andy Tai <atai@atai.org> writes:
>
> > Hi, sure. Since the tests are built, we can just skip running them by
> > deleting the check phase. That would be minimal change from the
> > (otherwise working) patch, also with no trouble from the missing
> > training data.
>
> I pushed a slightly modified version of your patch as 822cd628e6 to
> master; Instead of building the tests for no reason, I reverted the
> recursive git checkout and I removed dependencies that are not required
> for building tesseract from a git checkout.
>
> Additionally, the manpages are now generated and installed as well.
>
> Thanks again,
> - Jelle
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2021 ??110?
????????????
????????????
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46376@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46376
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch