[PATCH] gnu: xpdf: Update to 4.03.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20210207113847.16495-1-vincent.legoll@gmail.com
* gnu/packages/pdf.scm (xpdf): Update to 4.03.
(source): Use a "dl.xpdfreader.com" URL.
(build-system): Use cmake-build-system.
(arguments): Remove #:parallel-build?, #:configure-flags and #:phases
(inputs): Add cups, freetype & qtbase, remove gs-fonts, lesstif, libpaper
libx11, libxext, libxp, libxpm & libxt.
---
gnu/packages/pdf.scm | 30 +++++-------------------------
1 file changed, 5 insertions(+), 25 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66e920a7bb..b69f8d6536 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -396,15 +396,14 @@ reading and editing of existing PDF files.")
(define-public xpdf
(package
(name "xpdf")
- (version "4.02")
+ (version "4.03")
(source
(origin
(method url-fetch)
- (uri (string-append "https://xpdfreader-dl.s3.amazonaws.com/xpdf-"
- version "4.02.tar.gz"))
+ (uri (string-append "https://dl.xpdfreader.com/xpdf-" version ".tar.gz"))
(sha256
- (base32 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
- (build-system gnu-build-system)
+ (base32 "0ip81c9vy0igjnasl9iv2lz214fb01vvvdzbvjmgwc63fi1jgr0g"))))
+ (build-system cmake-build-system)
(inputs `(("freetype" ,freetype)
("gs-fonts" ,gs-fonts)
("lesstif" ,lesstif)
@@ -417,26 +416,7 @@ reading and editing of existing PDF files.")
("libpng" ,libpng)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; there is no check target
- #:parallel-build? #f ; build fails randomly on 8-way machines
- #:configure-flags
- (list (string-append "--with-freetype2-includes="
- (assoc-ref %build-inputs "freetype")
- "/include/freetype2"))
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
- (let* ((install (assoc-ref %standard-phases 'install))
- (out (assoc-ref outputs "out"))
- (xpdfrc (string-append out "/etc/xpdfrc"))
- (gs-fonts (assoc-ref inputs "gs-fonts")))
- (apply install args)
- (substitute* xpdfrc
- (("/usr/local/share/ghostscript/fonts")
- (string-append gs-fonts "/share/fonts/type1/ghostscript"))
- (("#fontFile") "fontFile")))
- #t)))))
+ `(#:tests? #f)) ; there is no check target
(synopsis "Viewer for PDF files based on the Motif toolkit")
(description
"Xpdf is a viewer for Portable Document Format (PDF) files.")
--
2.30.0
Vincent Legoll wrote 4 years ago
(address . 46357@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20210207114033.16634-1-vincent.legoll@gmail.com
* gnu/packages/pdf.scm (xpdf): Update to 4.03.
(source): Use a "dl.xpdfreader.com" URL.
(build-system): Use cmake-build-system.
(arguments): Remove #:parallel-build?, #:configure-flags and #:phases
(inputs): Add cups, freetype & qtbase, remove gs-fonts, lesstif, libpaper
libx11, libxext, libxp, libxpm & libxt.
---
gnu/packages/pdf.scm | 42 ++++++++----------------------------------
1 file changed, 8 insertions(+), 34 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66e920a7bb..dc7df3fa28 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -396,47 +396,21 @@ reading and editing of existing PDF files.")
(define-public xpdf
(package
(name "xpdf")
- (version "4.02")
+ (version "4.03")
(source
(origin
(method url-fetch)
- (uri (string-append "https://xpdfreader-dl.s3.amazonaws.com/xpdf-"
- version "4.02.tar.gz"))
+ (uri (string-append "https://dl.xpdfreader.com/xpdf-" version ".tar.gz"))
(sha256
- (base32 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
- (build-system gnu-build-system)
- (inputs `(("freetype" ,freetype)
- ("gs-fonts" ,gs-fonts)
- ("lesstif" ,lesstif)
- ("libpaper" ,libpaper)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxp" ,libxp)
- ("libxpm" ,libxpm)
- ("libxt" ,libxt)
+ (base32 "0ip81c9vy0igjnasl9iv2lz214fb01vvvdzbvjmgwc63fi1jgr0g"))))
+ (build-system cmake-build-system)
+ (inputs `(("cups" ,cups)
+ ("freetype" ,freetype)
("libpng" ,libpng)
+ ("qtbase" ,qtbase)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; there is no check target
- #:parallel-build? #f ; build fails randomly on 8-way machines
- #:configure-flags
- (list (string-append "--with-freetype2-includes="
- (assoc-ref %build-inputs "freetype")
- "/include/freetype2"))
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
- (let* ((install (assoc-ref %standard-phases 'install))
- (out (assoc-ref outputs "out"))
- (xpdfrc (string-append out "/etc/xpdfrc"))
- (gs-fonts (assoc-ref inputs "gs-fonts")))
- (apply install args)
- (substitute* xpdfrc
- (("/usr/local/share/ghostscript/fonts")
- (string-append gs-fonts "/share/fonts/type1/ghostscript"))
- (("#fontFile") "fontFile")))
- #t)))))
+ `(#:tests? #f)) ; there is no check target
(synopsis "Viewer for PDF files based on the Motif toolkit")
(description
"Xpdf is a viewer for Portable Document Format (PDF) files.")
--
2.30.0
Vincent Legoll wrote 4 years ago
Re: bug#46357: Acknowledgement ([PATCH] gnu: xpdf: Update to 4.03.)
(address . 46357@debbugs.gnu.org)
CAEwRq=otC+CzCSY8U4U4q6D6u9L=ZSfW+hb4rOu8sFR95uVK7g@mail.gmail.com
My guix is headless so I didn't test this, can
someone help test ?

--
Vincent Legoll
Leo Famulari wrote 4 years ago
Re: [bug#46357] [PATCH] gnu: xpdf: Update to 4.03.
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 46357-done@debbugs.gnu.org)
YCL0cOhOf1S1oEzS@jasmine.lan
On Sun, Feb 07, 2021 at 12:40:33PM +0100, Vincent Legoll wrote:
Toggle quote (7 lines)
> * gnu/packages/pdf.scm (xpdf): Update to 4.03.
> (source): Use a "dl.xpdfreader.com" URL.
> (build-system): Use cmake-build-system.
> (arguments): Remove #:parallel-build?, #:configure-flags and #:phases
> (inputs): Add cups, freetype & qtbase, remove gs-fonts, lesstif, libpaper
> libx11, libxext, libxp, libxpm & libxt.

Thank you for taking care of this complicated update!

I tweaked the commit message and pushed as
35089dca4053bf5888441d1648086cdadb6eb1e4

I made the commit message like this:

------
gnu: Xpdf: Update to 4.03.

* gnu/packages/pdf.scm (xpdf): Update to 4.03.
[source]: Update URL.
[build-system]: Use cmake-build-system.
[arguments]: Remove #:parallel-build?, #:configure-flags and #:phases.
[inputs]: Add cups, freetype & qtbase. Remove gs-fonts, lesstif, libpaper
libx11, libxext, libxp, libxpm & libxt.
------

The important difference is the use of () and [].

Basically, when we make changes to variables and functions — things that
are explicitly defined or exported — we put their names (parentheses).

Then, we describe changes to their components or fields in [brackets].

Does that make sense? I would have tweaked the commit message for your
vorbis-tools commit but I didn't notice the "(source)".

The general format, GNU ChangeLog, is described here:

Closed
Vincent Legoll wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 46357-done@debbugs.gnu.org)
CAEwRq=on8zDmy_v9edFQR43bZgje=skSjfvWhTp57TZUFfJAiw@mail.gmail.com
Hello Leo,

Thanks for taking care of this.

On Tue, Feb 9, 2021 at 9:45 PM Leo Famulari <leo@famulari.name> wrote:
Toggle quote (9 lines)
> The important difference is the use of () and [].
>
> Basically, when we make changes to variables and functions — things that
> are explicitly defined or exported — we put their names (parentheses).
>
> Then, we describe changes to their components or fields in [brackets].
>
> Does that make sense?

Yes

Toggle quote (4 lines)
> The general format, GNU ChangeLog, is described here:
>
> https://www.gnu.org/prep/standards/html_node/Change-Logs.html

I read it once, but I need to get better at actually doing it.

Cheers

--
Vincent Legoll
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46357@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46357
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help