[PATCH] gnu: Add gnome-recipes.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210206101130.2499-1-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (gnome-recipes): New variable.
---
gnu/packages/gnome.scm | 61 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 60 insertions(+), 1 deletion(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0f0b7c8157..e9da4e66d7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2019, 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
-;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2020, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
@@ -794,6 +794,65 @@ patterns.")
license:lgpl2.1+
license:gpl2+))))
+(define-public gnome-recipes
+ (package
+ (name "gnome-recipes")
+ (version "2.0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/recipes")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h049mzqnlcfqwrhmzbq3pzzdglvy2bn9fj1p8wql7a60pn8sr32"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'unpack 'unpack-libgd
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libgd (assoc-ref inputs "libgd")))
+ (copy-recursively libgd "subprojects/libgd")
+ #t))))))
+ (inputs
+ `(("glib" ,glib)
+ ("gnome-autoar" ,gnome-autoar)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libcanberra" ,libcanberra)
+ ("libsoup" ,libsoup)
+ ("rest" ,rest)))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("itstool" ,itstool)
+ ("libgd"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libgd")
+ (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
+ (file-name (git-file-name "libgd" version))
+ (sha256
+ (base32 "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs"))))
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://wiki.gnome.org/Apps/Recipes")
+ (synopsis "Recipes for preparing food")
+ (description "GNOME Recipes helps you discover what to cook today,
+tomorrow, the rest of the week and for special occasions.")
+ (license license:gpl3+)))
+
(define-public gnome-photos
(package
(name "gnome-photos")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46340@debbugs.gnu.org)
87a6sgus2t.fsf@nicolasgoaziou.fr
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (gnome-recipes): New variable.

Thanks.

Toggle quote (10 lines)
> + ("libgd"
> + ,(origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.gnome.org/GNOME/libgd")
> + (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
> + (file-name (git-file-name "libgd" version))
> + (sha256
> + (base32 "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs"))))

Do you know why we cannot use gd package from Guix? If so, it could be
useful to add a comment about it.

Toggle quote (4 lines)
> + ("pkg-config" ,pkg-config)))
> + (home-page "https://wiki.gnome.org/Apps/Recipes")
> + (synopsis "Recipes for preparing food")

Maybe "Discover recipes for preparing food"

Otherwise LGTM!

Regards,
--
Nicolas Goaziou
Leo Prikler wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46340@debbugs.gnu.org)
95c769c5af07a814d6fce2883cd60d038ad60007.camel@student.tugraz.at
Hello,

Am Sonntag, den 07.02.2021, 10:48 +0100 schrieb Nicolas Goaziou:
Toggle quote (15 lines)
> > + ("libgd"
> > + ,(origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://gitlab.gnome.org/GNOME/libgd")
> > + (commit
> > "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
> > + (file-name (git-file-name "libgd" version))
> > + (sha256
> > + (base32
> > "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs"))))
>
> Do you know why we cannot use gd package from Guix? If so, it could
> be
> useful to add a comment about it.
Those are two different projects. It might perhaps be worth packaging
GNOME's libgd inside gnome.scm, but there seems to be no public
release.
Other than that, I merely copied the snippet from gedit, which also has
it as a subproject.

Toggle quote (5 lines)
> > + ("pkg-config" ,pkg-config)))
> > + (home-page "https://wiki.gnome.org/Apps/Recipes")
> > + (synopsis "Recipes for preparing food")
>
> Maybe "Discover recipes for preparing food"
Good hint. Should I push this with that change or should I do
something about libgd first?

Regards,
Leo
Nicolas Goaziou wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46340@debbugs.gnu.org)
874kimfjtc.fsf@nicolasgoaziou.fr
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (6 lines)
> Those are two different projects. It might perhaps be worth packaging
> GNOME's libgd inside gnome.scm, but there seems to be no public
> release.
> Other than that, I merely copied the snippet from gedit, which also has
> it as a subproject.

Ah OK. Thanks for the information.

Toggle quote (3 lines)
> Good hint. Should I push this with that change or should I do
> something about libgd first?

I think pushing that change is fine. The libgd case can be handled
later, assuming there is anything to do.

Regards,
--
Nicolas Goaziou
Leo Prikler wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46340-done@debbugs.gnu.org)
c4eef2a89750d088a1c0a3023ca00e352da500e9.camel@student.tugraz.at
Hello,

Am Montag, den 08.02.2021, 20:20 +0100 schrieb Nicolas Goaziou:
Toggle quote (5 lines)
> > Good hint. Should I push this with that change or should I do
> > something about libgd first?
>
> I think pushing that change is fine. The libgd case can be handled
> later, assuming there is anything to do.
Aaaaand it's done. Thanks as always for the review 🙂

Leo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help