(address . guix-patches@gnu.org)
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 11f83352cfcf56dbbc94ac3e3d709591552e266c Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 5 Feb 2021 09:23:22 +0000
Subject: [PATCH] gnu: semantic_version: Update to 2.8.5
* gnu/packages/python-xyz.scm (python-semantic-version)
[arguments] tests are present in the latest version, enable them
---
gnu/packages/python-xyz.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
Toggle diff (26 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e296e3c6e1..4e2ffedbc3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1080,17 +1080,15 @@ inter-process communication.")
(define-public python-semantic-version
(package
(name "python-semantic-version")
- (version "2.6.0")
+ (version "2.8.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "semantic_version" version))
(sha256
(base32
- "1h2l9xyg1zzsda6kjcmfcgycbvrafwci283vcr1v5sbk01l2hhra"))))
+ "0m4avx8zdkzc7qglv5zlr54g8yna5vl098drg5396ql7aph2vjyj"))))
(build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; PyPI tarball lacks tests
(home-page "https://github.com/rbarrois/python-semanticversion")
(synopsis "Semantic versioning module for Python")
(description
--
2.30.0