[PATCH] gnu: Add chiaki.

  • Open
  • quality assurance status badge
Details
2 participants
  • Léo Le Bouter
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Léo Le Bouter
Severity
normal
L
L
Léo Le Bouter wrote on 5 Feb 2021 04:17
(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
20210205031731.27620-1-lle-bout@zaclys.net
* gnu/packages/games.scm (chiaki): New variable.
---
gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e3e18bf09e..3d6ba05a39 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12178,3 +12178,42 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public chiaki
+ (package
+ (name "chiaki")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~thestr4ng3r/chiaki")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kjaahv80p040wicj1a4ac1j2zsg0dbbf60a9aapn45qlkq80h2n"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("python" ,python)
+ ("protobuf" ,protobuf)
+ ("pkg-config" ,pkg-config)
+ ("python-protobuf" ,python-protobuf)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("opus" ,opus)
+ ("openssl" ,openssl)
+ ("libevdev" ,libevdev)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("sdl2" ,sdl2)))
+ (home-page "https://git.sr.ht/~thestr4ng3r/chiaki")
+ (synopsis "Free and Open Source PlayStation Remote Play Client")
+ (description "Chiaki is a Free and Open Source Software Client for
+PlayStation 4 and PlayStation 5 Remote Play.")
+ (license
+ (license:fsdg-compatible
+ "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
+ "AGPL-3.0-only-OpenSSL"))))
--
2.30.0
N
N
Nicolas Goaziou wrote on 7 Feb 2021 10:43
(name . Léo Le Bouter)(address . lle-bout@zaclys.net)(address . 46313@debbugs.gnu.org)
87eehsusaa.fsf@nicolasgoaziou.fr
Hello,

Léo Le Bouter via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (chiaki): New variable.

Thank you. Some comments follow.

Toggle quote (2 lines)
> + (recursive? #t)))

Do you know what sub-modules are being pulled? Could we unbundle them
instead?

Toggle quote (2 lines)
> + (synopsis "Free and Open Source PlayStation Remote Play Client")

Please remove "Free" and "Open Source": everything is in Guix. Also,
synopsis should not use titlecase:

"PlayStation Remote Play client"

Toggle quote (3 lines)
> + (description "Chiaki is a Free and Open Source Software Client for
> +PlayStation 4 and PlayStation 5 Remote Play.")

See above. Also, couldyou expound a bit the description?

Toggle quote (3 lines)
> + (license
> + (license:fsdg-compatible

It should be fsf-free instead of fsdg-compatible.

Toggle quote (3 lines)
> + "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
> + "AGPL-3.0-only-OpenSSL"))))

I think the correct string would be "AGPL-3.0 WITH OpenSSL exception"
but I wonder if Guix cares about the exception.

Could you send an updated patch?


Regards,
--
Nicolas Goaziou
L
L
Léo Le Bouter wrote on 7 Feb 2021 17:57
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46313@debbugs.gnu.org)
94473bccc8667f30694bd17a6cdf99eac0ca145b.camel@zaclys.net
On Sun, 2021-02-07 at 10:43 +0100, Nicolas Goaziou wrote:
Toggle quote (2 lines)
> Hello,

Hello!

Toggle quote (12 lines)
>
> Léo Le Bouter via Guix-patches via <guix-patches@gnu.org> writes:
>
> > * gnu/packages/games.scm (chiaki): New variable.
>
> Thank you. Some comments follow.
>
> > + (recursive? #t)))
>
> Do you know what sub-modules are being pulled? Could we unbundle them
> instead?

There is gf-complete, jerasure and nanopb. Will have to look for
unbundling.

Toggle quote (16 lines)
>
> > + (synopsis "Free and Open Source PlayStation Remote Play
> > Client")
>
> Please remove "Free" and "Open Source": everything is in Guix. Also,
> synopsis should not use titlecase:
>
> "PlayStation Remote Play client"
>
> > + (description "Chiaki is a Free and Open Source Software Client
> > for
> > +PlayStation 4 and PlayStation 5 Remote Play.")
>
> See above. Also, couldyou expound a bit the description?
>

Okay, merely copied the synopsis and description from the original
project.

Toggle quote (9 lines)
> > + (license
> > + (license:fsdg-compatible
>
> It should be fsf-free instead of fsdg-compatible.
>
> > + "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
> > + "AGPL-3.0-only-OpenSSL"))))
>

The thing is, the FSF does not approve that particular variant of the
license with OpenSSL exception so that's why I only specified it is
compatible.

Toggle quote (6 lines)
> I think the correct string would be "AGPL-3.0 WITH OpenSSL exception"
> but I wonder if Guix cares about the exception.
>
> Could you send an updated patch?
>

ASAP.

Toggle quote (3 lines)
>
> Regards,

Thank you.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEFIvLi9gL+xax3g6RRaix6GvNEKYFAmAgG+cACgkQRaix6GvN
EKY1mBAAiA3GrBlDUM9IJEg+T7VAxn0cQfBxlvBq681srVi8pZaSM15vZe9R5bjw
/4uJYrdv2Qu6ZVv3FGqLVvKD6aQL7Rp397GUpmJDBjaHZDCUds1NerZcbmJ3Cvof
P2j0g/HqZK8GrtFbopk1XCDIsdzOxD6cW9FAcZgt4NbN9i4M7sNLy4RIV390gdc0
ierIiUDEu2DdTwMcdYAH3Bf/8Vhvrfif9dQ1XGwOduqvO/XDQkeF615zCbauc0pl
ah9kon7ntc1NqAJLMwQuAAiHTeYwoV31EsJD7P6FGZYIstRcR2EHM/f+ueE/+Fwp
XCOCV95VT0XgNW2a1SVKGzWARNDiuMwN7TmJx2twMB8D5z4swjN7veGlCQPKNiHf
eMgOXTcdPOJApkeACn0CNir9k+X+qAJbaMrHnqAxl0eErZH3oH+E7ArO9x7vpKmE
d5zmXzAHeVqfpTZtslBVg78dI3CW/tMmhMsXuz29Q4qbq6TNKAUBACQfHfmfWYtD
IUBkky7qvN9X6UjEeY6H11JZFOhw1hPThGhMWX3sM3fD10JgbiaLrqEFYK8YsxeN
gk8eZ3mj4tvOHPwBA6GOgeAh2wNNmP+2xWqWm8IZQ3tv4ucw7nRYuuABbDCrbjVj
be8Vju0yGty5AbCex6w+fRZ96UQi194WlIE0EDzcXfOy5KtmESk=
=OuDn
-----END PGP SIGNATURE-----


?