(address . guix-patches@gnu.org)(name . Léo Le Bouter)(address . lle-bout@zaclys.net)
* gnu/packages/games.scm (chiaki): New variable.
---
gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e3e18bf09e..3d6ba05a39 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12178,3 +12178,42 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public chiaki
+ (package
+ (name "chiaki")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~thestr4ng3r/chiaki")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kjaahv80p040wicj1a4ac1j2zsg0dbbf60a9aapn45qlkq80h2n"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("python" ,python)
+ ("protobuf" ,protobuf)
+ ("pkg-config" ,pkg-config)
+ ("python-protobuf" ,python-protobuf)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("opus" ,opus)
+ ("openssl" ,openssl)
+ ("libevdev" ,libevdev)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("sdl2" ,sdl2)))
+ (home-page "https://git.sr.ht/~thestr4ng3r/chiaki")
+ (synopsis "Free and Open Source PlayStation Remote Play Client")
+ (description "Chiaki is a Free and Open Source Software Client for
+PlayStation 4 and PlayStation 5 Remote Play.")
+ (license
+ (license:fsdg-compatible
+ "file://LICENSES/AGPL-3.0-only-OpenSSL.txt"
+ "AGPL-3.0-only-OpenSSL"))))
--
2.30.0