[PATCH] gnu: Add cockatrice.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210204233352.24166-1-leo.prikler@student.tugraz.at
* gnu/packages/games.scm (cockatrice): New variable.
---
gnu/packages/games.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e3e18bf09e..953fd317ed 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -857,6 +857,52 @@ things far stranger and deadlier, and against the others like yourself, that
want what you have.")
(license license:cc-by-sa3.0)))
+(define-public cockatrice
+ (let ((release-date "2021-01-26"))
+ (package
+ (name "cockatrice")
+ (version "2.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cockatrice/Cockatrice")
+ (commit (string-append release-date "-Release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q8ffcklb2b7hcqhy3d2f9kz9aw22pp04pc9y4sslyqmf17pwnz9"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Strip image URLs as they point towards non-free web services
+ '(substitute* "cockatrice/src/settings/downloadsettings.cpp"
+ (("downloadURLs.append\\(\".*\"\\);") "")))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DWITH_SERVER=1"
+ "-DWITH_CLIENT=1"
+ "-DWITH_ORACLE=1"
+ "-DTEST=1")))
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("protobuf" ,protobuf)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
+ ("qtwebsockets" ,qtwebsockets)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (home-page "https://cockatrice.github.io")
+ (synopsis "Tabletop card game simulator")
+ (description "Cockatrice is an open-source, multiplatform program for
+playing tabletop card games over a network. The program's server design
+prevents users from manipulating the game for unfair advantage. The client
+also provides a single-player mode, which allows users to brew while offline.")
+ (license license:gpl2))))
+
(define-public corsix-th
(package
(name "corsix-th")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46311@debbugs.gnu.org)
87r1luedk4.fsf@nicolasgoaziou.fr
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (3 lines)
> + (description "Cockatrice is an open-source, multiplatform program for
> +playing tabletop card games over a network.

I suggest to remove "open-source" and "multiplatform" from the
description.

Otherwise, LGTM!

Regards,
--
Nicolas Goaziou
Leo Prikler wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46311-done@debbugs.gnu.org)
eb59dbee0dbc7d9dcce2da1406eb649c01aec7ac.camel@student.tugraz.at
Hello,

Am Freitag, den 05.02.2021, 16:31 +0100 schrieb Nicolas Goaziou:
Toggle quote (4 lines)
> I suggest to remove "open-source" and "multiplatform" from the
> description.
>
> Otherwise, LGTM!
Changed and pushed. Thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46311@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46311
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help