[PATCH] gnu: zeal: Update to 0.6.1-1.d3c5521.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210204225426.20206-1-mike@rohleder.de
* gnu/packages/documentation.scm (zeal): Update to 0.6.1-1.d3c5521.
[arguments]: Add phase wrap-qt-process-path.
[inputs]: Add qtwebengine, qtwebchannel, qtdeclarative, qtquickcontrols. Remove qtwebkit.
[home-page]: Changed to https://zealdocs.org/.
---
Zeal doesn't build with qt 5.15 (staging merge) for some reasons.
This patch upgrades to newest upstream commit (and change the inputs accordingly),
which fixes this.

gnu/packages/documentation.scm | 76 +++++++++++++++++++++-------------
1 file changed, 47 insertions(+), 29 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 0fca0b11eb..eb3227ca63 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -313,32 +313,50 @@ local system.")
(license lgpl2.1+)))
(define-public zeal
- (package
- (name "zeal")
- (version "0.6.1")
- (home-page "https://github.com/zealdocs/zeal")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "05qcjpibakv4ibhxgl5ajbkby3w7bkxsv3nfv2a0kppi1z0f8n8v"))))
- (build-system qt-build-system)
- (arguments `(#:tests? #f)) ; no tests
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("libarchive" ,libarchive)
- ("sqlite" ,sqlite)
- ("qtbase" ,qtbase)
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("xcb-util-keyms" ,xcb-util-keysyms)))
- (synopsis "Offline documentation browser inspired by Dash")
- (description "Zeal is a simple offline documentation browser
+ (let ((commit "d3c5521c501d24050f578348ff1b9d68244b992c")
+ (revision "1"))
+ (package
+ (name "zeal")
+ (version (git-version "0.6.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zealdocs/zeal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ky2qi2cmjckc51lm3i28815ixgqdm36j7smixxr16jxpmbqs6sl"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'wrap 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/zeal"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libarchive" ,libarchive)
+ ("sqlite" ,sqlite)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("qtx11extras" ,qtx11extras)
+ ("xcb-util-keyms" ,xcb-util-keysyms)))
+ (home-page "https://zealdocs.org/")
+ (synopsis "Offline documentation browser inspired by Dash")
+ (description "Zeal is a simple offline documentation browser
inspired by Dash.")
- (license gpl3+)))
+ (license gpl3+))))
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 46307-done@debbugs.gnu.org)
87czxeeb7g.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (9 lines)
> * gnu/packages/documentation.scm (zeal): Update to 0.6.1-1.d3c5521.
> [arguments]: Add phase wrap-qt-process-path.
> [inputs]: Add qtwebengine, qtwebchannel, qtdeclarative, qtquickcontrols. Remove qtwebkit.
> [home-page]: Changed to https://zealdocs.org/.
> ---
> Zeal doesn't build with qt 5.15 (staging merge) for some reasons.
> This patch upgrades to newest upstream commit (and change the inputs accordingly),
> which fixes this.

Applied. Thank you

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46307@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46307
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help