[PATCH 2/2] On the way of packing ViralityEngine

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5rLDq5gKJKRO=p5=NXcxsxKGY9hu8oxMyHths_Q=8o5cQ@mail.gmail.com
Hi Guix team!
Other series of patches which adds: origin and specialization-store
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 0c4b5326b8e919734ee3f6a66aba51596749570c Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 4 Feb 2021 01:32:23 +0000
Subject: [PATCH 1/2] gnu: Add specialization-store

* gnu/packages/lisp-xyz.scm
(specialization-store, cl-specialization-store,
ecl-specialization-store): New variables
---
gnu/packages/lisp-xyz.scm | 44 +++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bc607f2e54..5cf066af0f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6693,6 +6693,50 @@ ability to store all Common Lisp data types into streams.")
(define-public ecl-cl-store
(sbcl-package->ecl-package sbcl-cl-store))
+(define-public sbcl-specialization-store
+ (let ((commit "8d39a866a6f24986aad3cc52349e9cb2653496f3")
+ (revision "1"))
+ (package
+ (name "sbcl-specialization-store")
+ (version (git-version "0.0.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markcox80/specialization-store")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r0bgb46q4gy72l78s7djkxq8ibb4bb3yh9brsry5lih7br8lhi0"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems
+ '("specialization-store"
+ "specialization-store-features")))
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("introspect-environment" ,sbcl-introspect-environment)))
+ (home-page "https://github.com/markcox80/specialization-store")
+ (synopsis "Different type of generic function for Common Lisp")
+ (description
+ "SPECIALIZATION-STORE system provides a new kind of function, called
+a store function, whose behavior depends on the types of objects passed to the
+function.
+
+ This package provides 2 systems: @code{SPECIALIZATION-STORE}
+@code{SPECIALIZATION-STORE-FEATURES}")
+ (license license:bsd-3))))
+
+(define-public ecl-specialization-store
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-specialization-store))
+ (arguments
+ ;; TODO: Find why the tests get stuck forever; disable them for now.
+ `(#:tests? #f))))
+
+(define-public cl-specialization-store
+ (sbcl-package->cl-source-package sbcl-specialization-store))
+
(define-public sbcl-cl-gobject-introspection
(let ((commit "d0136c8d9ade2560123af1fc55bbf70d2e3db539")
(revision "1"))
--
2.30.0
From 55016b23986cf300373206bb45b0443456c41a7b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 4 Feb 2021 01:44:11 +0000
Subject: [PATCH 2/2] gnu: Add origin

* gnu/packages/lisp-xyz.scm (sbcl-origin, cl-origin, ecl-oring): New variables
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5cf066af0f..cecf29b207 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8761,6 +8761,43 @@ respectively.")
(define-public ecl-salza2
(sbcl-package->ecl-package sbcl-salza2))
+(define-public sbcl-origin
+ (let ((commit "d646134302456408d6d43580bb05299f1695ab8e")
+ (revision "1"))
+ (package
+ (name "sbcl-origin")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.mfiano.net/mfiano/origin")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n9aszaif3yh8prs5r8v51fbj4r5jd1a048mivd5yij3hplkm82b"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)))
+ (inputs
+ `(("golden-utils" ,sbcl-golden-utils)
+ ("specialization-store" ,sbcl-specialization-store)))
+ (home-page "https://git.mfiano.net/mfiano/origin")
+ (synopsis "Common Lisp graphics math library")
+ (description
+ "A native Common Lisp graphics math library with an emphasis on
+performance and correctness.
+
+This package provides 1 system: @code{ORIGIN}")
+ (license license:expat))))
+
+;; Time consumption build process on ECL 10min+
+(define-public ecl-origin
+ (sbcl-package->ecl-package sbcl-origin))
+
+(define-public cl-origin
+ (sbcl-package->cl-source-package sbcl-origin))
+
(define-public sbcl-png-read
(let ((commit "ec29f38a689972b9f1373f13bbbcd6b05deada88")
(revision "1"))
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46281-done@debbugs.gnu.org)
87lfc46jjv.fsf@yamatai
Patches pushed as 68608dd412c49a3372567b2d43633d9c7161ecbb and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBv4hA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+biQD/df4ZsMTEG15fIG9vQJGUOVQsXImcXuHVXq31
3ly7cWQA/1KwLHsDNNpkK4csLRoVYCj3+J7CmFm8qn7zJ9LHe1Yf
=R2sL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46281@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46281
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help