[PATCH] Update parse-float to 0.0.0-2.3074765

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5rQugq3jc1AvEdaB30r9fny-7t3xD0W1mtrwoEY8k1TUQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 4c0105c8be7f635e547fbadd93a8367086b5461d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 2 Feb 2021 00:37:36 +0000
Subject: [PATCH] gnu: parse-float: Update to 0.0.0-2.3074765

* gnu/packages/listp-xyz.scm (sbcl-parse-float)
[native-inputs] prove -> lisp-unit
[arguments] enable tests
---
gnu/packages/lisp-xyz.scm | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7cfd4b2a6b..fdcfa0fe4e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2323,10 +2323,11 @@ pattern-matching-like, but a char-by-char procedural parser.")
(sbcl-package->ecl-package sbcl-proc-parse))
(define-public sbcl-parse-float
- (let ((commit "2aae569f2a4b2eb3bfb5401a959425dcf151b09c"))
+ (let ((commit "3074765101e41222b6b624a66aaf1e6416379f9c")
+ (revision "2"))
(package
(name "sbcl-parse-float")
- (version (git-version "0.0.0" "1" commit))
+ (version (git-version "0.0.0" revision commit))
(source
(origin
(method git-fetch)
@@ -2334,23 +2335,22 @@ pattern-matching-like, but a char-by-char procedural parser.")
(url "https://github.com/soemraws/parse-float")
(commit commit)))
(sha256
- (base32
- "08xw8cchhmqcc0byng69m3f5a2izc9y2290jzz2k0qrbibp1fdk7"))
+ (base32 "0jd2spawc3v8vzqf8ky4cngl45jm65fhkrdf20mf6dcbn3mzpkmr"))
(file-name (git-file-name "proc-parse" version))))
(build-system asdf-build-system/sbcl)
+ (arguments
+ ;; FIXME: https://github.com/soemraws/parse-float/issues/12
+ `(#:asd-systems '("parse-float" "parse-float-tests")))
+ (native-inputs
+ `(("lisp-unit" ,sbcl-lisp-unit)))
(inputs
`(("alexandria" ,sbcl-alexandria)
("babel" ,sbcl-babel)))
- (native-inputs
- `(("prove" ,sbcl-prove)))
- (arguments
- ;; TODO: Tests don't find "proc-parse-test", why?
- `(#:tests? #f))
+ (home-page "https://github.com/soemraws/parse-float")
(synopsis "Parse a floating point value from a string in Common Lisp")
(description
"This package exports the following function to parse floating-point
values from a string in Common Lisp.")
- (home-page "https://github.com/soemraws/parse-float")
(license license:public-domain))))
(define-public cl-parse-float
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46251-done@debbugs.gnu.org)
87im7a955l.fsf@yamatai
I removed the babel input which was not used anymore and pushed the
patch as 65454c1caa60c8f07833aa920648188ab6bbca85.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBkepg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j914gD8CoVd3GrLCSFav1cFpJ510oF63SlILTpNyXsd
sYK5BSsA/Rt953qz4zRblqSdlN4ETjxuDwJZW+K5Do82JF+A5yAL
=Rs7z
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46251@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46251
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help