[PATCH 0/2] Update python-xlib and plover

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
87o8h3fsiv.fsf@cbaines.net
Christopher Baines (2):
gnu: python-xlib: Update to 0.29.
gnu: plover: Update to 4.0.0.dev8.

gnu/packages/python-xyz.scm | 7 ++++---
gnu/packages/stenography.scm | 28 +++++++++++++++-------------
2 files changed, 19 insertions(+), 16 deletions(-)
Christopher Baines wrote 4 years ago
[PATCH 1/2] gnu: python-xlib: Update to 0.29.
(address . 46245@debbugs.gnu.org)
20210201202458.30619-1-mail@cbaines.net
Make python-six a propagated input as it's used at runtime.

* gnu/packages/python-xyz.scm (python-xlib): Update to 0.29.
[native-inputs]: Move python-six to…
[propagated-inputs]: …here.
---
gnu/packages/python-xyz.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5199ac4d11..5ee4120666 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8014,7 +8014,7 @@ falling into the Python interpreter.")
(define-public python-xlib
(package
(name "python-xlib")
- (version "0.27")
+ (version "0.29")
(source
(origin
(method git-fetch)
@@ -8023,7 +8023,7 @@ falling into the Python interpreter.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "09kimic8rhprx3q8nzalc4aggg42ahqm4v5qcj8dm68yvxfdk986"))))
+ (base32 "17cwd2knqm2vwrii3kqii9abwsnydhpg4byqx1vy7rjs6i1vbqfc"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -8039,8 +8039,9 @@ falling into the Python interpreter.")
(native-inputs
`(("python-mock" ,python-mock)
("python-setuptools-scm" ,python-setuptools-scm)
- ("python-six" ,python-six)
("xorg-server" ,xorg-server)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(home-page "https://github.com/python-xlib/python-xlib")
(synopsis "Python X11 client library")
(description
--
2.30.0
Christopher Baines wrote 4 years ago
[PATCH 2/2] gnu: plover: Update to 4.0.0.dev8.
(address . 46245@debbugs.gnu.org)
20210201202458.30619-2-mail@cbaines.net
This moves from Python 2 to Python 3. This is a dev release, but from nearly 2
years ago.

Backing up your plover.cfg is advised by the release notes when upgrading from
version 3 to 4.

* gnu/packages/stenography.scm (plover): Update to 4.0.0.dev8.
[arguments]: Remove.
[native-inputs]: Switch to Python 3 package variants.
[inputs]: Switch to Python 3 package variants, and add python-pyqt.
---
gnu/packages/stenography.scm | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index c462deacfa..979b2c29ef 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages check)
#:use-module (gnu packages libusb)
#:use-module (gnu packages python)
@@ -31,7 +33,7 @@
(define-public plover
(package
(name "plover")
- (version "3.1.1")
+ (version "4.0.0.dev8")
(source
(origin
(method git-fetch)
@@ -40,21 +42,21 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "114rlxvq471fyifwcdcgdad79ak7q3w2lk8z9nqhz1i9fg05721c"))))
+ (base32 "1b2ys77bkjsdmyg97i7lq3lj45q56bycvsm06d4rs656kxhvc0a3"))))
(build-system python-build-system)
- (arguments
- `(#:python ,python-2))
(native-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-pytest" ,python2-pytest)
- ("python2-setuptools-scm" ,python2-setuptools-scm)))
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(inputs
- `(("python2-appdirs" ,python2-appdirs)
- ("python2-dbus" ,python2-dbus)
- ("python2-hidapi" ,python2-hidapi)
- ("python2-pyserial" ,python2-pyserial)
- ("python2-wxpython" ,python2-wxpython)
- ("python2-xlib" ,python2-xlib)))
+ `(("python-appdirs" ,python-appdirs)
+ ("python-pyqt" ,python-pyqt)
+ ("python-babel" ,python-babel)
+ ("python-dbus" ,python-dbus)
+ ("python-hidapi" ,python-hidapi)
+ ("python-pyserial" ,python-pyserial)
+ ("python-wxpython" ,python-wxpython)
+ ("python-xlib" ,python-xlib)))
(home-page "https://www.openstenoproject.org/plover/")
(synopsis "Stenography engine")
(description
--
2.30.0
Nicolas Goaziou wrote 4 years ago
Re: [bug#46245] [PATCH 0/2] Update python-xlib and plover
(name . Christopher Baines)(address . mail@cbaines.net)(address . 46245@debbugs.gnu.org)
87ft2edguf.fsf@nicolasgoaziou.fr
Hello,

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (4 lines)
> Christopher Baines (2):
> gnu: python-xlib: Update to 0.29.
> gnu: plover: Update to 4.0.0.dev8.

LGTM!

Thank you.

Regards,
--
Nicolas Goaziou
Christopher Baines wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 46245-done@debbugs.gnu.org)
87im7az2hc.fsf@cbaines.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (10 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> writes:
>
>> Christopher Baines (2):
>> gnu: python-xlib: Update to 0.29.
>> gnu: plover: Update to 4.0.0.dev8.
>
> LGTM!

Great, I've pushed this to master now as
5fc40f747873500adb268304156ada8823dc2358.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmAZqbBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe/IRAAiAkQWHU75BkSg0Q/e0rDNl/4wKsAHjg5
i8cOH5PHjzKHE7DuFpHpby7nm2WzciDA+af1yIl8oTJYGoEgoVvNsm4wmiEMFbWo
C24OvwYkz8DBefjODJk5pWn4XtHj8hH18kxOSTgpXeiSkxnntaPaCifhVxxcF39Y
lJ1rlBeCEXEadkokXavtT8OdB3cMUGMoKrVIkprS49+dWX5/YfbVswEYb+7vusku
2ri7Q6W/73htyeWZeQh5otkLOm54iSFkI8XkeRIeNssbqajlYpZVD3EignIXNTf7
f9yUjC4jBgV0TVCWCTXr9TGWjBj9P/MfmciyXKysegeyzVTkYK9vuk/SYnyKO0bw
PX4lSSEKV/1qP/XYi3tyBXDw3OTkbQbhHGDD1i66ePALfCW5rdhnsIlGn5RRhmgZ
129hkiBsk+dqqwGtaq37fbtBcoXJRqmnWq1tg9buAXlF9ECPH8ofrEp5/C5aPN6e
R72u7hdrTscap7mkRVEBK6BNRmgKQ00acpE9rd9bWMFaVkRZYX7eoVTnVJfh/kMh
YPC6m564cntPGCrPIy84S8Tkq+Km81FbjJag3YqitDJSrVz2inMN/wZ/6dIElyg1
NnIwKkDaO+hvXpQcLZkJK6lSmisayGuMx3u2secqfqtl+VpxXOnOcOV9etDZk4/p
0qYG96EYtjs=
=9NwI
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46245@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46245
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help