[PATCH 4/4] Updade deploy, new cl-mpg123 verbose piping

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5pn7PU-Wt9QZFdupbRxBwy8Vk0OfPwMOxyg5yZVfgJybQ@mail.gmail.com
Hi Guix team!
Here is the last set of patches of Radiance dependencies
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 31a01aa41e231b18d8e2fd7c9785f12ab00fb87e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 31 Jan 2021 01:43:40 +0000
Subject: [PATCH 4/4] gnu: Add cl-mpg123

* gnu/packages/lisp-xyz.scm
(sbcl-cl-mpg123, cl-mpg123, ecl-cl-mpg123): New variables
---
gnu/packages/lisp-xyz.scm | 57 +++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6403a94ebe..04d8ca1de0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10528,6 +10528,63 @@ online linear classification written in Common Lisp.")
(define-public ecl-cl-online-learning
(sbcl-package->ecl-package sbcl-cl-online-learning))
+(define-public sbcl-cl-mpg123
+ (let ((commit "5f042c839d2ea4a2ff2a7b60c839d8633d64161d")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-mpg123")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/cl-mpg123")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hl721xaczxck008ax2y3jpkm509ry1sg3lklh2k76764m3ndrjf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled pre-compiled libraries.
+ (delete-file-recursively "static")
+ #t))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-files '("cl-mpg123.asd" "cl-mpg123-example.asd")
+ #:asd-systems '("cl-mpg123" "cl-mpg123-example")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "low-level.lisp"
+ (("libmpg123.so" all)
+ (string-append (assoc-ref inputs "libmpg123")
+ "/lib/" all))))))))
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("cl-out123" ,sbcl-cl-out123)
+ ("documentation-utils" ,sbcl-documentation-utils)
+ ("libmpg123" ,mpg123)
+ ("trivial-features" ,sbcl-trivial-features)
+ ("trivial-garbage" ,sbcl-trivial-garbage)
+ ("verbose" ,sbcl-verbose)))
+ (home-page "https://shirakumo.github.io/cl-mpg123/")
+ (synopsis "Bindings to libmpg123, allowing fast MPG1/2/3 decoding")
+ (description
+ "This is a bindings and wrapper library to @code{libmpg123} allowing for
+convenient, extensive, and fast decoding of MPEG1/2/3 (most prominently mp3)
+files.
+
+This package produces 2 systems: @code{CL-MPG123} @code{CL-MPG123-EXAMPLE}")
+ (license license:zlib))))
+
+(define-public ecl-cl-mpg123
+ (sbcl-package->ecl-package sbcl-cl-mpg123))
+
+(define-public cl-mpg123
+ (sbcl-package->cl-source-package sbcl-cl-mpg123))
+
(define-public sbcl-cl-out123
(let ((commit "6b58d3f8c2a28ad09059ac4c60fb3c781b9b421b")
(revision "1"))
--
2.30.0
From 00624008d382509d2e144b9dff51184d2d3f081e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 31 Jan 2021 01:41:35 +0000
Subject: [PATCH 3/4] gnu: Add verbose

* gnu/packages/lisp-xyz.scm (sbcl-verbose, cl-verbose, ecl-verbose): New variables
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c32b285a2a..6403a94ebe 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4704,6 +4704,43 @@ various levels and mix text with expressions.")
(define-public ecl-log4cl
(sbcl-package->ecl-package sbcl-log4cl))
+(define-public sbcl-verbose
+ (let ((commit "c5b7ecd465be61b35af17ef57564697b88397174")
+ (revision "1"))
+ (package
+ (name "sbcl-verbose")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/verbose/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r51ydj5v7afi2jrlscbhxprv13d9vzg5316g1yzwaxc1kzsdsw6"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("piping" ,sbcl-piping)
+ ("local-time" ,sbcl-local-time)
+ ("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("dissect" ,sbcl-dissect)
+ ("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/verbose/")
+ (synopsis "Logging framework using the piping library")
+ (description
+ "A Common Lisp library providing logging faciltiy similar to
+@code{CL-LOG}, @code{LOG4CL}.
+
+This package produces 1 system: @code{VERBOSE}")
+ (license license:zlib))))
+
+(define-public ecl-verbose
+ (sbcl-package->ecl-package sbcl-verbose))
+
+(define-public cl-verbose
+ (sbcl-package->cl-source-package sbcl-verbose))
+
(define-public sbcl-find-port
(let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
(revision "1"))
--
2.30.0
From 31ea489d0fd8a34d3a1c4235491897bc23cb549e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 31 Jan 2021 01:39:25 +0000
Subject: [PATCH 2/4] gnu: Add piping

* gnu/packages/lisp-xyz.scm (sbcl-piping, cl-piping, ecl-piping): New variables
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cd436b7b12..c32b285a2a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1323,6 +1323,36 @@ and macros, primarily for software projects written in CL by the author.")
(define-public ecl-jpl-util
(sbcl-package->ecl-package sbcl-jpl-util))
+(define-public sbcl-piping
+ (let ((commit "c7a4163c00dea7e72bf6ad33d6abac0d5826a656")
+ (revision "1"))
+ (package
+ (name "sbcl-piping")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/piping/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0in84qnfkynm36d4n4d6v87vprpi27xrydnga462wfhplji6klv5"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://shinmera.github.io/piping/")
+ (synopsis "Library to enable simple message pipelines")
+ (description
+ "A Common Lisp library to enable simple message pipelines.
+
+This package produces 1 system: @code{PIPING}")
+ (license license:zlib))))
+
+(define-public ecl-piping
+ (sbcl-package->ecl-package sbcl-piping))
+
+(define-public cl-piping
+ (sbcl-package->cl-source-package sbcl-piping))
+
(define-public sbcl-jpl-queues
(package
(name "sbcl-jpl-queues")
--
2.30.0
From f2ce59a6ea20434b6a95c5cfb2a24f0af1c4a127 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 31 Jan 2021 01:34:40 +0000
Subject: [PATCH 1/4] gnu: Update deploy to the latest commit

* gnu/packages/lisp-xyz.scm (sbcl-deploy)
[commit] Update to the latest
[revision] 1 -> 2
[inputs] Add cl-mpg123, cl-out123, trivial-features
---
gnu/packages/lisp-xyz.scm | 19 ++++++++++++-------
1 file changed, 12 insertions(+), 7 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 83a406c038..cd436b7b12 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12271,9 +12271,8 @@ predictable cross-platform behavior and some utilities useful for versioning.")
(sbcl-package->ecl-package sbcl-defpackage-plus))
(define-public sbcl-deploy
- ;; tagged branch is outdated
- (let ((revision "1")
- (commit "59fd49719ef651a8fc11750bcfb337f132cff75f"))
+ (let ((commit "9b20e64fe924b9e31832304d87a3a72c383dc6d8")
+ (revision "2"))
(package
(name "sbcl-deploy")
(version (git-version "1.0.0" revision commit))
@@ -12285,13 +12284,19 @@ predictable cross-platform behavior and some utilities useful for versioning.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1vl2116z4kw2pd3qd3n6mmg8g0mnwxr9dgddk86g7j1bis1z8k9a"))))
+ (base32 "07pfkibaridihg8lbq2czwa4iqifqk24n6rx7bfnv7i49p1ppja1"))))
(build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:test-asd-file "deploy-test.asd"
+ #:asd-files
+ '("deploy.asd"
+ "deploy-test.asd")))
(inputs
`(("cffi" ,sbcl-cffi)
- ("documentation-utils" ,sbcl-documentation-utils)))
- (arguments
- '(#:asd-files '("deploy.asd")))
+ ("cl-mpg123" ,sbcl-cl-mpg123)
+ ("cl-out123" ,sbcl-cl-out123)
+ ("documentation-utils" ,sbcl-documentation-utils)
+ ("trivial-features" ,sbcl-trivial-features)))
(home-page "https://shinmera.github.io/deploy/")
(synopsis "Deployment tools for standalone Common Lisp application")
(description
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46200-done@debbugs.gnu.org)
87a6spa1q6.fsf@yamatai
Patches pushed as f7174a2889130328e586cda15cf74d29aa74795c and following
with a few modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBZ5wQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9jzgD9HLaOsJUymGjYV/GuwNzagtv5GQKUYqKSBuE+
9YkF5PQA/0HuJp3mUhOWJGEyBnHjX81aw4hADf5VjVhdBCbRcrTC
=qw39
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46200@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46200
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help