[PATCH] Refactor cl-online-leraning

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oBbhYTXnWVCcWibzEoDS99mx+JXGotCLfvWLKJEZO5qQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From e2ef0372b788fc6a6f363ae23de6c62a00540b45 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 30 Jan 2021 11:08:26 +0000
Subject: [PATCH] gnu: Refactor cl-online-learning
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/lisp-xyz.scm (sbcl-cl-online-learning)
Revision 1
Bumped to the latest commit and fix test passing

(ecl-cl-online-learning) - it needs some proper attention, it throws a
long warning output during build:

...
;;;;;;;;;;;;;;;; Dence, Binary ;;;;;;;;;;;;;;;;;
;;; Read libsvm dataset
× Raised an error #<closed input stream /gnu/store/zqvp2ky4zl4rdimkjnkqqq0nrr88q2vf-ecl-cl-online-learning-0.5-1.87fbef8/share/common-lisp/ecl/cl-online-learning/t/dataset/a1a 0x7ffff47b6b40> is not a character stream
...
---
gnu/packages/lisp-xyz.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bc959502be..286639bef2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10423,8 +10423,8 @@ format.")
(sbcl-package->ecl-package sbcl-cl-libsvm-format))
(define-public sbcl-cl-online-learning
- (let ((commit "fc7a34f4f161cd1c7dd747d2ed8f698947781423")
- (revision "0"))
+ (let ((commit "87fbef8a340219e853adb3a5bf44a0470da76964")
+ (revision "1"))
(package
(name "sbcl-cl-online-learning")
(version (git-version "0.5" revision commit))
@@ -10437,7 +10437,7 @@ format.")
(file-name (git-file-name name version))
(sha256
(base32
- "14x95rlg80ay5hv645ki57pqvy12v28hz4k1w0f6bsfi2rmpxchq"))))
+ "1lfq04lnxivx59nq5dd02glyqsqzf3vdn4s9b8wnaln5fs8g2ph9"))))
(build-system asdf-build-system/sbcl)
(native-inputs
`(("prove" ,sbcl-prove)))
@@ -10445,13 +10445,16 @@ format.")
`(("cl-libsvm-format" ,sbcl-cl-libsvm-format)
("cl-store" ,sbcl-cl-store)))
(arguments
- `(;; FIXME: Tests pass but then the check phase crashes
- #:tests? #f))
+ `(#:test-asd-file "cl-online-learning-test.asd"
+ #:asd-systems
+ (list
+ "cl-online-learning-test"
+ "cl-online-learning")))
+ (home-page "https://github.com/masatoi/cl-online-learning")
(synopsis "Online Machine Learning for Common Lisp")
(description
"This library contains a collection of machine learning algorithms for
online linear classification written in Common Lisp.")
- (home-page "https://github.com/masatoi/cl-online-learning")
(license license:expat))))
(define-public cl-online-learning
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46187-done@debbugs.gnu.org)
87ft2ha1xz.fsf@yamatai
Patch pushed as e11055f0125a902fe091394480dd4206c687a98c.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBZ4qA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/HwAD/eAFmOK701pMDMtbRoCa+LdBFpSe7oyNRq386
v+IDEakA/1g6YSkxB05BhP7yJyeO7jyUQNeG2cFAcrMtzlyr1bvA
=+Ao7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46187@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46187
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help