[PATCH] Add new - stuff swarp weightwatcher

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5p2-5kg1e-pxammh+1xsEfRCPt6NYSzhT1sMh2QH6u1xg@mail.gmail.com
Hi Guix team!
3 more small programs for astronomy without dependencies.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From a7b548d5c4ca5ba6ff9fad061a50813b27d74d61 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 28 Jan 2021 21:20:37 +0000
Subject: [PATCH] gnu: Add swarp

* gnu/packages/astronomy.scm (swarp): New variable
---
gnu/packages/astronomy.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6476a18d57..aa6533a117 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -345,6 +345,25 @@ generates object lists in ASCII which can read by the SkyMaker program to produc
realistic astronomical fields. Stuff is part of the EFIGI development project.")
(license license:gpl3+)))
+(define-public swarp
+ (package
+ (name "swarp")
+ (version "2.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.astromatic.net/download/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1i670waqp54vin1cn08mqckcggm9zqd69nk7yya2vvqpdizn6jpm"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.astromatic.net/software/swarp")
+ (synopsis "Image regridding and co-addition")
+ (description
+ "SWarp is a program that resamples and co-adds together FITS images using
+any arbitrary astrometric projection defined in the WCS standard.")
+ (license license:gpl3+)))
+
(define-public celestia
(let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
(package
--
2.30.0
From e8ec4fda81d86a06cb5436f47f7c2649abb4b7e1 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 28 Jan 2021 21:09:56 +0000
Subject: [PATCH] ghu: Add weightwatcher

* gnu/packages/astronomy.scm (weightwatcher): New variable
---
gnu/packages/astronomy.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 58fefa04a0..4fce2d3530 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -150,6 +150,25 @@ coordinate systems in a @dfn{FITS} (Flexible Image Transport System) image
header.")
(license license:lgpl3+)))
+(define-public weightwatcher
+ (package
+ (name "weightwatcher")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.astromatic.net/download/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1zaqd8d9rpgcwjsp92q3lkfaa22i20gppb91dz34ym54swisjc2p"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.astromatic.net/software/weightwatcher")
+ (synopsis "Weight-map/flag-map multiplexer and rasteriser")
+ (description
+ "Weightwatcher is a program that resamples and co-adds together FITS images using
+any arbitrary astrometric projection defined in the WCS standard.")
+ (license license:gpl3+)))
+
(define-public gnuastro
(package
(name "gnuastro")
--
2.30.0
From 9123526a823831ecf4288c198f8c07c3e3ce09ea Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 28 Jan 2021 21:15:04 +0000
Subject: [PATCH] gnu: Add stuff

* gnu/packages/astronomy.scm (stuff): New variable
---
gnu/packages/astronomy.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4fce2d3530..6476a18d57 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -325,6 +325,26 @@ can be used to control telescopes over a serial port for tracking celestial
objects.")
(license license:gpl2+)))
+(define-public stuff
+ (package
+ (name "stuff")
+ (version "1.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.astromatic.net/download/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1syibi3b86z9pikhicvkkmgxm916j732fdiw0agw0lq6z13fdcjm"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.astromatic.net/software/stuff")
+ (synopsis "Catalogue simulation")
+ (description
+ "Stuff is a program that simulates \"perfect\" astronomical catalogues. It
+generates object lists in ASCII which can read by the SkyMaker program to produce
+realistic astronomical fields. Stuff is part of the EFIGI development project.")
+ (license license:gpl3+)))
+
(define-public celestia
(let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
(package
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46161-done@debbugs.gnu.org)
877dnwxcvf.fsf@yamatai
Patches pushed as c21ad767d4368dbd9ff37a6fd5cdea8aa37fec57 and following
with a few modifications on some URIs and descriptions.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBPhlA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8wpAD8C3RCS4kJwWzSXoNaqcpnbH7Q/3tN9k4ZOH2v
BmclDGQA/08Tq+/ShwxXACIdvJaNnWqehRiuUbsI9LT0xyuus8Ok
=UyTt
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46161@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46161
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help