[PATCH 0/1] gnu: pinentry-rofi: Update to 2.0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 28 Jan 2021 02:56
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20210128015659.148867-1-plattfot@posteo.net
Update pinentry-rofi to 2.0.2 and incorporate the feedback from [0], namely:

Toggle quote (7 lines)
> Since I think you’re also upstream :-), how about adding something like
> that at the top of the installed executable:
>
> (eval-when (load expand eval)
> (set! %load-path (cons "@moddir@" %load-path))
> (set! %laod-compiled-path (cons "@godir@" %load-compiled-path)))>> ?


Fredrik Salomonsson (1):
gnu: pinentry-rofi: Update to 2.0.2.

gnu/packages/gnupg.scm | 39 ++++++++-------------------------------
1 file changed, 8 insertions(+), 31 deletions(-)

--
2.30.0
F
F
Fredrik Salomonsson wrote on 28 Jan 2021 03:02
[PATCH 1/1] gnu: pinentry-rofi: Update to 2.0.2.
(address . 46148@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
20210128020207.149383-1-plattfot@posteo.net
* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2.
* gnu/packages/gnupg.scm (pinentry-rofi): Simplify the package definition.
---
gnu/packages/gnupg.scm | 39 ++++++++-------------------------------
1 file changed, 8 insertions(+), 31 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 6e80ca339f..9be8a32540 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -894,7 +894,7 @@ passphrase when @code{gpg} is run and needs it.")))
(define-public pinentry-rofi
(package
(name "pinentry-rofi")
- (version "2.0.1")
+ (version "2.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -902,7 +902,7 @@ passphrase when @code{gpg} is run and needs it.")))
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "044bnldz7k74s873jwsjgff176l1jsvpbaka7d1wcj8b5pwqv2av"))))
+ (base32 "14rbz32ykc8pz7gglbvxm3pcgabr7xdnddar6k24icd5xk9mr4rp"))))
(build-system gnu-build-system)
(arguments
`(#:modules
@@ -914,38 +914,15 @@ passphrase when @code{gpg} is run and needs it.")))
%standard-phases
(add-after 'install 'hall-wrap-binaries
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((compiled-dir
- (lambda (out version)
- (string-append out "/lib/guile/" version "/site-ccache")))
- (uncompiled-dir
- (lambda (out version)
- (string-append
- out
- "/share/guile/site"
- (if (string-null? version) "" "/")
- version)))
- (dep-path
- (lambda (env path)
- (list env ":" 'prefix (list path))))
- (out (assoc-ref outputs "out"))
+ (let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/"))
- (site (uncompiled-dir out "")))
+ (site (string-append out "/share/guile/site"))
+ (rofi-bin (string-append (assoc-ref inputs "rofi") "/bin")))
(match (scandir site)
(("." ".." version)
- (for-each
- (lambda (file)
- (wrap-program
- (string-append bin file)
- (dep-path
- "PATH"
- (string-append (assoc-ref inputs "rofi") "/bin"))
- (dep-path
- "GUILE_LOAD_PATH"
- (uncompiled-dir out version))
- (dep-path
- "GUILE_LOAD_COMPILED_PATH"
- (compiled-dir out version))))
- ,''("pinentry-rofi"))
+ (wrap-program
+ (string-append bin "pinentry-rofi")
+ (list "PATH" ":" 'prefix `(,rofi-bin)))
#t))))))))
(native-inputs
`(("autoconf" ,autoconf)
--
2.30.0
N
N
Nicolas Goaziou wrote on 28 Jan 2021 14:22
(name . Fredrik Salomonsson)(address . plattfot@posteo.net)(address . 46148-done@debbugs.gnu.org)
87czxpjiwj.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

Toggle quote (4 lines)
> * gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2.
> * gnu/packages/gnupg.scm (pinentry-rofi): Simplify the package
> definition.

Applied, with a slight change to commit message.

Thank you.

Regards,
--
Nicolas Goaziou
Closed
?