[PATCH] Add new skymaker

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oz3WSRAFuzU9svyLnxZigFiriJN7whhDyHjvq+pTe1pQ@mail.gmail.com
Hi Guix team!
One more patch for astronomy software.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 29ae710d189764cbcaba8726b0b9901bc2d3e3e4 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 27 Jan 2021 20:00:55 +0000
Subject: [PATCH] gnu: Add skymaker

* gnu/packages/astronomy.scm (skymaker): New variable
---
gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 95231e1837..cd1a27477a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -229,6 +229,36 @@ large scale galaxy-survey data, it can perform reasonably well on moderately
crowded star fields.")
(license license:gpl3+)))
+(define-public skymaker
+ (package
+ (name "skymaker")
+ (version "3.10.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.astromatic.net/download/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03zvx7c89plp9559niqv5532r233kza3ir992rg3nxjksqmrqvx1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append
+ "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+ (string-append
+ "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+ (inputs
+ `(("fftw" ,fftwf)))
+ (home-page "https://www.astromatic.net/software/skymaker")
+ (synopsis "Image simulation")
+ (description
+ "SkyMaker is a program that simulates astronomical images. It accepts
+object lists in ASCII generated by the Stuff program to produce realistic
+astronomical fields. SkyMaker is part of the EFIGI
+(https://www.astromatic.net/projects/efigi) development project.")
+ (license license:gpl3+)))
+
(define-public stellarium
(package
(name "stellarium")
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46143-done@debbugs.gnu.org)
87lfcdns8n.fsf@yamatai
Patch pushed as 33648567dd229b1302d2258e76d8b30593fedce6.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYBKySA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9BPQEAmWqkNcNF4QEpAYIi/AYl4CKIR/D0dv3k2aIa
pyBj9zQBAKVng2fWrkfpXiWUrTsAg/vey6JHSKNCz8jVChzjr57w
=UM4Y
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46143@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46143
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help