[PATCH] Add new shapelib

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oarXE3gEx3DL2izXxg8JLas7+SroOPfHGBtWoj7dW+7g@mail.gmail.com
Hi Guix team!
This patch is a part of packaging astronomy software
Regards
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From b6c776ef1ff238e8d32d94684ba36bb0bc05138d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 27 Jan 2021 19:02:22 +0000
Subject: [PATCH] gnu: Add shapelib

* gnu/packages/geo.scm (shapelib): New variable
---
gnu/packages/geo.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c682613ff1..942d6d1844 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2020 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1693,6 +1694,32 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
license:lgpl2.1+
license:mpl1.1))))
+(define-public shapelib
+ (package
+ (name "shapelib")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OSGeo/shapelib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lzch0jf6yqhw391phhafzw4ghmiz98zkf698h4fmq109fa2vhqd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "http://shapelib.maptools.org/")
+ (synopsis "Provides C library to write and update ESRI Shapefiles")
+ (description
+ "The Shapefile C Library provides the ability to write simple C programs
+for reading, writing and updating (to a limited extent) ESRI Shapefiles, and the
+associated attribute file (.dbf).")
+ (license license:gpl2+)))
+
(define-public spatialite-tools
(package
(name "spatialite-tools")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46141-done@debbugs.gnu.org)
8735ymruhs.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/geo.scm (shapelib): New variable

I added a little Texinfo markup in description, and applied your patch.

Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46141@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46141
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help