[PATCH] gnu: Add emacs-templatel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210127161708.9605-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-templatel): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8e87f88663..ad1e7ff050 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9366,6 +9366,28 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+(define-public emacs-templatel
+ (package
+ (name "emacs-templatel")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/templatel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k33h503038l2bcr8gs020z2cjxfs94lamkdgv52cvd9i20d0kqq"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clarete/templatel")
+ (synopsis "Jinja inspired template language for Emacs Lisp")
+ (description "A modern templating language for Emacs-Lisp. Inspired on
+Jinja, templatel brings a high level language for expanding variables with
+conditional and loop control flow structures.")
+ (license license:gpl3+)))
+
(define-public emacs-wgrep
(package
(name "emacs-wgrep")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 46133-done@debbugs.gnu.org)
87bldarv30.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-templatel): New variable.

Thank you.

I fixed home-page, using https://clarete.li/templatel/ instead of
GitHub, and description (use complete sentences, and two spaces after
full stop).

Patch applied.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46133@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46133
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help