(address . guix-patches@gnu.org)
This version of obs adds support for OBS_PLUGINS*_PATH environment variables,
which are required to be able to load plugins, which are present in profile.
It will make it possible for following packages to work:
* gnu/packages/video.scm (obs): Update to fb347c.
---
gnu/packages/video.scm | 116 ++++++++++++++++++++++-------------------
1 file changed, 63 insertions(+), 53 deletions(-)
Toggle diff (132 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 28cde06f04..0f9b405261 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3076,62 +3076,72 @@ be used for realtime video capture via Linux-specific APIs.")
(license (list license:lgpl2.1+ license:gpl2))))
(define-public obs
- (package
- (name "obs")
- (version "26.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/obsproject/obs-studio")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0p8wdzm9imn3s17arr206sz92g4pkacfcpfbwvhvgkrrs4w000bx"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-DOBS_VERSION_OVERRIDE=" ,version)
- "-DENABLE_UNIT_TESTS=TRUE")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (plugin-path (getenv "QT_PLUGIN_PATH")))
- (wrap-program (string-append out "/bin/obs")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
- #t)))))
- (native-inputs
- `(("cmocka" ,cmocka)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("curl" ,curl)
- ("eudev" ,eudev)
- ("ffmpeg" ,ffmpeg)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("jack" ,jack-1)
- ("jansson" ,jansson)
- ("libx264" ,libx264)
- ("libxcomposite" ,libxcomposite)
- ("mbedtls" ,mbedtls-apache)
- ("mesa" ,mesa)
- ("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
- ("qtsvg" ,qtsvg)
- ("qtx11extras" ,qtx11extras)
- ("speexdsp" ,speexdsp)
- ("v4l-utils" ,v4l-utils)
- ("zlib" ,zlib)))
- (synopsis "Live streaming software")
- (description "Open Broadcaster Software provides a graphical interface for
+ (let ((commit "fb347c3c62ced2ea302769e449d300fd923c2d4b")
+ (revision "1"))
+ (package
+ (name "obs")
+ (version (git-version "26.1.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/obsproject/obs-studio")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "017llgj1hlfvk2622qa44d8iz6d0kahhckn421dypj09a4n6aajz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DOBS_VERSION_OVERRIDE=" ,version)
+ "-DENABLE_UNIT_TESTS=TRUE")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append out "/bin/obs")
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
+ #t)))))
+ (native-inputs
+ `(("cmocka" ,cmocka)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("eudev" ,eudev)
+ ("ffmpeg" ,ffmpeg)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("jack" ,jack-1)
+ ("jansson" ,jansson)
+ ("libx264" ,libx264)
+ ("libxcomposite" ,libxcomposite)
+ ("mbedtls" ,mbedtls-apache)
+ ("mesa" ,mesa)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)
+ ("speexdsp" ,speexdsp)
+ ("v4l-utils" ,v4l-utils)
+ ("zlib" ,zlib)))
+ (native-search-paths
+ (list
+ (search-path-specification
+ (variable "OBS_PLUGINS_DATA_PATH")
+ (files '("share/obs/obs-plugins")))
+ (search-path-specification
+ (variable "OBS_PLUGINS_PATH")
+ (files '("lib/obs-plugins")))))
+ (synopsis "Live streaming software")
+ (description "Open Broadcaster Software provides a graphical interface for
video recording and live streaming. OBS supports capturing audio and video
from many input sources such as webcams, X11 (for screencasting), PulseAudio,
and JACK.")
- (home-page "https://obsproject.com")
- (license license:gpl2+)))
+ (home-page "https://obsproject.com")
+ (license license:gpl2+))))
(define-public libvdpau
(package
--
2.30.0