(address . bug-guix@gnu.org)
Hello,
I am building GNU Guix from the source on a foreign distro. Several
tests fail:
1. tests/lint.scm.
2. tests/guix-pack.sh. Probably, tar is the root of the issue, as it
refuses to create a hard link to /opt/gnu/bin.
3. When current directory has symlinks in its path, tests/guix-gc.sh
fail because of the absence of path canonicalization in $PWD.
Assuming ln -s ~/downloads ~/downloads-sl and insertion of echo
instead of pipe at line 71, tests/guix-gc.sh yields
+ guix gc --list-roots
accepted connection from pid 911, user taxus
/home/taxus/downloads/distro/guix/guix-1.2.0/guix-gc-root
/home/taxus/downloads/distro/guix/guix-1.2.0/test-tmp/var/755/profiles
+ echo grep /home/taxus/downloads-sl/distro/guix/guix-1.2.0/guix-gc-root
grep /home/taxus/downloads-sl/distro/guix/guix-1.2.0/guix-gc-root
I am ?ttaching ./test-suite-failing.log for the #1 and #2 and providing
the versions of the build requirements below:
- GNU tar: 1.33
- GNU make: 4.3
- GNU guix: 1.2.0,
- GNU Guile: 2.2.6
- guile-json: 4.3.2
- guile-gcrypt: 0.3.0
- gnutls: 3.7.0
- guile-sqlite3: 0.1.3
- guile-zlib: 0.0.1
- guile-lzlib: 0.0.1
- guile-avahi: 6d43caf64f672a9694bf6c98bbf7a734f17a51e8
- guile-git: 0.4.0
Also, tests/offload.scm tests brings down the entire test suite when
guile-ssh is not installed (despite it being an optional dependency);
attaching the corresponding logfile, too.
Thanks in advance,
~taxuswc
Backtrace:
In ice-9/boot-9.scm:
2887:24 19 (_)
222:17 18 (map1 (((guix scripts offload)) ((srfi srfi-64))))
2800:17 17 (resolve-interface (guix scripts offload) #:select _ # _ …)
In ice-9/threads.scm:
390:8 16 (_ _)
In ice-9/boot-9.scm:
2726:13 15 (_)
In ice-9/threads.scm:
390:8 14 (_ _)
In ice-9/boot-9.scm:
2994:20 13 (_)
2312:4 12 (save-module-excursion #<procedure 7f40c806d2a0 at ice-…>)
3014:26 11 (_)
In unknown file:
10 (primitive-load-path "guix/scripts/offload" #<procedure…>)
In ice-9/eval.scm:
721:20 9 (primitive-eval (define-module (guix scripts offload) …))
In ice-9/psyntax.scm:
1262:36 8 (expand-top-sequence ((define-module (guix # #) # # …)) …)
1209:24 7 (parse _ (("placeholder" placeholder)) ((top) #(# # …)) …)
285:10 6 (parse _ (("placeholder" placeholder)) (()) _ c&e (eval) …)
In ice-9/eval.scm:
293:34 5 (_ #<module (#{ g24}#) 7f40c8b980a0>)
In ice-9/boot-9.scm:
2874:4 4 (define-module* _ #:filename _ #:pure _ #:version _ # _ …)
2887:24 3 (_)
222:17 2 (map1 (((ssh key)) ((ssh auth)) ((ssh session)) ((…)) …))
2803:6 1 (resolve-interface _ #:select _ #:hide _ #:prefix _ # _ …)
In unknown file:
0 (scm-error misc-error #f "~A ~S" ("no code for modu…" …) …)
ERROR: In procedure scm-error:
no code for module (ssh key)