[PATCH] gnu: Add quark.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
SN4PR0801MB3679D53CDE75C2C8B45AA2E7C5BD9@SN4PR0801MB3679.namprd08.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/web.scm (quark): New variable.
---

So linting this package brings up CVE-2019-15520. This CVE is for a completely
different program that also happens to be called quark.

---
gnu/packages/web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 16c99af9d3..63a5637c87 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8039,3 +8039,36 @@ handling library written in C89 (\"ANSI C\"). uriparser is fast and supports
Unicode.")
(home-page "https://uriparser.github.io/")
(license license:bsd-3))))
+
+(define-public quark
+ ;; No releases yet
+ (let ((revision "0")
+ (commit "c6a9055e5a30be570e30da8d216c39662c3a3f99"))
+ (package
+ (name "quark")
+ (version "0.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.suckless.org/quark/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1znvnr30xi5vgd6n3wvgv9pwj992zpzzjk0fmq28ydf1l6kqvkm7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/quark/")
+ (synopsis "Small and simple HTTP GET/HEAD-only web server for static
+content")
+ (description "An extremely small and simple HTTP GET/HEAD only web
+server for static content. TLS is not natively supported and should be
+provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
+ (license license:isc))))
--
2.30.0
Ludovic Courtès wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)(address . 46106-done@debbugs.gnu.org)
87bld2g51p.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/web.scm (quark): New variable.

Applied with the changes below.

Thanks,
Ludo’.
Toggle diff (29 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1366637de6..879eb160ea 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8022,7 +8022,7 @@ Unicode.")
(commit "c6a9055e5a30be570e30da8d216c39662c3a3f99"))
(package
(name "quark")
- (version "0.0.0")
+ (version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8044,7 +8044,12 @@ Unicode.")
(home-page "https://tools.suckless.org/quark/")
(synopsis "Small and simple HTTP GET/HEAD-only web server for static
content")
- (description "An extremely small and simple HTTP GET/HEAD only web
-server for static content. TLS is not natively supported and should be
+ (description "Quark is an extremely small and simple HTTP GET/HEAD only
+web server for static content. TLS is not natively supported and should be
provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
- (license license:isc))))
+ (license license:isc)
+
+ ;; XXX: Ignore this CVE to work around a name clash with the unrelated
+ ;; "cpe:2.3:a:comelz:quark" package. The proper fix is for (guix cve)
+ ;; to account for "vendor names".
+ (properties '((lint-hidden-cve . ("CVE-2019-15520")))))))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46106@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46106
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help