Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/web.scm (quark): New variable.
---
So linting this package brings up CVE-2019-15520. This CVE is for a completely
different program that also happens to be called quark.
---
gnu/packages/web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 16c99af9d3..63a5637c87 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8039,3 +8039,36 @@ handling library written in C89 (\"ANSI C\"). uriparser is fast and supports
Unicode.")
(home-page "https://uriparser.github.io/")
(license license:bsd-3))))
+
+(define-public quark
+ ;; No releases yet
+ (let ((revision "0")
+ (commit "c6a9055e5a30be570e30da8d216c39662c3a3f99"))
+ (package
+ (name "quark")
+ (version "0.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.suckless.org/quark/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1znvnr30xi5vgd6n3wvgv9pwj992zpzzjk0fmq28ydf1l6kqvkm7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/quark/")
+ (synopsis "Small and simple HTTP GET/HEAD-only web server for static
+content")
+ (description "An extremely small and simple HTTP GET/HEAD only web
+server for static content. TLS is not natively supported and should be
+provided by a TLS reverse proxy (e.g. tlstunnel, hitch or stunnel).")
+ (license license:isc))))
--
2.30.0