[PATCH] Add 3 new - modularize, trivial-arguments, ubiquitous

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qso8O72z4Qe3WNFFB9uCJ=-+tdjPkr8ScbzxxV7hchhw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 3628d1ebe0ff69438db26aca79c0f7a1372bdbb0 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 25 Jan 2021 18:03:31 +0000
Subject: [PATCH] gnu: Add new modularize

* gnu/packages/lisp-xyz.scm
sbcl-modularize, cl-modularize, ecl-modularize: New variables
---
gnu/packages/lisp-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3fefccf1e8..6dac53abaa 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9686,6 +9686,48 @@ PascalCase, snake_case, param-case, CONSTANT_CASE and more.")
(define-public ecl-cl-change-case
(sbcl-package->ecl-package sbcl-cl-change-case))
+(define-public sbcl-modularize
+ (let ((commit "86c5d9a11fbd2df9f0f03ac10b5d71837c8934ba")
+ (revision "1"))
+ (package
+ (name "sbcl-modularize")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/modularize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zys29rfkb649rkgl3snxhajk8d5yf7ryxkrwy020kwdh7zdsg7d"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:test-asd-file "modularize-test-module.asd"
+ #:asd-files '("modularize.asd" "modularize-test-module.asd")
+ #:asd-systems '("modularize" "modularize-test-module")))
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("trivial-package-local-nicknames" ,sbcl-trivial-package-local-nicknames)))
+ (home-page "https://shinmera.github.io/modularize/")
+ (synopsis "Common Lisp modularization framework")
+ (description
+ "@code{MODULARIZE} is an attempt at providing a common interface to
+segregate major application components. This is achieved by adding special
+treatment to packages. Each module is a package that is specially registered,
+which allows it to interact and co-exist with other modules in better ways. For
+instance, by adding module definition options you can introduce mechanisms to
+tie modules together in functionality, hook into each other and so on.
+
+This package produces 1 system: @code{MODULARIZE}")
+ (license license:zlib))))
+
+(define-public ecl-modularize
+ (sbcl-package->ecl-package sbcl-modularize))
+
+(define-public cl-modularize
+ (sbcl-package->cl-source-package sbcl-modularize))
+
(define-public sbcl-moptilities
(let ((commit "a436f16b357c96b82397ec018ea469574c10dd41"))
(package
--
2.30.0
From 76c0dd9735548910df042e33717a36a983327994 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 25 Jan 2021 18:08:24 +0000
Subject: [PATCH] gnu: Add new trivial-arguments

* gnu/packages/lisp-xyz.scm
sbcl-trivial-arguments, cl-trivial-arguments, ecl-trivial-arguments:
New varialbes
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6dac53abaa..6da89131ce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3235,6 +3235,36 @@ client and server.")
(define-public ecl-s-xml-rpc
(sbcl-package->ecl-package sbcl-s-xml-rpc))
+(define-public sbcl-trivial-arguments
+ (let ((commit "ecd84ed9cf9ef8f1e873d7409e6bd04979372aa7")
+ (revision "1"))
+ (package
+ (name "sbcl-trivial-arguments")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/trivial-arguments")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02vaqfavhj8jqxnr68nnzvzshm8jbgcy6m9lvyv4daa6f7ihqf88"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/Shinmera/trivial-arguments")
+ (synopsis "Tiny Common Lisp library to retrieve the arguments list of a function")
+ (description
+ "A simple library to retrieve the lambda-list of a function.
+
+This package produces 1 system: @code{TRIVIAL-ARGUMENTS}")
+ (license license:zlib))))
+
+(define-public ecl-trivial-arguments
+ (sbcl-package->ecl-package sbcl-trivial-arguments))
+
+(define-public cl-trivial-arguments
+ (sbcl-package->cl-source-package sbcl-trivial-arguments))
+
(define-public sbcl-trivial-clipboard
(let ((commit "afcd3743b842f5a81fc86dba60f9db59970f49c5"))
(package
--
2.30.0
From d9282622a8c908e486e9705bedaf9a813bdae37b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 25 Jan 2021 18:12:44 +0000
Subject: [PATCH] gnu: Add new ubiquitous

* gnu/packages/lisp-xyz.scm
sbcl-ubiquitous, cl-ubiquitous, ecl-ubiquitous: New variables
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6da89131ce..428d3aacb8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -459,6 +459,41 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public ecl-cl-ppcre
(sbcl-package->ecl-package sbcl-cl-ppcre))
+(define-public sbcl-ubiquitous
+ (let ((commit "35eb7bd9e1b3daee1705f6b41260775180cce8af")
+ (revision "1"))
+ (package
+ (name "sbcl-ubiquitous")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/ubiquitous")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xlkaqmjcpkiv2xl2s2pvvrv976dlc846wm16s1lj62iy1315i49"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)))
+ (home-page "https://shinmera.github.io/ubiquitous/")
+ (synopsis "Provides universal application configuration mechanism")
+ (description
+ "@code{UBIQUITOUS} is a very easy-to-use library for persistent
+configuration storage. It automatically takes care of finding a suitable place
+to save your data, and provides simple functions to access and modify the data
+within.
+
+This package produces 2 systems: @code{UBIQUITOUS} @code{UBIQUITOUS-CONCURRENT}")
+ (license license:zlib))))
+
+(define-public ecl-ubiquitous
+ (sbcl-package->ecl-package sbcl-ubiquitous))
+
+(define-public cl-ubiquitous
+ (sbcl-package->cl-source-package sbcl-ubiquitous))
+
(define-public sbcl-uax-15
(package
(name "sbcl-uax-15")
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46105-done@debbugs.gnu.org)
87ft2ojd1s.fsf@yamatai
Patches pushed as f39d8d2ca96b15c4d415a36932526e1dd9ee212c and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYA/YLw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8mkgEAkaYO/EKFeL0cxSJL/+5cOck8EJ8GTVfIuyn0
cyOFHpgA/AqFSenEh1i5H9jEWfJ4sucGW0sDiKeGSLnp/3Xs0beK
=QJmZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46105@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46105
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help