[PATCH 0/2] Update wine to 6.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
4cd19b91e1fbfb7f62fc616a044101ad144baa25.camel@student.tugraz.at
This series updates vkd3d to 1.2 and wine to 6.0.
Leo Prikler wrote 4 years ago
[PATCH 1/2] gnu: vkd3d: Update to 1.2.
(address . 46094@debbugs.gnu.org)
20210125084046.31520-1-leo.prikler@student.tugraz.at
* gnu/packages/vulkan.scm (vkd3d): Update to 1.2.
---
gnu/packages/vulkan.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 7e622946e9..86b0e55f34 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -351,10 +351,10 @@ shader compilation.")
(license license:asl2.0)))
(define-public vkd3d
- (let ((commit "ecda316ef54d70bf1b3e860755241bb75873e53f")) ; Release 1.1.
+ (let ((commit "56cd4a94d541707959ce7677af6d1a34739e5579")) ; Release 1.2.
(package
(name "vkd3d")
- (version "1.1")
+ (version "1.2")
(source
(origin
(method git-fetch)
@@ -363,7 +363,7 @@ shader compilation.")
(commit commit)))
(sha256
(base32
- "05a28kspy8gzng181w28zjqdb3pj2ss83b0lwnppxbcdzsz7rvrf"))
+ "1n4a622drgnprvz5hjxzyzcsg2lp5rlf1sajki2vzf5gsx6fdpk8"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
--
2.30.0
Leo Prikler wrote 4 years ago
[PATCH 2/2] gnu: wine: Update to 6.0.
(address . 46094@debbugs.gnu.org)
20210125084046.31520-2-leo.prikler@student.tugraz.at
* gnu/packages/wine.scm (wine): Update to 6.0.
[inputs]: Add libusb. Remove glu, ncurses and zlib.
---
gnu/packages/wine.scm | 13 +++++--------
1 file changed, 5 insertions(+), 8 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 0d93af0dc9..98b435cb8d 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -38,7 +38,6 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
- #:use-module (gnu packages compression)
#:use-module (gnu packages cups)
#:use-module (gnu packages databases)
#:use-module (gnu packages fontutils)
@@ -52,6 +51,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages mingw)
#:use-module (gnu packages openldap)
@@ -60,7 +60,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages mp3)
- #:use-module (gnu packages ncurses)
#:use-module (gnu packages photo)
#:use-module (gnu packages samba)
#:use-module (gnu packages scanner)
@@ -76,7 +75,7 @@
(define-public wine
(package
(name "wine")
- (version "5.21")
+ (version "6.0")
(source
(origin
(method url-fetch)
@@ -88,7 +87,7 @@
(string-append "https://dl.winehq.org/wine/source/" dir
"wine-" version ".tar.xz")))
(sha256
- (base32 "0h185lfpid6cw1sz8rmkpky2l11izpb0w8j0cq6ww6yi94jmq6js"))))
+ (base32 "0micb3l54cc2cl3v5q92hzvkxxiwi9lmiv72caf45vl35xghd4xl"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -104,7 +103,6 @@
("faudio" ,faudio)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ("glu" ,glu)
("gnutls" ,gnutls)
("gst-plugins-base" ,gst-plugins-base)
("lcms" ,lcms)
@@ -118,6 +116,7 @@
("libpcap" ,libpcap)
("libpng" ,libpng)
("libjpeg" ,libjpeg-turbo)
+ ("libusb" ,libusb)
("libtiff" ,libtiff)
("libICE" ,libice)
("libX11" ,libx11)
@@ -130,15 +129,13 @@
("libXxf86vm" ,libxxf86vm)
("libXcomposite" ,libxcomposite)
("mit-krb5" ,mit-krb5)
- ("ncurses" ,ncurses)
("openal" ,openal)
("pulseaudio" ,pulseaudio)
("sdl2" ,sdl2)
("unixodbc" ,unixodbc)
("v4l-utils" ,v4l-utils)
("vkd3d" ,vkd3d)
- ("vulkan-loader" ,vulkan-loader)
- ("zlib" ,zlib)))
+ ("vulkan-loader" ,vulkan-loader)))
(arguments
`(;; Force a 32-bit build targeting a similar architecture, i.e.:
;; armhf for armhf/aarch64, i686 for i686/x86_64.
--
2.30.0
Ludovic Courtès wrote 4 years ago
Re: bug#46094: [PATCH 0/2] Update wine to 6.0
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 46094@debbugs.gnu.org)
874kj0j9q5.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> This series updates vkd3d to 1.2 and wine to 6.0.

Go for it!

Ludo’.
Leo Prikler wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 46094-done@debbugs.gnu.org)
28979bec321c741a550ac48db485d6a21024dc83.camel@student.tugraz.at
Am Freitag, den 29.01.2021, 11:52 +0100 schrieb Ludovic Courtès:
Toggle quote (9 lines)
> Hi,
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > This series updates vkd3d to 1.2 and wine to 6.0.
>
> Go for it!
>
> Ludo’.
Aaand it's done.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46094@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46094
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help