[PATCH 6/6] gnu: Added wally-cli.

  • Done
  • quality assurance status badge
Details
2 participants
  • Martin Becze
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 24 Jan 2021 18:55
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124175532.9501-6-mjbecze@riseup.net
* gnu/packages/flashing-tools.scm (wally-cli): New variable.
---
gnu/packages/flashing-tools.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 669c45fd68..5aa7eef761 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,11 +32,13 @@
#:use-module (gnu packages)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages pciutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libusb)
@@ -476,3 +479,32 @@ ME as far as possible (it only edits ME firmware image files).")
(description "@code{uefitool} is a graphical image file editor for
Unifinished Extensible Firmware Interface (UEFI) images.")
(license license:bsd-2)))
+
+(define-public wally-cli
+ (package
+ (name "wally-cli")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zsa/wally-cli.git")
+ (commit (string-append version "-linux"))))
+ (sha256
+ (base32
+ "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ; tests fail on the linter
+ #:import-path "github.com/zsa/wally-cli"))
+ (native-inputs
+ `(("go-gopkg-in-cheggaaa-pb-v1" ,go-gopkg-in-cheggaaa-pb-v1)
+ ("go-github-com-google-gousb" ,go-github-com-google-gousb)
+ ("go-github-com-marcinbor85-gohex" ,go-github-com-marcinbor85-gohex)
+ ("go-github-com-caarlos0-spin" ,go-github-com-caarlos0-spin)
+ ("go-github-com-logrusorgru-aurora" ,go-github-com-logrusorgru-aurora)))
+ (home-page "https://ergodox-ez.com/pages/wally")
+ (synopsis "Flashing tool for ZSA keyboards")
+ (description "This tool is for flashing custom layouts to ZSA keyboards.")
+ (license license:expat)))
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:02
Re: bug#46081: Acknowledgement ([PATCH 6/6] gnu: Added wally-cli.)
(address . 46081@debbugs.gnu.org)
a0fe56a4-2f2b-b581-3ecc-6edb6932a786@riseup.net

S
S
Sharlatan Hellseher wrote on 29 Mar 15:25 +0100
[PATCH 6/6] gnu: Added wally-cli.
(address . 46081-done@debbugs.gnu.org)
87jzlldsj7.fsf@gmail.com
Closing as duplicate.

wally-cli was added from https://issues.guix.gnu.org/47769.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYGz0wACgkQdtcnv/Ys
0rWFEQ//U2J+tHbcFFos1rbr45/559soZL19ExR2FusN+O3sqR7mCbZgPu/WFvIx
QxcOmadcGwQ0ImCK8N560615Q5XyG7jt5SHrpz/bic2Hk7xbbzfXjtWTd9ewjxEd
z9NN8zXXSZBKAZML2VWg5xOJCmOChBfPPQy1CmKWrXcqoeR3LJ8FbBs5Nm/64Zaq
CgT56Z2+oEWIQgPBrz9Qg/GuWHG8IqKlyorL18rRRIAWWC70TQAXszyjY9lr7GFU
EYB4hElht6QD9xLtLUdhvlHhzETkwMc7fYCMnhNXEelf2y5m/dWmrexbowwtx58k
veZIgKGVpg+k2wO/raIXhswWbTu5HbeyD88GCdcKbalhGaFl/VyAGPxBF3KotTF9
Vwuf/hR0S7kjy7khHEOHR6c28EivMIhKJr86nWm8aC6gr44EZdOty6m41anyDFeX
6puD3ds7J5PUUIW4uJMPM8bhl21pEXvfjmdD9Or+FYIR2wH20VRR5B2ojlbTH1YY
+KmGBERIjJ1/G2U3f767FBqaqxJeNb37F2rJFbtYPStIgL3P/Ube6UcBHQ5ZltQK
dX2e9VqwtxL/FaoQj9bkOdEIS5O4PjhNThPX6JxnADi5TdJuzbMIyotdL4gMLdxN
Yy8EbLjTxbWN0gagDR3AI8gzEIs7DAOpRAjMk1QkePV3f+bSE/o=
=AwJv
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46081@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46081
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch