[PATCH 5/6] gnu: Added go-github-com-google-gousb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Martin Becze
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 24 Jan 2021 18:55
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124175532.9501-5-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-google-gousb): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index da23ec7848..0600f07b48 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pcre)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages mp3)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -4655,6 +4656,32 @@ GitHub API v3.")
create or replace a file or symbolic link.")
(license license:asl2.0)))
+(define-public go-github-com-google-gousb
+ (package
+ (name "go-github-com-google-gousb")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gousb.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1aki6hk009sicrf7gxy5nkjmj4j7lsy0by4kjgd9bwq8ragfyv5x"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/gousb"))
+ (propagated-inputs
+ `(("pkg-config" ,pkg-config)
+ ("libusb" ,libusb)))
+ (home-page "https://github.com/google/gousb")
+ (synopsis "Wrapping for libusb")
+ (description "The gousb package is an attempt at wrapping the libusb
+library into a Go-like binding.")
+ (license license:asl2.0)))
+
(define-public go-golang.org-x-sync-errgroup
(let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
(revision "0"))
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:03
Re: bug#46079: Acknowledgement ([PATCH 5/6] gnu: Added go-github-com-google-gousb.)
(address . 46079@debbugs.gnu.org)
a9979f01-0e2b-97a9-a6d3-0e584172b22e@riseup.net

S
S
Sharlatan Hellseher wrote on 29 Mar 15:35 +0100
[PATCH 5/6] gnu: Added go-github-com-google-gousb.
(address . 46079-done@debbugs.gnu.org)
877chlds1q.fsf@gmail.com
Closing as duplicate.

wally-cli was added from https://issues.guix.gnu.org/47769.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYG0cEACgkQdtcnv/Ys
0rWKfxAAnj8i5kM0McZFfAEz7QbQ1qsK2pkXYdwk70PepQ0PJugRxVZjNYV40xk1
kPGINaposUDmGfURiVQRAH1jXhh1Posnrgt2cKfyq9ZGeRv9wtDHLHcg9sAbqoRE
zO1DOJCoxYcalKbJLTQxpOoVusWZNXlmNr+8ocga8hXam+A1MDpIa7q60cSG2c1G
kOHCw+nlH8THjHb4F8yxzb3bAmcfJEpmfE/lEVLXsHjE1DLTem3iV0K6x/VpQZjA
yyAxCrAamqhc2BLKdbHNlBJioWSZC7ONCPQHYb+T4fYF3xneMzgl8VDCCI0YrJnO
5W/qUr5HG8AJ9tqqgiu65EKerfxXPis8DixxSnzidlWEXW5GljHY/5RsbGQP6sux
+UqPLB3808p6B14U94jOmjeKT7baLeJECyg3qJc8p94fnuUoxFOvGjGQjkQTGQrZ
qINZphq1C5Z2iBehJ1MygoMo0p+qzzLU/4PAI9AA4+NvdRuI3AlHnmk1+sJME8Tl
N3xuP9Rs4YrruuTwJMX59Nt1dfWAX+lKISpNFFRRMF2ukLAaLrlDRAUOo0jtg6DK
tmhxFp3TMtvSntxvPMzPvwdTzsOZ+El/yGaBaIZYQWgdaHvA1rT2j57qv4M0DIBB
IXJhT/IThgZ6JTNU5bI6lotzUPWgJpX66bAMD2yFLJrFxLHhs5c=
=qVms
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46079@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46079
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch