[PATCH 1/6] gnu: Add go-gopkg-in-cheggaaa-pb-v1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Martin Becze
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 24 Jan 2021 18:55
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124175532.9501-1-mjbecze@riseup.net
* gnu/packages/golang.scm (go-gopkg-in-cheggaaa-pb-v1): New variable.
---
gnu/packages/golang.scm | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d34bb1acb7..915d64bc4d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
-;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020, 2021 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6392,6 +6392,23 @@ inspired by the causal messaging system in the Pony programming language.")
the terminal.")
(license license:bsd-3)))
+(define-public go-gopkg-in-cheggaaa-pb-v1
+ (package
+ (inherit go-github-com-cheggaaa-pb)
+ (name "go-gopkg-in-cheggaaa-pb-v1")
+ (version "1.0.28")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/cheggaaa/pb.v1.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13a66cqbpdif804qj12z9ad8r24va9q41gfk71qbc4zg1wsxs3rh"))))
+ (arguments
+ '(#:import-path "gopkg.in/cheggaaa/pb.v1"))))
+
(define-public go-github-com-gologme-log
;; this is the same as v1.2.0, only the LICENSE file changed
(let ((commit "720ba0b3ccf0a91bc6018c9967a2479f93f56a55"))
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:10
[PATCH 2/6] gnu: Added go-github-com-logrusorgru-aurora.
(address . 46076@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124181102.10519-1-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-logrusorgru-aurora): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 915d64bc4d..384cdc5a1c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6683,6 +6683,28 @@ compressed streams in Go.")
(home-page "https://github.com/ulikunitz/xz")
(license license:bsd-3)))
+(define-public go-github-com-logrusorgru-aurora
+ (package
+ (name "go-github-com-logrusorgru-aurora")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/logrusorgru/aurora.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0z7cgj8gl69271d0ag4f4yjbsvbrnfibc96cs01spqf5krv2rzjc"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/logrusorgru/aurora"))
+ (home-page "https://github.com/logrusorgru/aurora")
+ (synopsis "Ultimate ANSI colors for Golang")
+ (description "This package provides ANSI colors for Golang. The package
+supports Printf/Sprintf etc.")
+ (license license:unlicense)))
+
(define-public go-github-com-songmu-gitconfig
(package
(name "go-github-com-songmu-gitconfig")
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:10
[PATCH 3/6] gnu: Added go-github-com-caarlos0-spin.
(address . 46076@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124181102.10519-2-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-caarlos0-spin): New variable.
---
gnu/packages/golang.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 384cdc5a1c..0cd6053872 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6705,6 +6705,27 @@ compressed streams in Go.")
supports Printf/Sprintf etc.")
(license license:unlicense)))
+(define-public go-github-com-caarlos0-spin
+ (package
+ (name "go-github-com-caarlos0-spin")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/caarlos0-graveyard/spin.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1pnijds4145j8nsxvq8203r2sg2pbk7x8prkdg2ilghhrzqj6vyc"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/caarlos0/spin"))
+ (home-page "https://github.com/caarlos0-graveyard/spin")
+ (synopsis "Simple spinner for cli apps")
+ (description "A very simple spinner for cli golang apps.")
+ (license license:expat)))
+
(define-public go-github-com-songmu-gitconfig
(package
(name "go-github-com-songmu-gitconfig")
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:11
[PATCH 4/6] gnu: Added go-github-com-marcinbor85-gohex.
(address . 46076@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124181102.10519-3-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-marcinbor85-gohex): New variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0cd6053872..da23ec7848 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6726,6 +6726,29 @@ supports Printf/Sprintf etc.")
(description "A very simple spinner for cli golang apps.")
(license license:expat)))
+(define-public go-github-com-marcinbor85-gohex
+ (let ((commit "baab2527a9a2a4abb3dc06baabedfa5e0268b8d8")
+ (revision "1"))
+ (package
+ (name "go-github-com-marcinbor85-gohex")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcinbor85/gohex")
+ (commit commit)))
+ (sha256
+ (base32
+ "06v4cc6ld6vvxd4xm9k6l49lhcd9ncq7xfx35mj5b9r96ih49fiz"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/marcinbor85/gohex"))
+ (home-page "https://godoc.org/github.com/marcinbor85/gohex")
+ (synopsis "Parse Intel hex files")
+ (description "A Go library for parsing Intel HEX files.")
+ (license license:expat))))
+
(define-public go-github-com-songmu-gitconfig
(package
(name "go-github-com-songmu-gitconfig")
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:11
[PATCH 5/6] gnu: Added go-github-com-google-gousb.
(address . 46076@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124181102.10519-4-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-google-gousb): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index da23ec7848..0600f07b48 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pcre)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages mp3)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -4655,6 +4656,32 @@ GitHub API v3.")
create or replace a file or symbolic link.")
(license license:asl2.0)))
+(define-public go-github-com-google-gousb
+ (package
+ (name "go-github-com-google-gousb")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gousb.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1aki6hk009sicrf7gxy5nkjmj4j7lsy0by4kjgd9bwq8ragfyv5x"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/gousb"))
+ (propagated-inputs
+ `(("pkg-config" ,pkg-config)
+ ("libusb" ,libusb)))
+ (home-page "https://github.com/google/gousb")
+ (synopsis "Wrapping for libusb")
+ (description "The gousb package is an attempt at wrapping the libusb
+library into a Go-like binding.")
+ (license license:asl2.0)))
+
(define-public go-golang.org-x-sync-errgroup
(let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
(revision "0"))
--
2.30.0
M
M
Martin Becze wrote on 24 Jan 2021 19:11
[PATCH 6/6] gnu: Added wally-cli.
(address . 46076@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210124181102.10519-5-mjbecze@riseup.net
* gnu/packages/flashing-tools.scm (wally-cli): New variable.
---
gnu/packages/flashing-tools.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 669c45fd68..5aa7eef761 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,11 +32,13 @@
#:use-module (gnu packages)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages pciutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libusb)
@@ -476,3 +479,32 @@ ME as far as possible (it only edits ME firmware image files).")
(description "@code{uefitool} is a graphical image file editor for
Unifinished Extensible Firmware Interface (UEFI) images.")
(license license:bsd-2)))
+
+(define-public wally-cli
+ (package
+ (name "wally-cli")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zsa/wally-cli.git")
+ (commit (string-append version "-linux"))))
+ (sha256
+ (base32
+ "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ; tests fail on the linter
+ #:import-path "github.com/zsa/wally-cli"))
+ (native-inputs
+ `(("go-gopkg-in-cheggaaa-pb-v1" ,go-gopkg-in-cheggaaa-pb-v1)
+ ("go-github-com-google-gousb" ,go-github-com-google-gousb)
+ ("go-github-com-marcinbor85-gohex" ,go-github-com-marcinbor85-gohex)
+ ("go-github-com-caarlos0-spin" ,go-github-com-caarlos0-spin)
+ ("go-github-com-logrusorgru-aurora" ,go-github-com-logrusorgru-aurora)))
+ (home-page "https://ergodox-ez.com/pages/wally")
+ (synopsis "Flashing tool for ZSA keyboards")
+ (description "This tool is for flashing custom layouts to ZSA keyboards.")
+ (license license:expat)))
--
2.30.0
S
S
Sharlatan Hellseher wrote on 29 Mar 15:24 +0100
[PATCH 1/6] gnu: Add go-gopkg-in-cheggaaa-pb-v1.
(address . 46076-done@debbugs.gnu.org)
87msqhdsjz.fsf@gmail.com
Closing as duplicate.

wally-cli was added from https://issues.guix.gnu.org/47769.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYGzzAACgkQdtcnv/Ys
0rXbAw//e8YwD10mAZscZIB4iYpNQdwPjeTwk+CLDJ+Uc0yiT+7/V2hN4TV9P3EE
Epv0qXTk03DzK0d9us5UEYXKs+BSiXHmXUHukgml/n4P4PxYf+o7UuvR5at0uds8
XW+MecolTpNNVZjWG9J5lm+r9v16ny9EwTo1DfdejedKymYGtc5iiPpKCnCyJTeW
BlV5Gu4CFAT/alKjiDz6DdrU1UUKw2PSOkX5fCoAZksW8e4tkTMC0EUcDY4Rwdp8
zalzb3HxcdjZdabVLR5FrOFtDnGWWV1OJgSs69ZjnOQsslgUdQvAMqLwIebH9NIK
qlJZpbvcfpE5H5C3Idu9RVTY5tc9GwQi0B+TGiFK5HOT0dSUD8CQAFMQ3fsy2Uhf
0ki/cq1T/2Z03oWpjDNe/Qrj056FqGfl2FJ0kHwh27oOaipuOQYoRLnVAxP6Tk/Q
JQyxWGutYkVrtccK3fbCzy8QsmdUiSW32ZjtjmhtU75LHUWysad8gGhtZlMbOke4
gRmRzpSbJfZzPuO8yQong40hHxMuXyLCgAFfCOs4/cQv2X7qznhrNiaosxVcNB+n
jX6dd++1a1HlmxjW6JlFK+xxXbbUlo2MSdV/giVw050G+Del3cxDCJI83GH2D+xJ
1jdFPSyReW0OXSpzDaIKxtvcCgy3zqG6aRczRsJC3vH2Gf+qtB4=
=sdfa
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46076@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46076
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch