[PATCH] New variable - sextractor

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qu+MDi_T_4Ba=8EAAFVK3Uenm7ty9UdFsNsBGM7aExRw@mail.gmail.com
Hi Guix team!
This patch is one of the planed set of software for astronomy I'd like
to pack for Guix
Regards
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 067fecb0a5b64d1dd17dcb0c4ef78687fe030645 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 24 Jan 2021 11:16:36 +0000
Subject: [PATCH] Add new sextractor

* gnu/packages/astronomy.scm (sextractor): New variable
---
gnu/packages/astronomy.scm | 48 ++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9485fe600f..65f42df5df 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -156,6 +156,54 @@ header.")
programs for the manipulation and analysis of astronomical data.")
(license license:gpl3+)))
+(define-public sextractor
+ (package
+ (name "sextractor")
+ (version "2.25.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/sextractor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q69n3nyal57h3ik2xirwzrxzljrwy9ivwraxzv9566vi3n4z5mw"))))
+ (build-system gnu-build-system)
+ ;; NOTE: (Sharlatan-20210124T103117+0000): Building with `atlas' is failing
+ ;; due to missing shared library which required on configure phase. Switch
+ ;; build to use `openblas' instead. It requires FFTW with single precision
+ ;; `fftwf'.
+ (arguments
+ `(#:configure-flags
+ (list
+ "--enable-openblas"
+ (string-append
+ "--with-openblas-libdir=" (assoc-ref %build-inputs "openblas") "/lib")
+ (string-append
+ "--with-openblas-incdir=" (assoc-ref %build-inputs "openblas") "/include")
+ (string-append
+ "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+ (string-append
+ "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("openblas" ,openblas)
+ ("fftw" ,fftwf)))
+ (home-page "http://www.astromatic.net/software/sextractor")
+ (synopsis "Extract catalogs of sources from astronomical images")
+ (description
+ "SExtractor is a program that builds a catalogue of objects from an
+astronomical image. Although it is particularly oriented towards reduction of
+large scale galaxy-survey data, it can perform reasonably well on moderately
+crowded star fields.
+
+This package produces binaries: ldactoasc, sex")
+ (license license:gpl3)))
+
(define-public stellarium
(package
(name "stellarium")
--
2.30.0
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46072-done@debbugs.gnu.org)
87lfchaquz.fsf@yamatai
Patch pushed as b2d6f127c24787df00bffd918fa879842f933817.
Thanks.
Closed
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46072-done@debbugs.gnu.org)
87im7laqou.fsf@yamatai
Patch pushed as b2d6f127c24787df00bffd918fa879842f933817.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYA77YQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/rygD/X7aj8YLHNOIeBkRuvtJZpdK07TGoCjp7p5hD
NncpoiYBAIg4/9PG2wTP+9D4OFUusRDPJ13GGqB/jUfnVltmzB5u
=RGds
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46072@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46072
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help