[PATCH] Enable riscv-elf targets

  • Open
  • quality assurance status badge
Details
One participant
  • Ekaitz Zarraga
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal
E
E
Ekaitz Zarraga wrote on 23 Jan 2021 23:00
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ef2YQavtUNwLAlNDfePhAHovSF3ilvjbP2zUxxMQEY7FMwN-yJni9Gvg-9Ad9NbceXHTc6Ii7NxNURiAZRucsgipeuIrAdNtOKGUwcYg8jU=@elenq.tech
Hi,

I've been struggling to make a RISC-V cross compiler. This `manifest.scm`
file failed to create because there was no available dynamic linker for
the targets which, in the end, don't need any dynamic linker:

manifest.scm:

``` scm

(use-modules (gnu packages cross-base)
(gnu packages embedded)
(gnu packages man))

(packages->manifest
`(,@(let* ((triplet "riscv32-unknown-elf")
(binutils (cross-binutils triplet)))
(list
binutils
(cross-gcc triplet
#:xbinutils binutils
#:libc #f)))
,man-db))
```

I realized there were some targets missing (and there are more!) in the
bootstrap.scm file, so I think adding them is harmless and lets us
make cross compilers that are not available otherwise.

I'd like to add riscv32-linux too, but that involves setting the correct
path and I don't know it.

Hope this patch is helpful.


From 58785556b7448cfe32916d3842bce398b360c2de Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sat, 23 Jan 2021 22:50:44 +0100
Subject: [PATCH] gnu: glibc-dynamic-linker: Add riscv*-elf targets

* gnu/packages/bootstrap.scm: (glibc-dynamic-linker): Set
riscv64-*-elf targets to "no-ld"
---
gnu/packages/bootstrap.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (13 lines)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index c39e60ec8b..8566d11284 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -302,6 +302,8 @@ or false to signal an error."
((string=? system "i686-mingw") "no-ld.so")
((string=? system "x86_64-mingw") "no-ld.so")
((string=? system "vc4-elf") "no-ld.so")
+ ((string=? system "riscv32-elf") "no-ld.so")
+ ((string=? system "riscv64-elf") "no-ld.so")

(else (error "dynamic linker name not known for this system"
system))))
--
2.29.2
E
E
Ekaitz Zarraga wrote on 24 Jan 2021 00:24
More info about other targets
(name . 46059@debbugs.gnu.org)(address . 46059@debbugs.gnu.org)
e3TytODU43fkggM5x-oJDvoJ24yGpW0XSP1jG-cjpjZ2m8IrOLNUyYg4dAsB95Ybn4D_XUsFDSePo_16EgP5pJFMLTjxwTzV2J30GmuFzhQ=@elenq.tech
This issue from RISC-V GNU Toolchain has more information
related with the issue described:

E
E
Ekaitz Zarraga wrote on 24 Jan 2021 18:09
(name . 46059@debbugs.gnu.org)(address . 46059@debbugs.gnu.org)
euzuHrOCrTT08ndLCWn3g5284aI_IyG52OUCGgO_X8sVp_x7WIVlQPnPhTqwlKICORiIoUYm0fpOAgPAw6ynK48RpeIv3bx6GHu70KEpOEk=@elenq.tech
For more information on the dynamic linker names I didn't know:

lp32, ilp32f and ilp32d are the ABI.

i -> integer
l -> long
p -> pointer
f -> float
d -> double

The chars in the beginning indicate what kind of data is sent to 32 bit registers.

The suffix says which ones are sent to floating point registers.

So in ilp32 floating point numbers are sent to integer registers, while in ilp32d double precision numbers are sent to floating point registers.

Not every ABI is compatible with every single RISC-V configuration. RV32I for instance, doesn't support floating point numbers (they are supported in the F extension) so it doesn't provide floating point registers meaning that it's not able to use any ABI that has a `d` or an `f` as suffix.

But RISC-V configurations with floating point modules can actually run the simplest ABI if they want so we probably need to add many entries here :)

Does this make sense?
?