[PATCH] Add drill gnu/packages/rust-apps.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5pFcsuS2-t7dMJiBng1rdXd2usCuDEP7ePh0gbEpr9rNw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 94b41edb0ffcd4f52bd88c9fc2ada02ea2be1995 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 20 Jan 2021 15:26:52 +0000
Subject: [PATCH] Add drill

* gnu/packages/rust-apps.scm (drill) new variable
---
gnu/packages/rust-apps.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 3745a8377c..df13c8ae55 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.ccom>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,47 @@ highlighting for a large number of languages, git integration, and automatic
paging.")
(license (list license:expat license:asl2.0))))
+(define-public drill
+ (package
+ (name "drill")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "drill" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1m73d7rzi0p5c1hn0081d2235kcyapdza7h0vqf5jhnirpnjn793"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-colored" ,rust-colored-1)
+ ("rust-csv" ,rust-csv-1)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-linked-hash-map" ,rust-linked-hash-map-0.5)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-reqwest" ,rust-reqwest-0.10)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-url" ,rust-url-2)
+ ("rust-yaml-rust" ,rust-yaml-rust-0.4))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/fcsonline/drill")
+ (synopsis "HTTP load testing application")
+ (description
+ "Drill is a HTTP load testing application written in Rust inspired by
+Ansible syntax. Benchmark files can be written in YAML.")
+ (license license:gpl3)))
+
(define-public exa
(package
(name "exa")
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 46007-done@debbugs.gnu.org)
87zh0zevk8.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/rust-apps.scm (drill) new variable

I tweaked the commit message and applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 46007@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46007
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help