[PATCH] gnu: Add python-lmso-algorithm.

  • Done
  • quality assurance status badge
Details
3 participants
  • phodina
  • Adam Kandur
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 20 Jan 2021 11:12
(name . Guix Patches)(address . guix-patches@gnu.org)
MRUGtYQ--3-2@tuta.io
master de26d8049032567fd97db310941c6b9c4b06bceb
Author:     Adam Kandur <rndd@tuta.io>
AuthorDate: Wed Jan 20 12:56:31 2021 +0300
Commit:     Adam Kandur <rndd@tuta.io>
CommitDate: Wed Jan 20 12:56:31 2021 +0300

Parent:     100a4f8 gnu: Add pgloader.
Merged:     master
Contained:  master

gnu: Add python-lmso-algorithm.

* gnu/packages/python-xyz.scm (python-lmso-algorithm): New variable.

1 file changed, 32 insertions(+)
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++

modified   gnu/packages/python-xyz.scm
@@ -9675,6 +9675,38 @@ a hash value.")
 applications from a list of lists of strings.  It supports multi-line rows.")
     (license license:expat)))
 
+(define-public python-lmso-algorithm
+  (package
+    (name "python-lmso-algorithm")
+    (version "1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alexgrusu/lmso_algorithm")
+             (commit "463699946d1805c6898ae9789370b1e8a122ccda")))
+       (file-name (git-file-name name version))
+       (sha256 "122kyd1m0l1x79x0sp201bgbg7sb36c2dz7cranbf8g6m69f4w68")))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'delete-egg
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Delete the .egg-info directory, to avoid build errors
+             (delete-file-recursively "lmso_algorithm.egg-info"))))))
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)
+       ("python-scipy" ,python-scipy )))
+    (synopsis "An optimized LMS algorithm")
+    (description "The least-mean-square (LMS) and the normalized least-mean-square (NLMS)
+algorithms require a trade-off between fast convergence and low misadjustment, obtained
+by choosing the control parameters.  In general, time variable parameters are proposed
+according to different rules.  Many studies on the optimization of the NLMS algorithm imply
+time variable control parameters according some specific criteria.")
+    (license license:gpl3)))
+
 (define-public python-libarchive-c
   (package
     (name "python-libarchive-c")
P
P
phodina wrote on 3 Nov 2021 21:16
Re: [PATCH v2] gnu: Add python-lmso-algorithm.
(name . 46005@debbugs.gnu.org)(address . 46005@debbugs.gnu.org)
z-Rfy350-5RP6T_0iWuIto2uo-b53IRCIIuuwySTv1bBX6OH2eYFh_dRtsAJdZ7X-1aOqvbnLZMFodS6j53MVtNeAoUE1RJmtiFj7aJ-3Io=@protonmail.com
Hi Adam,

here's the reworked patch.

Petr

Toggle snippet (49 lines)
* gnu/packages/python-xyz.scm (python-lmso-algorithm): New variable.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d6b403d4..1d70cd6f2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13440,6 +13440,39 @@ (define-public python-lmfit
enhancements to optimization and data fitting problems.")
(license license:bsd-3)))

+(define-public python-lmso-algorithm
+ (let ((commit "463699946d1805c6898ae9789370b1e8a122ccda")
+ (revision "1"))
+ (package
+ (name "python-lmso-algorithm")
+ (version (git-version "1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alexgrusu/lmso_algorithm")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256 "122kyd1m0l1x79x0sp201bgbg7sb36c2dz7cranbf8g6m69f4w68")))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'delete-egg
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Delete the .egg-info directory, to avoid build errors
+ (delete-file-recursively "lmso_algorithm.egg-info"))))))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy )))
+ (home-page "https://github.com/alexgrusu/lmso_algorithm")
+ (synopsis "Optimized LMS algorithm")
+ (description "This package provides an optimized least-mean-square (LMSO)
+algorithm. The proposed algorithm follows an optimization problem and
+introduces a variable step-size in order to minimize the system
+misalignment.")
+ (license license:gpl3))))
+
(define-public python-boto
(package
(name "python-boto")
--
2.33.1
S
S
Sharlatan Hellseher wrote 5 days ago
[PATCH] gnu: Add python-lmso-algorithm.
(address . 46005-done@debbugs.gnu.org)
87v7togq94.fsf@gmail.com
Hi,

The project is not active for 6y (now is 2025), no release and no

Closing as not applied.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmejuBcACgkQdtcnv/Ys
0rVXZA/+Iq6LMM3ocPKLH+uCWAA92KoF+fBfjWc6WFM744qj4d+xe28S/nk+pRXm
v+FUf4DsCpTEczUZDQ5m+BPrlkTZbRl5JbWZrJhI0h98PZP3UqZbdMNqXCEhlaaQ
lFB6kFrZmuIihv215R9b+8WYHcBMEuRUT3rFy/Fq5x6/50N+jL8TS1FOXlPICWOt
PHUm4xjch2ARIeuKWzEs2UhW/waqjsRruGq3kyP6eQQ4msMqSwre2KCbQTFicrC1
U8F4vM2z1iO6Cp1oeOHnFmrUnLRKgvTgN3sN7XCP+RAqqlBoI4HFJRt3u3+275c9
iR1hbN1NDDea6BkPjBl0O04IImC0/hIohd+npnMkHR3B7DB7laiKk3ErTx0tqxTd
cY0n6++3hXYeiCMZlDv1rbJys2YDFgIn6l7BiL92qG7ALexRY0zb4YNF8DhHtd6g
n/N9fY7uJ8hEUTl2PIoJb27L1T76LpL0xq0i+0UBt5R1GQpYbiMriZfnLaKiDOHx
1ZcUpEummPJolMofT3zLz5+QpzAaSMBCNOD1HPCVbcUQitPYdrE8C+dlhgr0tl62
RH2VBL8wW3HRR3At49HN4ssxBiBZopDaY6/Qvu/pkq0MVXrZIpYu4B7l8Utio8BL
kMCUO3fRMUDqiYjM1eSN1AxZ5dL8uF2/N/xFnuCaAIGnYm9k0PU=
=A3RA
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 46005@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 46005
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch