(name . Guix Patches)(address . guix-patches@gnu.org)
master de26d8049032567fd97db310941c6b9c4b06bceb
Author: Adam Kandur <rndd@tuta.io>
AuthorDate: Wed Jan 20 12:56:31 2021 +0300
Commit: Adam Kandur <rndd@tuta.io>
CommitDate: Wed Jan 20 12:56:31 2021 +0300
Parent: 100a4f8 gnu: Add pgloader.
Merged: master
Contained: master
gnu: Add python-lmso-algorithm.
* gnu/packages/python-xyz.scm (python-lmso-algorithm): New variable.
1 file changed, 32 insertions(+)
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
modified gnu/packages/python-xyz.scm
@@ -9675,6 +9675,38 @@ a hash value.")
applications from a list of lists of strings. It supports multi-line rows.")
(license license:expat)))
+(define-public python-lmso-algorithm
+ (package
+ (name "python-lmso-algorithm")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "463699946d1805c6898ae9789370b1e8a122ccda")))
+ (file-name (git-file-name name version))
+ (sha256 "122kyd1m0l1x79x0sp201bgbg7sb36c2dz7cranbf8g6m69f4w68")))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'delete-egg
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Delete the .egg-info directory, to avoid build errors
+ (delete-file-recursively "lmso_algorithm.egg-info"))))))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy )))
+ (home-page "https://github.com/alexgrusu/lmso_algorithm")
+ (synopsis "An optimized LMS algorithm")
+ (description "The least-mean-square (LMS) and the normalized least-mean-square (NLMS)
+algorithms require a trade-off between fast convergence and low misadjustment, obtained
+by choosing the control parameters. In general, time variable parameters are proposed
+according to different rules. Many studies on the optimization of the NLMS algorithm imply
+time variable control parameters according some specific criteria.")
+ (license license:gpl3)))
+
(define-public python-libarchive-c
(package
(name "python-libarchive-c")