(address . bug-guix@gnu.org)
Hi Guix,
I believe that this is a feature request. I would like to create a Guix
qcow2 image to run as a VM. Additionally, I would like the root file
system to be btrfs. Therefore, I created an operating system definition
with the following file-systems:
```
(file-systems (cons (file-system
(mount-point "/")
(device "/dev/vda1")
(type "btrfs")
(flags '(no-atime))
(options "compress=zstd"))
%base-file-systems))
```
I then ran `guix system vm-image --image-size=10G --volatile config.scm`.
That successfully created a qcow2 image, but the root file system was ext4
instead of btrfs.
Ideally, I would get an image with a btrfs filesystem. I expect supporting
all combinations of filesystems and mapped devices might be challenging
for the image creation process, but some more options might be
interesting. At the very least, I think a warning or error when the
requested configuration is not supported would be appropriate.
What do you think about this feature?
Best,
Jack