[PATCH 0/3] Add zplugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Leo Famulari
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 4 years ago
(address . guix-patches@gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210116174829.9265-1-alex@zrythm.org
Hi,

This patch series adds zplugins, an LV2 plugin collection.

First, it moves some dependencies of ztoolkit and ztoolkit-rsvg from
inputs to propagated-inputs because those are pkgconfig dependencies
for ztoolkit. Librsvg does something similar.

Then, zlfo is deprecated because it is now included in zplugins.

Thanks,
Alex

Alexandros Theodotou (3):
gnu: ztoolkit: Move dependencies to propagated-inputs.
gnu: ztoolkit-rsvg: Move dependencies to propagated-inputs.
gnu: Add zplugins.

gnu/packages/audio.scm | 12 +++++++-----
gnu/packages/music.scm | 37 +++++++++++++++++++++----------------
2 files changed, 28 insertions(+), 21 deletions(-)

--
2.30.0
Alexandros Theodotou wrote 4 years ago
[PATCH 1/3] gnu: ztoolkit: Move dependencies to propagated-inputs.
(address . 45918@debbugs.gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210116175227.9510-1-alex@zrythm.org
* gnu/packages/audio.scm (ztoolkit): Move dependencies to propagated
inputs.
[inputs]: Remove cairo, libx11.
[propagated-inputs]: Add cairo, libx11.
---
gnu/packages/audio.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2e46dc3a26..9a9168c2d4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4829,11 +4829,13 @@ with the provided metadata and adhere to well-known best practices.")
(base32
"07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
(build-system meson-build-system)
- (inputs
- `(("cairo" ,cairo)
- ("libx11" ,libx11)))
(native-inputs
`(("pkg-config" ,pkg-config)))
+ ;; These are listed as propagated inputs because they are dependencies
+ ;; in pkgconfig.
+ (propagated-inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
(synopsis "GUI toolkit for LV2 plugins")
(description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
inspired by GTK. It handles events and low level drawing on behalf of
--
2.30.0
Alexandros Theodotou wrote 4 years ago
[PATCH 2/3] gnu: ztoolkit-rsvg: Move dependencies to propagated-inputs.
(address . 45918@debbugs.gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210116175227.9510-2-alex@zrythm.org
* gnu/packages/audio.scm (ztoolkit-rsvg): Move dependencies to propagated
inputs.
[inputs]: Remove librsvg.
[propagated-inputs]: Add librsvg.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9a9168c2d4..0ec163e932 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4884,9 +4884,9 @@ edited, converted, compressed and saved.")
(name "ztoolkit-rsvg")
(arguments
`(#:configure-flags `("-Denable_rsvg=true")))
- (inputs
+ (propagated-inputs
`(("librsvg" ,librsvg)
- ,@(package-inputs ztoolkit)))
+ ,@(package-propagated-inputs ztoolkit)))
(synopsis "ZToolkit with SVG support")))
(define-public lsp-dsp-lib
--
2.30.0
Alexandros Theodotou wrote 4 years ago
[PATCH 3/3] gnu: Add zplugins.
(address . 45918@debbugs.gnu.org)(name . Alexandros Theodotou)(address . alex@zrythm.org)
20210116175227.9510-3-alex@zrythm.org
* gnu/packages/music.scm (zplugins): New variable.
---
gnu/packages/music.scm | 37 +++++++++++++++++++++----------------
1 file changed, 21 insertions(+), 16 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2fe5e2081a..9d9d50eab5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5932,34 +5932,39 @@ hall reverb and a room reverb. Both are available as LV2 plugins as well
as JACK standalone applications.")
(license license:gpl3+)))
-(define-public zlfo
+(define-public zplugins
(package
- (name "zlfo")
- (version "0.1.3")
+ (name "zplugins")
+ (version "0.1.7")
(source
(origin
(method git-fetch)
- (uri (git-reference
- (url "https://git.zrythm.org/git/ZLFO")
- (commit (string-append "v" version))))
+ (uri
+ (git-reference
+ (url "https://git.zrythm.org/git/zplugins")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
+ "1rkm2xajmyik6289b20rp5a5br9f3sh1xk8nb1bs6qpmcrfirgbs"))))
(build-system meson-build-system)
(inputs
- `(("librsvg" ,librsvg)
- ("lv2" ,lv2)
- ("ztoolkit-rsvg" ,ztoolkit-rsvg)))
+ `(("guile" ,guile-2.2)
+ ("libsndfile" ,libsndfile)
+ ("lv2" ,lv2)
+ ("ztoolkit-rsvg" ,ztoolkit-rsvg)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (synopsis "Low frequency oscillator plugin")
- (description "ZLFO is a fully featured
-@dfn{low frequency oscillator} (LFO) for @dfn{control voltage} (CV)-based
-automation that comes as an LV2 plugin bundle with a custom UI.")
- (home-page "https://git.zrythm.org/cgit/ZLFO/")
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Audio plugin collection")
+ (description "ZPlugins is a collection of audio DSP plugins intended
+to be bundled with the Zrythm @dfn{digital audio workstation} (DAW).")
+ (home-page "https://www.zrythm.org/en/plugins.html")
(license license:agpl3+)))
+(define-public zlfo
+ ;; The "zlfo" package is now included in zplugins
+ (deprecated-package "zlfo" zplugins))
+
(define-public remid-lv2
(package
(name "remid-lv2")
--
2.30.0
Leo Famulari wrote 4 years ago
Re: [bug#45918] [PATCH 0/3] Add zplugins.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 45918-done@debbugs.gnu.org)
YBii6DkendYPvaBT@jasmine.lan
On Sat, Jan 16, 2021 at 05:48:29PM +0000, Alexandros Theodotou wrote:
Toggle quote (18 lines)
> Hi,
>
> This patch series adds zplugins, an LV2 plugin collection.
>
> First, it moves some dependencies of ztoolkit and ztoolkit-rsvg from
> inputs to propagated-inputs because those are pkgconfig dependencies
> for ztoolkit. Librsvg does something similar.
>
> Then, zlfo is deprecated because it is now included in zplugins.
>
> Thanks,
> Alex
>
> Alexandros Theodotou (3):
> gnu: ztoolkit: Move dependencies to propagated-inputs.
> gnu: ztoolkit-rsvg: Move dependencies to propagated-inputs.
> gnu: Add zplugins.

Thanks! I tweaked the commit messages a bit and pushed as
5b5915560e5cbd546c005a950515f6d293442a28
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45918@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45918
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help