[PATCH] gnu: xpra: Update to 4.0.6.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210115232058.31809-1-mike@rohleder.de
* gnu/packages/xorg.scm (xpra): Update to 4.0.6.
[inputs]: Add libx264, x265, libvpx to have more encoding options.
---
gnu/packages/xorg.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8f84b894f6..900f6c925d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
;;;
@@ -6279,14 +6279,14 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "4.0.5")
+ (version "4.0.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.xpra.org/src/xpra-"
version ".tar.xz"))
(sha256
- (base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
+ (base32 "1s49y2s75a8a70vj0micnmpic5zv1n32yjxy8fkxsqa6j5njyrww"))
(patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
(build-system python-build-system)
;; see also http://xpra.org/trac/wiki/Dependencies
@@ -6313,6 +6313,9 @@ basic eye-candy effects.")
("xf86-input-keyboard" ,xf86-input-keyboard)
("python-pillow" ,python-pillow)
;; Optional dependencies.
+ ("libx264" ,libx264)
+ ("x265" ,x265)
+ ("libvpx" ,libvpx)
("python-rencode" ,python-rencode) ; For speed.
("python-numpy" ,python-numpy)
("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
--
2.30.0
Efraim Flashner wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45908@debbugs.gnu.org)
YAVavo31oHMkOMUV@3900XT
Does this build without the extra inputs? If so, can you split this into
two patches, one for the upgrade and one to add the extra inputs?
Thanks!

On Sat, Jan 16, 2021 at 12:20:58AM +0100, Michael Rohleder wrote:
Toggle quote (53 lines)
> * gnu/packages/xorg.scm (xpra): Update to 4.0.6.
> [inputs]: Add libx264, x265, libvpx to have more encoding options.
> ---
> gnu/packages/xorg.scm | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 8f84b894f6..900f6c925d 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -23,7 +23,7 @@
> ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
> ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
> ;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
> -;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
> +;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
> ;;;
> @@ -6279,14 +6279,14 @@ basic eye-candy effects.")
> (define-public xpra
> (package
> (name "xpra")
> - (version "4.0.5")
> + (version "4.0.6")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://www.xpra.org/src/xpra-"
> version ".tar.xz"))
> (sha256
> - (base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
> + (base32 "1s49y2s75a8a70vj0micnmpic5zv1n32yjxy8fkxsqa6j5njyrww"))
> (patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
> (build-system python-build-system)
> ;; see also http://xpra.org/trac/wiki/Dependencies
> @@ -6313,6 +6313,9 @@ basic eye-candy effects.")
> ("xf86-input-keyboard" ,xf86-input-keyboard)
> ("python-pillow" ,python-pillow)
> ;; Optional dependencies.
> + ("libx264" ,libx264)
> + ("x265" ,x265)
> + ("libvpx" ,libvpx)
> ("python-rencode" ,python-rencode) ; For speed.
> ("python-numpy" ,python-numpy)
> ("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
> --
> 2.30.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmAFWrsACgkQQarn3Mo9
g1EBMBAAmfDVy9EZjEbED6/hWodAwIyxtS0nejP/Z80haYcB6NgtJyWy8MWdsqjs
nHbMo7gc7Djrss1KN0CA5c3T8OsieqPO2ZUhnnPSGXxfghzo37Ce9LnTB3BY5nKs
iLeamDIrMSr2g7ZXkLJOOQeyTktgANaLzNCvvC4VdiwNbz8rXHbcerkMs8XePha4
nOXWlh8BU0b90AlrWVySBS6FeUEjg2XzEAffU7F666ggluc2LrKU9xwcrCj3DhIq
Ea+hMSTQS3vdueA7n5cjmuH7KitWZDUUu3vW5OCS6g0cm6Ok/cXzvRc/u0Ud7Spl
7FHhm2px3fX9wuRHzwLPFybpmiHy3SxUq9Z8Ap3PcWlicjr2fmtlGA+kII3h4LBz
s17+7b4IXGFOOV1AzUDgD2sESCOP/QKq4IB7BUk8ZcaKWUJy+ZpHXS7qgDm7jyRm
yX0RmzSPrs4XPFidR2jApK81FL6y9Akn/cBwZHBPkVbE0zEGuoB0hNfgIzUF5mK0
/WcuU0Ipq0M050I0iffne/U6xIqnvq2XST56GS0mUyKEUatO+SSyQjwUuABmCYQe
W7UOKM8EyjgMDjkfUGmtjXltnp2qIp63c5ahrIW14TxscPBupPUWlKx7rbOC0/qC
PlhAbTqaAn7YFX2leYMzfjbnVo5ZfK91MVjNHir++NLhj1KEAy4=
=CJhp
-----END PGP SIGNATURE-----


Michael Rohleder wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 45908@debbugs.gnu.org)
87czy2grkp.fsf@rohleder.de
Hi Efraim,

Thank you for reviewing!

Efraim Flashner <efraim@flashner.co.il> writes:
Toggle quote (3 lines)
> Does this build without the extra inputs? If so, can you split this into
> two patches, one for the upgrade and one to add the extra inputs?

Yes, they are independent.
Toggle quote (1 lines)
>From 974edd786f172acdb374111468d37cd6ec8d51aa Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Mon, 18 Jan 2021 16:45:29 +0100
Subject: [PATCH] gnu: xpra: Update to 4.0.6.

* gnu/packages/xorg.scm (xpra): Update to 4.0.6.
---
gnu/packages/xorg.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8f84b894f6..ef80b10e3a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
;;;
@@ -6279,14 +6279,14 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "4.0.5")
+ (version "4.0.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.xpra.org/src/xpra-"
version ".tar.xz"))
(sha256
- (base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
+ (base32 "1s49y2s75a8a70vj0micnmpic5zv1n32yjxy8fkxsqa6j5njyrww"))
(patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
(build-system python-build-system)
;; see also http://xpra.org/trac/wiki/Dependencies
--
2.30.0
Toggle quote (1 lines)
>From 985e711a6d5b7c6306841bdc7a90686556228366 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Mon, 18 Jan 2021 16:53:26 +0100
Subject: [PATCH] gnu: xpra: Add more encoding options.

* gnu/packages/xorg.scm (xpra)[inputs]: Add libx264, x265, libvpx.
---
gnu/packages/xorg.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8f84b894f6..c2fbba7e67 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6313,6 +6313,9 @@ basic eye-candy effects.")
("xf86-input-keyboard" ,xf86-input-keyboard)
("python-pillow" ,python-pillow)
;; Optional dependencies.
+ ("libx264" ,libx264)
+ ("x265" ,x265)
+ ("libvpx" ,libvpx)
("python-rencode" ,python-rencode) ; For speed.
("python-numpy" ,python-numpy)
("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
--
2.30.0
--
APL is a mistake, carried through to perfection. It is the language of the
future for the programming techniques of the past: it creates a new generation
of coding bums.
-- Edsger W. Dijkstra, SIGPLAN Notices, Volume 17, Number 5
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmAFsWYRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyXG2wgAnhlpiFMBdPWMveHqJMz0e45HpMv02TJw
hKpxeHBO88JIDdxPfGgZub6sEZI9/j39Rye3ZCDCx5hlrw8gBZVL3269lpY7AqFg
gLRUdKaqhHjS+1nvhrhD42gZCrTnC2EC6Hi2cU44chd7tWoPce8moxn+K0utfk+S
qg+qzD77VDByBg/ylLTVouNXVlx5YPWIaEU/GzW5yEy/mPiOgmGYWqA0btBDWPjD
NBO9wk6sLTepDNf6ziOXj9F/RYyjDWX3kbbVVtldyhw4pwPkfNwOMLQyYkMWcv24
Nh+/001cwflHPTNS4AiOWkwc/Y8J0kVp0tO7/tSGk1Vjx8n27gRu3Q==
=o6rL
-----END PGP SIGNATURE-----

Efraim Flashner wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45908-done@debbugs.gnu.org)
YAaQS+1Xk6MckXl6@3900XT
Thanks. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmAGkEsACgkQQarn3Mo9
g1ETyg/8CPeXIRQYobt+/y1VzJt+NRAPti5vQKoh1VYtLRKgMuftm2Flqgl76U/R
w91FUaQrf2YXaC/iqG7hqOki+AulCkNaXOXwPG1BCqeFZG5Q84vL5i/Y1XaCjHo7
Q5TycKegu1tGLWi2nS+mgkMtQsto2vbtcCJmUIF/7VckIu5aFACtwQHVwEsJ/e7R
iGypMy3sVBdioXNnGrjLAoB1UNyMPIHLfi4nddY1qjKx3wm0hhAeNeAtIss/FXjr
EY+NsvD+EkYKAH3uMdUfZIP1IGIEPB54ZtIFc8Dq7qViHbeAUE0T5S2nvUMnftg3
5HtQoratR+j1vCzFYRlcM5SdRQmOFLNza53LWE5m2E40dabBt4pNnx2je5fjFSR0
s0fbESACFSdu3CAUuFHYMYvjvF21HB8TLVtIzf8JVm8NEg9iEa5rG3I4AXgQhIbe
pKEauENdH+aqdDa5RI5IBHXFo6mZr4DciJmVdWF39/BuivJXAA5ecBj6P0ODAfba
+e3clyLJI5/38Z8EeQGjzj6wcZtdor98HFTX82WdI4stELiBZj4z60ygaiyW1g4m
JeYDRs+4NzcnRsywO0I1/53hWB7YYTVy8WwqE987jOJc9tjOid4A8LpA9KjU1dJX
cqJvchd7xnqUzKp/qNEhmqjjbqw0na5dGBiYU7asKP2pakPlPZ4=
=+bZV
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45908@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45908
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help