[PATCH] gnu: emacs-calibredb: Patch paths to calibre programs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210115015802.571-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-calibredb): Patch paths to calibre programs.
[arguments]: Add phase patch-paths.
[inputs]: Add calibre.
---
gnu/packages/emacs-xyz.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e35a29cdc3..19db9278c5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -131,6 +131,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages dictionaries)
#:use-module (gnu packages djvu)
+ #:use-module (gnu packages ebook)
#:use-module (gnu packages emacs)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
@@ -22694,6 +22695,21 @@ through Dash docsets.")
(sha256
(base32 "19gc05k2p1l8wlkrqij9cw6d61hzknd6a9n64kzlpi87cpbav3lv"))))
(build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((calibre (assoc-ref inputs "calibre")))
+ (make-file-writable "calibredb-core.el")
+ (emacs-substitute-variables "calibredb-core.el"
+ ("calibredb-program"
+ (string-append calibre "/bin/calibredb"))
+ ("calibredb-fetch-metadata-program"
+ (string-append calibre "/bin/fetch-ebook-metadata"))))
+ #t)))))
+ (inputs
+ `(("calibre" ,calibre)))
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
("emacs-s" ,emacs-s)
--
2.30.0
Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45880-done@debbugs.gnu.org)
87mtxadjgq.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-calibredb): Patch paths to calibre programs.
> [arguments]: Add phase patch-paths.
> [inputs]: Add calibre.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help