Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/xfce.scm (xfconf)[arguments]: Add install-shell-completions phase.
---
gnu/packages/xfce.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (20 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a5c9482c01..00befc517d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -155,6 +155,13 @@ Xfce Desktop Environment.")
;; For the missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(invoke "dbus-launch" "make" "check")))
+ (add-after 'custom-check 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (with-directory-excursion "completions"
+ (install-file "xfconf-query"
+ (string-append etc "/bash_completion.d"))))))
(delete 'check))))
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.30.0