[PATCH] gnu: Add r-snapatac.

  • Open
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210114195744.15053-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-snapatac): New variable.
---
gnu/packages/bioinformatics.scm | 51 ++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 512abcd8fd..6be82773ac 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019, 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019, 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
@@ -7073,6 +7073,55 @@ sequence.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))
+(define-public r-snapatac
+ (package
+ (name "r-snapatac")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/r3fang/SnapATAC")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "037jzlbl436fi7lkpq7d83i2vd1crnrik3vac2x6xj75dbikb2av"))))
+ (properties `((upstream-name . "SnapATAC")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bigmemory" ,r-bigmemory)
+ ("r-doparallel" ,r-doparallel)
+ ("r-dosnow" ,r-dosnow)
+ ("r-edger" ,r-edger)
+ ("r-foreach" ,r-foreach)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-igraph" ,r-igraph)
+ ("r-iranges" ,r-iranges)
+ ("r-irlba" ,r-irlba)
+ ("r-matrix" ,r-matrix)
+ ("r-plyr" ,r-plyr)
+ ("r-plot3d" ,r-plot3d)
+ ("r-rann" ,r-rann)
+ ("r-raster" ,r-raster)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rhdf5" ,r-rhdf5)
+ ("r-rtsne" ,r-rtsne)
+ ("r-scales" ,r-scales)
+ ("r-viridis" ,r-viridis)))
+ (home-page "https://github.com/r3fang/SnapATAC")
+ (synopsis "Single nucleus analysis package for ATAC-Seq")
+ (description
+ "This package provides a fast and accurate analysis toolkit for single
+cell ATAC-seq (Assay for transposase-accessible chromatin using sequencing).
+Single cell ATAC-seq can resolve the heterogeneity of a complex tissue and
+reveal cell-type specific regulatory landscapes. However, the exceeding data
+sparsity has posed unique challenges for the data analysis. This package
+@code{r-snapatac} is an end-to-end bioinformatics pipeline for analyzing large-
+scale single cell ATAC-seq data which includes quality control, normalization,
+clustering analysis, differential analysis, motif inference and exploration of
+single cell ATAC-seq sequencing data.")
+ (license license:gpl3)))
+
(define-public r-scde
(package
(name "r-scde")
--
2.30.0
Ricardo Wurmus wrote 4 years ago
(address . 45873@debbugs.gnu.org)(name . Patrascu, Madalin Ionel)(address . MadalinIonel.Patrascu@mdc-berlin.de)
87bldrccem.fsf@elephly.net
Hi Madalin,

thanks for the patch. It looks good to me but I have a few questions.

The README file claims that the Python Snaptools must be installed.
This package does not do this, so I suppose the package will fail when
it’s run in an environment that does not have the Snaptools on the PATH.

Do you happen to have a package definition for the Snaptools as well, so
that we could either propagate it or patch r-snapatac to retain
references to the executables it provides?

I also see references to Homer and other bioinfo tools, which are not
provided by this package and which are not found among the inputs. Does
it make sense to install this package when these tools are not
available?

--
Ricardo
Ludovic Courtès wrote 4 years ago
control message for bug #45873
(address . control@debbugs.gnu.org)
87mtuyc09k.fsf@gnu.org
tags 45873 + moreinfo
quit
Simon Tournier wrote 3 weeks ago
Re: [bug#45873] [PATCH] gnu: Add r-snapatac.
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 45873@debbugs.gnu.org)(name . Patrascu, Madalin Ionel)(address . MadalinIonel.Patrascu@mdc-berlin.de)
8734g7eyka.fsf@gmail.com
Hi Ricardo, Madalin,

Thanks for the submission.

For reference of this old submission:


On Fri, 15 Jan 2021 at 00:43, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (9 lines)
> Do you happen to have a package definition for the Snaptools as well, so
> that we could either propagate it or patch r-snapatac to retain
> references to the executables it provides?
>
> I also see references to Homer and other bioinfo tools, which are not
> provided by this package and which are not found among the inputs. Does
> it make sense to install this package when these tools are not
> available?

Well, what is the status? Is it still relevant? Or closing?

Cheers,
simon
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 45873@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45873
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help