Add embree and update Blender

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Leo Famulari
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 4 years ago
(address . guix-patches@gnu.org)
87pn2761bn.fsf@dustycloud.org
Two patches attached. Embree seems necessary for the newer Blender.

(Sadly newer Blender also still has graphics crashes on my GPU. Wah!
Well, enjoy to those of you who can.)
From f584d5784087e2a795c9be28294582b3ca79f085 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 13 Jan 2021 14:45:39 -0500
Subject: [PATCH 1/2] gnu: Add embree.

* gnu/packages/graphics.scm (embree): New variable.
---
gnu/packages/graphics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index def3dc6913..09cf47b66a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -428,6 +428,36 @@ with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
(license (list license:gpl2+ ;for the utility itself
license:lgpl2.1+))))) ;for use as a library
+(define-public embree
+ (package
+ (name "embree")
+ (version "3.12.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/embree/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aznd16n7h8g3f6jcahzfp1dq4r7wayqvn03wsaskiq2dvsi4srd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests (apparently)
+ #:configure-flags
+ (list
+ "-DEMBREE_ISPC_SUPPORT=OFF")))
+ (inputs
+ `(("tbb" ,tbb)
+ ("glfw" ,glfw)))
+ (home-page "https://www.embree.org/")
+ (synopsis "High performance ray tracing kernels")
+ (description
+ "Embree is a collection of high-performance ray tracing kernels.
+Embree is meant to increase performance of photo-realistic rendering
+applications.")
+ (license license:asl2.0)))
+
(define-public blender
(package
(name "blender")
--
2.30.0
From ce00650a374bd4a4bb866e5492dd2483222323f8 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 13 Jan 2021 14:46:23 -0500
Subject: [PATCH 2/2] gnu: blender: Update to 2.91.0.

* gnu/packages/graphics.scm (blender): Update to 2.91.0 and add embree as a
dependency.
---
gnu/packages/graphics.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 09cf47b66a..01f0671ddc 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -461,14 +461,14 @@ applications.")
(define-public blender
(package
(name "blender")
- (version "2.83.9")
+ (version "2.91.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "106w9vi6z0gi2nbr73g8pm40w3wn7dkjcibzvvzbc786yrnzvkhb"))))
+ "0x396lgmk0dq9115yrc36s8zwxzmjr490sr5n2y6w27y17yllyjm"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -540,7 +540,8 @@ applications.")
("python" ,python)
("python-numpy" ,python-numpy)
("tbb" ,tbb)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("embree" ,embree)))
(home-page "https://blender.org/")
(synopsis "3D graphics creation suite")
(description
--
2.30.0
Leo Famulari wrote 4 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 45861-done@debbugs.gnu.org)
YANP0B6R+IMKl2iK@jasmine.lan
On Thu, Jan 14, 2021 at 09:27:24AM -0500, Christopher Lemmer Webber wrote:
Toggle quote (5 lines)
> Two patches attached. Embree seems necessary for the newer Blender.
>
> (Sadly newer Blender also still has graphics crashes on my GPU. Wah!
> Well, enjoy to those of you who can.)

Thanks! Pushed as 2a333f2535a65bfa3607ef50591e9f5dbc6970d1
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45861@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45861
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help