[PATCH] gnu: genimage: Use GIT-FILE-NAME.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20210114125845.30922-1-vincent.legoll@gmail.com
* gnu/packages/genimage.scm (origin): Use GIT-FILE-NAME.
---
gnu/packages/genimage.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index c9ed6258a0..bd77e4dc33 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2021 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
(uri (git-reference
(url "https://github.com/pengutronix/genimage")
(commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
"15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
--
2.30.0
Mathieu Othacehe wrote 4 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45859-done@debbugs.gnu.org)
874kj9z66p.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/genimage.scm (origin): Use GIT-FILE-NAME.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45859@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45859
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help