[PATCH 1/1] Added a package definition for the C++17 header only library 'magic-enum'.

  • Done
  • quality assurance status badge
Details
2 participants
  • Anadon
  • Leo Prikler
Owner
unassigned
Submitted by
Anadon
Severity
normal
Merged with

Debbugs page

Anadon wrote 4 years ago
(address . guix-patches@gnu.org)(address . 45604@debbugs.gnu.org)(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)
20210114021711.52857-2-joshua.r.marshall.1991@gmail.com
gnu/packages/cpp.scm: Added the package definition.
---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..ff10a4247b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-10)))
+ (synopsis "Header-only C++17 library for reflection for enums")
+ (description "Static reflection for enums (to string, from string,
+iteration) for modern C++, work with any enum type without any macro or
+boilerplate code")
+ (license license:expat)))
--
2.27.0
Leo Prikler wrote 4 years ago
Please don't tag guix-patches in follow-ups
(address . control@debbugs.gnu.org)
b3ee40116e925066349799811038b8813b0332dd.camel@student.tugraz.at
merge 45604 45730 45731 45850 45851 45852 45853
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45851@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45851
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help