[PATCH] gnu/packages/databases.scm freetds

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5onUHorKeQjOQM+9qDTTtgsPyiOktNKjywLH0K6HhkP-g@mail.gmail.com
Hi Guix team!
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 4f1ee596e190ded04bc9c005c48712d41ea6cad2 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 10 Jan 2021 22:24:17 +0000
Subject: [PATCH] gnu: Add freetds

* gnu/packages/databases.scm freetds

I add it as producer of `libsybdb.so` library to build
---
gnu/packages/databases.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6e03724798..48d233a1f6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1943,6 +1943,31 @@ module, and nothing else.")
(license license:perl-license)
(home-page "https://metacpan.org/release/DBD-SQLite")))
+(define-public freetds
+ (package
+ (name "freetds")
+ (version "1.2.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.freetds.org/pub/freetds/stable/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1hspvwxwdd1apadsy2b40dpjik8kfwcvdamvhpg3lnm15n02fb50"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; NOTE: (Sharlatan-20210110213908+0000) some tests require DB connection,
+ ;; disabled for now.
+ `(#:tests? #f))
+ (home-page "http://www.freetds.org/")
+ (synopsis "FreeTDS is a free implementation of Sybase's DB-Library,
+CT-Library, and ODBC libraries")
+ (description
+ "MS SQL and Sybase client library (static libs and headers) FreeTDS is an
+implementation of the Tabular DataStream protocol, used for connecting to MS SQL
+and Sybase servers over TCP/IP.")
+ (license license:lgpl2.0)))
+
(define-public perl-mysql-config
(package
(name "perl-mysql-config")
--
2.26.2
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 45775-done@debbugs.gnu.org)
874kjjamuc.fsf@yamatai
Patch pushed as 0c0a2831b0c114dc5645482dcfef7f69e8a8298f with a few
modifications. Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYAAO2w8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+LnQD/TFFgxKQ7ULgkZhMOktxXQRBPcHmlI1+kn6oh
ywwKhIYA/3zO/c0Go4sBTHpHyAm+FxwhluQFwmblsy1sQxuBpzvT
=W03d
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45775@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45775
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help