emacs-guix segfault on searches with multiple package output results

  • Done
  • quality assurance status badge
Details
3 participants
  • André Alexandre Gomes
  • Christopher Howard
  • John Soo
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 4 years ago
(name . Guix Bug Reports)(address . bug-guix@gnu.org)
0dbbcaceb335979dcebd0b80a1366a35c8346b70.camel@librehacker.com
To reproduce:
- Start emacs
- M-x guix, p, n, gcc-toolchain

Also works searching instead for "mesa", another search that would have
multiple package output results.

Emacs crashes with a segfault:

"""
christopher@nightshade ~$ emacs
Fatal error 11: Segmentation fault
Backtrace:
/home/christopher/.guix-profile/bin/emacs[0x50fe24]
/home/christopher/.guix-profile/bin/emacs[0x41f89c]
/home/christopher/.guix-profile/bin/emacs[0x50e65e]
/home/christopher/.guix-profile/bin/emacs[0x50e8b8]
/home/christopher/.guix-profile/bin/emacs[0x50e92c]
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-
2.31/lib/libpthread.so.0(+0x13010)[0x7f92deb77010]
/home/christopher/.guix-profile/bin/emacs[0x5cfbe8]
/home/christopher/.guix-profile/bin/emacs[0x58282d]
/home/christopher/.guix-profile/bin/emacs[0x5d1c37]
/home/christopher/.guix-profile/bin/emacs[0x5d22e9]
/home/christopher/.guix-profile/bin/emacs[0x5d268e]
/home/christopher/.guix-profile/bin/emacs[0x44fb6c]
/home/christopher/.guix-profile/bin/emacs[0x4537b9]
/home/christopher/.guix-profile/bin/emacs[0x453fca]
/home/christopher/.guix-profile/bin/emacs[0x4560c1]
/home/christopher/.guix-profile/bin/emacs[0x456286]
/home/christopher/.guix-profile/bin/emacs[0x46ea04]
/home/christopher/.guix-profile/bin/emacs[0x47322b]
/home/christopher/.guix-profile/bin/emacs[0x56a726]
/home/christopher/.guix-profile/bin/emacs[0x43fe8c]
/home/christopher/.guix-profile/bin/emacs[0x460008]
/home/christopher/.guix-profile/bin/emacs[0x5019cb]
/home/christopher/.guix-profile/bin/emacs[0x5040ed]
/home/christopher/.guix-profile/bin/emacs[0x50571e]
/home/christopher/.guix-profile/bin/emacs[0x56a68e]
/home/christopher/.guix-profile/bin/emacs[0x4f76cc]
/home/christopher/.guix-profile/bin/emacs[0x56a5fd]
/home/christopher/.guix-profile/bin/emacs[0x4f7674]
/home/christopher/.guix-profile/bin/emacs[0x4fc596]
/home/christopher/.guix-profile/bin/emacs[0x4fc8a4]
/home/christopher/.guix-profile/bin/emacs[0x421725]
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-
2.31/lib/libc.so.6(__libc_start_main+0xed)[0x7f92de8f4a6d]
/home/christopher/.guix-profile/bin/emacs[0x4222ca]
Segmentation fault
"""

System information:

"""
christopher@nightshade ~$ guix describe
Generation 37 Jan 04 2021 07:04:44 (current)
guix 223d8fb
branch: master
commit: 223d8fb4a0e31957c85ef42ef501c8ed038a7259
christopher@nightshade ~$ neofetch --stdout
christopher@nightshade
----------------------
OS: Guix System 223d8fb4a0e31957c85ef42ef501c8ed038a7259 x86_64
Host: GA-880GM-UD2H
Kernel: 5.9.11-gnu
Uptime: 5 days, 54 mins
Packages: 104 (guix-system), 88 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1200
DE: GNOME 3.34.2
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: kitty
CPU: AMD Athlon II X3 455 (3) @ 3.300GHz
GPU: NVIDIA GeForce 8400 GS Rev. 3
Memory: 4669MiB / 7960MiB
"""


--
Christopher Howard
p: +1 (907) 374-0257 (no texting)
gpg: ADDEAADE5D607C8D (keys.gnupg.net)
André Alexandre Gomes wrote 4 years ago
(no subject)
(address . 45758@debbugs.gnu.org)
878s8zx1oq.fsf@gmail.com
I'm also facing this issue on GUI Emacs. For instance, even when one does
(find-file "path/to/any/org/file").

If anyone wants to reproduce:

- emacs -Q
- Help -> Search Documentation -> Emacs Terminology

Fatal error 11: Segmentation fault
Backtrace:
/home/aadcg/.guix-profile/bin/emacs[0x50fe24]
/home/aadcg/.guix-profile/bin/emacs[0x41f89c]
/home/aadcg/.guix-profile/bin/emacs[0x50e65e]
/home/aadcg/.guix-profile/bin/emacs[0x50e8b8]
/home/aadcg/.guix-profile/bin/emacs[0x50e92c]
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/lib/libpthread.so.0(+0x13010)[0x7f5e9d86c010]
/home/aadcg/.guix-profile/bin/emacs[0x5cfbe8]
/home/aadcg/.guix-profile/bin/emacs[0x58282d]
/home/aadcg/.guix-profile/bin/emacs[0x582e09]
/home/aadcg/.guix-profile/bin/emacs[0x4c4a67]
/home/aadcg/.guix-profile/bin/emacs[0x4c58a0]
/home/aadcg/.guix-profile/bin/emacs[0x4c7bc0]
/home/aadcg/.guix-profile/bin/emacs[0x438cac]
/home/aadcg/.guix-profile/bin/emacs[0x44f0ae]
/home/aadcg/.guix-profile/bin/emacs[0x4498a8]
/home/aadcg/.guix-profile/bin/emacs[0x450b2d]
/home/aadcg/.guix-profile/bin/emacs[0x44f215]
/home/aadcg/.guix-profile/bin/emacs[0x456d38]
/home/aadcg/.guix-profile/bin/emacs[0x45c575]
/home/aadcg/.guix-profile/bin/emacs[0x46e30a]
/home/aadcg/.guix-profile/bin/emacs[0x47322b]
/home/aadcg/.guix-profile/bin/emacs[0x56a726]
/home/aadcg/.guix-profile/bin/emacs[0x43fe8c]
/home/aadcg/.guix-profile/bin/emacs[0x460008]
/home/aadcg/.guix-profile/bin/emacs[0x5019cb]
/home/aadcg/.guix-profile/bin/emacs[0x5040ed]
/home/aadcg/.guix-profile/bin/emacs[0x50571e]
/home/aadcg/.guix-profile/bin/emacs[0x56a68e]
/home/aadcg/.guix-profile/bin/emacs[0x4f76cc]
/home/aadcg/.guix-profile/bin/emacs[0x56a5fd]
/home/aadcg/.guix-profile/bin/emacs[0x4f7674]
/home/aadcg/.guix-profile/bin/emacs[0x4fc596]
/home/aadcg/.guix-profile/bin/emacs[0x4fc8a4]
/home/aadcg/.guix-profile/bin/emacs[0x421725]
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/lib/libc.so.6(__libc_start_main+0xed)[0x7f5e9d5e9a6d]
/home/aadcg/.guix-profile/bin/emacs[0x4222ca]
Segmentation fault



I assume that reverting back to an older glibc version should fix this issue...

--
André Alexandre Gomes
"Free Thought, Free World"
André Alexandre Gomes wrote 4 years ago
(address . 45758@debbugs.gnu.org)
87lfcz8uhm.fsf@gmail.com
Please ignore my previous email. I had an issue with Emacs but I got it
fixed with the help of Ludovic on IRC. All I needed was to run "fc-cache -rv".

I'm sorry that I got confused about a segmentation fault error triggered
by emacs-guix, and not emacs.

--
André Alexandre Gomes
"Free Thought, Free World"
John Soo wrote 4 years ago
Issue with emacs/fontconfig
(name . 45758-Done)(address . 45758-done@debbugs.gnu.org)
b87f9535-5d21-4a75-9fd2-032d31360881@Johns-iPhone
This was closed after some debugging on irc
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45758@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45758
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help