[PATCH 2/2] Made changes Leo on the ML suggested.

  • Done
  • quality assurance status badge
Details
3 participants
  • Jelle Licht
  • Anadon
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Anadon
Severity
normal
A
A
Anadon wrote on 9 Jan 2021 03:40
(address . guix-patches@gnu.org)
20210109024058.68902-3-joshua.r.marshall.1991@gmail.com
---
gnu/packages/cpp.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ff10a4247b..487639c879 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
"0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
(modules '((guix build utils)))))
(build-system cmake-build-system)
-
- (inputs
- `(("gcc" ,gcc-10)))
- (synopsis "Header-only C++17 library for reflection for enums")
- (description "Static reflection for enums (to string, from string,
-iteration) for modern C++, work with any enum type without any macro or
-boilerplate code")
+ (native-inputs
+ `(("gcc" ,gcc-9)))
+ (synopsis "Header-only C++17 library for reflection on enums")
+ (description "C++17 static reflection for enums, allowing functions like
+ to string, from string, and iteration.")
(license license:expat)))
--
2.30.0
M
M
Maxim Cournoyer wrote on 22 May 2022 06:31
(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)
87ee0m6ve1.fsf_-_@gmail.com
tags 45732 +moreinfo
thanks

Hello,

Anadon <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (26 lines)
> ---
> gnu/packages/cpp.scm | 12 +++++-------
> 1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ff10a4247b..487639c879 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
> "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
> (modules '((guix build utils)))))
> (build-system cmake-build-system)
> -
> - (inputs
> - `(("gcc" ,gcc-10)))
> - (synopsis "Header-only C++17 library for reflection for enums")
> - (description "Static reflection for enums (to string, from string,
> -iteration) for modern C++, work with any enum type without any macro or
> -boilerplate code")
> + (native-inputs
> + `(("gcc" ,gcc-9)))
> + (synopsis "Header-only C++17 library for reflection on enums")
> + (description "C++17 static reflection for enums, allowing functions like
> + to string, from string, and iteration.")
> (license license:expat)))

What package is this supposed to affect? There's no mention of its name
anywhere in the title and it doesn't seem to exist in the repo.

Thanks!

Maxim
J
J
Jelle Licht wrote on 29 May 2023 14:18
(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)(address . 45732-done@debbugs.gnu.org)
87pm6jmiuv.fsf@fsfe.org
Anadon <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (27 lines)
> ---
> gnu/packages/cpp.scm | 12 +++++-------
> 1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ff10a4247b..487639c879 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
> "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
> (modules '((guix build utils)))))
> (build-system cmake-build-system)
> -
> - (inputs
> - `(("gcc" ,gcc-10)))
> - (synopsis "Header-only C++17 library for reflection for enums")
> - (description "Static reflection for enums (to string, from string,
> -iteration) for modern C++, work with any enum type without any macro or
> -boilerplate code")
> + (native-inputs
> + `(("gcc" ,gcc-9)))
> + (synopsis "Header-only C++17 library for reflection on enums")
> + (description "C++17 static reflection for enums, allowing functions like
> + to string, from string, and iteration.")
> (license license:expat)))


These changes were taken into account for commit
944aebb46abfaa16321b42a095c729a0d04ae68d as well. Closing
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45732@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45732
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch