[PATCH] gnu: Remove QT 4.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Kei Kebreau
  • Leo Famulari
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 6 Jan 2021 20:58
(address . guix-patches@gnu.org)
f96e5d3cdc9c913cc0794835643166be03ba04b6.1609963117.git.leo@famulari.name
This package has been unsupported upstream for several years:


I suggest we apply this patch as part of a major update — either a core-updates
merge, or a new release.

We should notify the people who contributed or maintained the affected packages
so that they have ample time to update the packages and avoid their removal.

What do you think?

* gnu/packages/qt.scm (qt-4, python2-pyqt-4): Remove variables.
* gnu/packages/chemistry.scm (avogadro): Remove variable.
* gnu/packages/education.scm (tipp10): Remove variable.
* gnu/packages/engineering.scm (qucs, qucs-s): Remove variables.
* gnu/packages/messaging.scm (pybitmessage): Remove variable.
* gnu/packages/password-utils.scm (keepassx): Remove variable.
* gnu/packages/pdf.scm (poppler-qt4): Remove variable.
* gnu/packages/patches/avogadro-boost148.patch,
gnu/packages/patches/avogadro-eigen3-update.patch,
gnu/packages/patches/avogadro-python-eigen-lib.patch,
gnu/packages/patches/tipp10-fix-compiling.patch,
gnu/packages/patches/tipp10-remove-license-code.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
---
gnu/local.mk | 5 -
gnu/packages/chemistry.scm | 85 ---
gnu/packages/education.scm | 53 --
gnu/packages/engineering.scm | 250 --------
gnu/packages/messaging.scm | 93 ---
gnu/packages/password-utils.scm | 31 -
gnu/packages/patches/avogadro-boost148.patch | 69 --
.../patches/avogadro-eigen3-update.patch | 603 ------------------
.../patches/avogadro-python-eigen-lib.patch | 161 -----
.../patches/tipp10-fix-compiling.patch | 212 ------
.../patches/tipp10-remove-license-code.patch | 332 ----------
gnu/packages/pdf.scm | 7 -
gnu/packages/qt.scm | 251 --------
13 files changed, 2152 deletions(-)
delete mode 100644 gnu/packages/patches/avogadro-boost148.patch
delete mode 100644 gnu/packages/patches/avogadro-eigen3-update.patch
delete mode 100644 gnu/packages/patches/avogadro-python-eigen-lib.patch
delete mode 100644 gnu/packages/patches/tipp10-fix-compiling.patch
delete mode 100644 gnu/packages/patches/tipp10-remove-license-code.patch

Toggle diff (385 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 1151d4642e..0a03a4e3a7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -820,9 +820,6 @@ dist_patch_DATA = \
%D%/packages/patches/audiofile-function-signature.patch \
%D%/packages/patches/automake-skip-amhello-tests.patch \
%D%/packages/patches/avahi-localstatedir.patch \
- %D%/packages/patches/avogadro-boost148.patch \
- %D%/packages/patches/avogadro-eigen3-update.patch \
- %D%/packages/patches/avogadro-python-eigen-lib.patch \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
@@ -1663,8 +1660,6 @@ dist_patch_DATA = \
%D%/packages/patches/thefuck-test-environ.patch \
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
%D%/packages/patches/tinyxml-use-stl.patch \
- %D%/packages/patches/tipp10-fix-compiling.patch \
- %D%/packages/patches/tipp10-remove-license-code.patch \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index ddbf5ca098..4f79ce29e6 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -49,91 +49,6 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
-(define-public avogadro
- (package
- (name "avogadro")
- (version "1.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cryos/avogadro")
- (commit version)))
- (sha256
- (base32 "0258py3lkba85qhs5ynancinyym61vlp0zaq9yrfs3hhnhpzv9n2"))
- (file-name (git-file-name name version))
- (patches
- (search-patches "avogadro-eigen3-update.patch"
- "avogadro-python-eigen-lib.patch"
- "avogadro-boost148.patch"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f
- #:configure-flags
- (list "-DENABLE_GLSL=ON"
- (string-append "-DPYTHON_LIBRARIES="
- (assoc-ref %build-inputs "python")
- "/lib")
- (string-append "-DPYTHON_INCLUDE_DIRS="
- (assoc-ref %build-inputs "python")
- "/include/python"
- ,(version-major+minor
- (package-version python))))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-python-lib-path
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This is necessary to install the Python module in the correct
- ;; directory.
- (substitute* "libavogadro/src/python/CMakeLists.txt"
- (("^EXECUTE_PROCESS.*$") "")
- (("^.*from sys import stdout.*$") "")
- (("^.*OUTPUT_VARIABLE.*")
- (string-append "set(PYTHON_LIB_PATH \""
- (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages\")")))
- #t))
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make sure 'avogadro' runs with the correct PYTHONPATH.
- (let* ((out (assoc-ref outputs "out")))
- (setenv "PYTHONPATH"
- (string-append
- (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages:"
- (getenv "PYTHONPATH")))
- (wrap-program (string-append out "/bin/avogadro")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))))
- #t)))))
- (native-inputs
- `(("doxygen" ,doxygen)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("boost" ,boost)
- ("eigen" ,eigen)
- ("glew" ,glew)
- ("openbabel" ,openbabel)
- ("python" ,python-2)
- ("python-numpy" ,python2-numpy)
- ("python-pyqt" ,python2-pyqt-4)
- ("python-sip" ,python2-sip)
- ("qt" ,qt-4)
- ("zlib" ,zlib)))
- (home-page "https://avogadro.cc")
- (synopsis "Advanced molecule editor")
- (description
- "Avogadro is an advanced molecule editor and visualizer designed for use
-in computational chemistry, molecular modeling, bioinformatics, materials
-science, and related areas. It offers flexible high quality rendering and a
-powerful plugin architecture.")
- (license license:gpl2+)))
-
(define-public domainfinder
(package
(name "domainfinder")
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 07862291a7..f212b22ba3 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -217,59 +217,6 @@ Currently available boards include:
(license (list license:silofl1.1 ; bundled fonts
license:gpl3+))))
-(define-public tipp10
- (package
- (name "tipp10")
- (version "2.1.0")
- (source (origin
- (method url-fetch)
- ;; guix download is not able to handle the download links on the
- ;; home-page, which use '<meta http-equiv="refresh" …>'
- (uri (string-append "mirror://debian/pool/main/"
- "t/tipp10/tipp10_2.1.0.orig.tar.gz"))
- (sha256
- (base32
- "0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
- (patches (search-patches "tipp10-fix-compiling.patch"
- "tipp10-remove-license-code.patch"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; packages has no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-new-version-check
- (lambda _
- ;; Make new version check to default to false.
- ;; TODO: Remove the checkbox from the dialog and the check itself
- (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
- (("settings.value(\"check_new_version\", true)")
- "settings.value(\"check_new_version\", false)"))
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Make program honor $PREFIX
- (substitute* "tipp10.pro"
- (("\\.path = /usr/") (string-append ".path = " out "/")))
- (substitute* "def/defines.h"
- (("\"/usr/") (string-append "\"" out "/")))
- ;; Recreate Makefile
- (invoke "qmake")))))))
- (inputs
- `(("qt4" ,qt-4)
- ("sqlite" ,sqlite)))
- (home-page "https://www.tipp10.com/")
- (synopsis "Touch typing tutor")
- (description "Tipp10 is a touch typing tutor. The ingenious thing about
-the software is its intelligence feature: characters that are mistyped are
-repeated more frequently. Beginners will find their way around right away so
-they can start practicing without a hitch.
-
-Useful support functions and an extensive progress tracker, topical lessons
-and the ability to create your own practice lessons make learning to type
-easy.")
- (license license:gpl2)))
-
(define-public snap
(package
(name "snap")
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5166a4635c..b80a946bab 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1986,256 +1986,6 @@ parallel computing platforms. It also supports serial execution.")
(license (list license:gpl2+
license:lgpl2.0+)))) ; freehdl's libraries
-(define-public qucs
- ;; Qucs 0.0.19 segfaults when using glibc-2.26. Temporarily build from git.
- ;; TODO: When qucs-0.0.20 is released, revert the commit that introduced this
- ;; comment and update the package.
- (let ((commit "b4f27d9222568066cd59e4c387c51a35056c99d8")
- (revision "0"))
- (package
- (name "qucs")
- (version (git-version "0.0.19" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Qucs/qucs")
- (commit commit)))
- (sha256
- (base32 "10bclay9xhkffmsh4j4l28kj1qpxx0pnxja5vx6305cllnq4r3gb"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap
- (lambda _
- (for-each patch-shebang
- '("bootstrap"
- "qucs/bootstrap"
- "qucs-doc/bootstrap"
- "qucs-core/bootstrap"))
- #t))
- (add-before 'configure 'patch-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "qucs/configure"
- (("\\$QTDIR") (assoc-ref inputs "qt4")))
- #t))
- (add-after 'patch-configure 'patch-scripts
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* '("qucs/qucs/qucsdigi"
- "qucs/qucs/qucsdigilib"
- "qucs/qucs/qucsveri")
- (("\\$BINDIR")
- (string-append (assoc-ref outputs "out") "/bin"))
- (("freehdl-config")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-config"))
- (("freehdl-v2cc")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-v2cc"))
- (("cp ")
- (string-append (assoc-ref inputs "coreutils") "/bin/cp "))
- (("glibtool")
- (string-append (assoc-ref inputs "libtool") "/bin/libtool"))
- (("sed")
- (string-append (assoc-ref inputs "sed") "/bin/sed"))
- (("iverilog")
- (string-append (assoc-ref inputs "iverilog") "/bin/iverilog"))
- (("vvp")
- (string-append (assoc-ref inputs "iverilog") "/bin/vvp")))
- #t))
- (add-before 'check 'pre-check
- (lambda _
- ;; The test suite requires a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- #t))
- (add-after 'install 'make-wrapper
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; 'qucs' directly invokes gcc, hence this wrapping.
- (wrap-program (string-append out "/bin/qucs")
- `("CPLUS_INCLUDE_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/include")))
- `("PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/bin")))
- `("LIBRARY_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/lib")))
- `("ADMSXMLBINDIR" ":" prefix
- (,(string-append (assoc-ref inputs "adms") "/bin")))
- `("ASCOBINDIR" ":" prefix
- (,(string-append (assoc-ref inputs "asco") "/bin")))
- `("QUCS_OCTAVE" ":" prefix
- (,(string-append (assoc-ref inputs "octave") "/bin/octave")))))
- #t)))
- #:parallel-build? #f ; race condition
- #:configure-flags '("--disable-doc"))) ; we need octave-epstk
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bison" ,bison)
- ("flex" ,flex)
- ("gperf" ,gperf)
- ("libtool-native" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-2) ; for tests
- ("matplotlib" ,python2-matplotlib) ; for tests
- ("numpy" ,python2-numpy) ; for tests
- ("xorg-server" ,xorg-server-for-tests))) ; for tests
- (inputs
- `(("adms" ,adms)
- ("asco" ,asco)
- ("coreutils" ,coreutils)
- ("freehdl" ,freehdl)
- ("gcc-toolchain" ,gcc-toolchain)
- ("iverilog" ,iverilog)
- ("libtool" ,libtool)
- ("octave" ,octave-cli)
- ("qt4" ,qt-4)
- ("sed" ,sed)))
- (home-page "http://qucs.sourceforge.net/")
- (synopsis "Circuit simulator with graphical user interface")
- (description
- "Qucs is a circuit simulator with graphical user interface. The software
-aims to support all kinds of circuit simulation types---e.g. DC, AC,
-S-parameter, transient, noise and harmonic balance analysis. Pure digital
-simulations are also supported.")
- (license license:gpl2+))))
-
-(define-public qucs-s
- (package
- (name "qucs-s")
- (version "0.0.21")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ra3xdh/qucs_s/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "12m1jwhb9qwvb141qzyskbxnw3wn1x22d02z4b4862p7xvccl5h7"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-scripts
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("qucs/qucsdigi"
- "qucs/qucsdigilib"
- "qucs/qucsveri")
- (("\\$BINDIR")
- (string-append (assoc-ref inputs "qucs") "/bin"))
- (("freehdl-config")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-config"))
- (("freehdl-v2cc")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-v2cc"))
- (("cp ")
- (string-append (assoc-ref inputs "coreutils") "/bin/cp "))
- (("glibtool")
- (string-append (assoc-ref inputs "libtool") "/bin/libtool"))
- (("sed")
- (string-append (assoc-ref inputs "sed") "/bin/sed"))
- (("iverilog")
- (string-append (assoc-ref inputs "iverilog") "/bin/iverilog"))
- (("vvp")
- (string-append (assoc-ref inputs "iverilog") "/bin/vvp")))
- #t))
- (add-after 'patch-scripts 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "qucs/main.cpp"
- (((string-append "QucsSettings\\.Qucsator = QucsSettings\\.BinDir "
- "\\+ \"qucsator\" \\+ executableSuffix"))
- (string-append "}{ QucsSettings.Qucsator = \""
- (assoc-ref inputs "qucs") "/bin/qucsator\""))
- (((string-append "QucsSettings\\.XyceExecutable = "
- "\"/usr/local/Xyce-Release-6.8.0-OPENSOURCE/bin/Xyce"))
- (string-append "}{ QucsSettings.XyceExecutable = \""
- (assoc-ref inputs "xyce-serial") "/bin/Xyce"))
- (((string-append "else QucsSettings\\.XyceParExecutable = "
- "\"mpirun -np %p /usr/local"
- "/Xyce-Release-6.8.0-OPENMPI-OPENSOURCE/bin/Xyce"))
- (string-append "QucsSettings.XyceParExecutable = \""
- (assoc-ref inputs "mpi") "/bin/mpirun -np %p "
- (assoc-ref inputs "xyce-parallel") "/bin/Xyce"))
- (("else QucsSettings\\.NgspiceExecutable = \"ngspice\"")
- (string-append "QucsSettings.NgspiceExecutable = " "\""
- (assoc-ref inputs "ngspice") "/bin/ngspice\"")))
- (substitute* "qucs/extsimkernels/ngspice.cpp"
- (("share/qucs/xspice_cmlib") "share/qucs-s/xspice_cmlib"))
- (substitute* "qucs/qucs_actions.cpp"
- (("qucstrans")
- (string-append (assoc-ref inputs "qucs") "/bin/qucstrans"))
- (("qucsattenuator")
- (string-append (assoc-ref inputs "qucs") "/bin/qucsattenuator"))
- (("qucsrescodes")
- (string-append (assoc-ref inputs "qucs") "/bin/qucsrescodes")))
- #t))
- (add-after 'install 'install-scripts
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each
- (lambda (script)
- (let ((file (string-append "../qucs_s-" ,version
- "/qucs/" script))
- (out (assoc-ref outputs "out")))
- (install-file file (string-append o
This message was truncated. Download the full message here.
E
E
Efraim Flashner wrote on 10 Jan 2021 13:53
(name . Leo Famulari)(address . leo@famulari.name)(address . 45704@debbugs.gnu.org)
X/r41CSIZpNM+ENT@3900XT
On Wed, Jan 06, 2021 at 02:58:37PM -0500, Leo Famulari wrote:
Toggle quote (12 lines)
> This package has been unsupported upstream for several years:
>
> https://lists.gnu.org/archive/html/guix-devel/2016-02/msg00596.html
>
> I suggest we apply this patch as part of a major update — either a core-updates
> merge, or a new release.
>
> We should notify the people who contributed or maintained the affected packages
> so that they have ample time to update the packages and avoid their removal.
>
> What do you think?

I've added some in-line notes

Toggle quote (2 lines)
> * gnu/packages/qt.scm (qt-4, python2-pyqt-4): Remove variables.

qt-4 when nothing depends on it, python2-pyqt-4 whenever

Toggle quote (2 lines)
> * gnu/packages/chemistry.scm (avogadro): Remove variable.

I hear this has been superseded by development of avogadro2, but someone
using it might want to let us know.

Toggle quote (2 lines)
> * gnu/packages/education.scm (tipp10): Remove variable.

Toggle quote (2 lines)
> * gnu/packages/engineering.scm (qucs, qucs-s): Remove variables.

I don't know anything about this

Toggle quote (2 lines)
> * gnu/packages/messaging.scm (pybitmessage): Remove variable.

I believe first introduced by Nikita, I don't know if they still use it,
and I'm disappointed by the stable release being years old and still
using qt4 and python2. I hear there is no concrete plans upstream for
the next release still.

Toggle quote (2 lines)
> * gnu/packages/password-utils.scm (keepassx): Remove variable.

IMO superseded by keepassxc

Toggle quote (2 lines)
> * gnu/packages/pdf.scm (poppler-qt4): Remove variable.

Apparently nothing depends on this, so probably free to go.


I'd like to hear from someone with regards to avogadro, perhaps also
qucs.

I'd also like to remind everyone that guix time-machine can be used to
go back to before these will be removed :)

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/6+NIACgkQQarn3Mo9
g1F7Iw/+PxipAP1EKswH1uK0kkON4SrTvJX8hlm9GUBt+tyxyPoqr2coA1eRg6ro
T+ip864pfbC5PoEwtSxlX/wLYVHmbfyt3pLkWEWlz66Z1O/AugLyi2nU0aaHHD3Y
PuZ4Ri6kIeIuR40nyimsVebD8k2rBvquSG6NuVGyTdANybrafEztr9j/l5NyqxqG
nunrSge8XiDzwNG+18uALTHsdZB1+3Ek8/GppAW4QcwT7mBWev45OswC3z14ZDQJ
UxLmEyOpEdtHRSlUmPQfZOTh9YOsD8L2R9+TzhmNI9CY1RAzaF/kkP0TJ556yQ75
xNxO9tzJjp2uaZgNw3/FnNsJK1J99abSP7qbiKqEHNAPmwPhEOYc9mX0tSr8MMfG
U2vRD0FiReL3xPIkkV9xWjBZ15iTp4Y0/P04ENmlqXKEHX2R7XJmUbP4DfVAsk79
q1kk5f7KV2whODDQTcxpihxD4Hc0+5g7DMDKNDtfCPHykt1WPsvssJGj7GOKPigw
z02Y3emcYiVcfPJJYVz6IdKimZzn0BY/WbWlMU9CXrA9w4XGWJ47uzXmeL1A7mDA
qS/UtSf4JLi9JUX2e6fLohr+dv45S8VHFmgA91pDr4lcdjCSK82nrWFc38TmH9OT
2zw51Y2XX04pcNWDTnFPThp26Bg4FvZrouQp63b68yM3/TmLtKA=
=bLpz
-----END PGP SIGNATURE-----


R
R
Ricardo Wurmus wrote on 10 Jan 2021 14:21
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87lfd1dj1p.fsf@elephly.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (4 lines)
>> * gnu/packages/password-utils.scm (keepassx): Remove variable.
>
> IMO superseded by keepassxc

Should we define a deprecation replacement for keepassx then?

--
Ricardo
L
L
Leo Famulari wrote on 10 Jan 2021 19:14
(name . Ricardo Wurmus)(address . rekado@elephly.net)
X/tEHdMSCx3IdBKH@jasmine.lan
On Sun, Jan 10, 2021 at 02:21:22PM +0100, Ricardo Wurmus wrote:
Toggle quote (9 lines)
>
> Efraim Flashner <efraim@flashner.co.il> writes:
>
> >> * gnu/packages/password-utils.scm (keepassx): Remove variable.
> >
> > IMO superseded by keepassxc
>
> Should we define a deprecation replacement for keepassx then?

It was marked as "superseded" by keepassxc in commit
b7ac10e6da6e2199aa379fdfa19bd43ca8fddc4d, in 2017.
K
K
Kei Kebreau wrote on 20 Jan 2021 21:21
Re: bug#45704: [PATCH] gnu: Remove QT 4.
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87o8hj741b.fsf_-_@posteo.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (1 lines)
> On Wed, Jan 06, 2021 at 02:58:37PM -0500, Leo Famulari wrote:
...
Toggle quote (3 lines)
> I'd like to hear from someone with regards to avogadro, perhaps also
> qucs.

Good thing I happened to see this message! I packaged Avogadro, and it
looks like Avogadro 2 uses QT 5 as its default GUI toolkit [0]. I can
add packaging Avogadro 2 to my Guix to-do list to make the removal of
the original avogadro package a non-issue.

Thanks,
Kei

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAmAIkNAACgkQ5qXuPBlG
eg3iAA/9ECyZNQt0rklqtnTC75ipfbpBxbCnAbQ5wPjqgIV1wveo1vOrGSC418kF
beJtNIrPl/dBTs3/qLSsWQ9co8slLr3owZKgeGURGPZqpnYnHJR8w4Os3vge1ay/
drtcdcteGtu6gdTV6E8wSTyk3XTSYkvxCcaPn4Xx2EYDXMezTAFTUIictTUO0i2e
ojqShZdD+no5mOXESUfY9pzzTA65EsVMRXzX/5rT7jAEWoDfBlJ1xAKkH8pCw+NV
ppU5TXb7tea6my77d5haxBBhTAbHdeWYZXxcqDts9+5GEz7TSPynBwQtzlL1jD/V
xknBqLMM9BZQCPYryUVEIDWo3RVaaZLPMKje39mcORJSLaa3LteniiUbx1+Hpv4X
dxMwlWGSaYdjZg0cHAXP7jTbJGqMNVSCUAUvvKBPReGWlOtKfxSQqeuSP/JGEDe9
4ytSMB5M480UQ0WLMQiGsG0jaaIeorCxjvVUTiaLJBBr9cnCCze54i82sqKKZ634
xXW3xEf8Aq+DSGx2oyxWpXq+/JPlsY9l4Y0Y9EQb8vCofbAndLseSmZE0tL9HOLX
j3m4IEwJDd9HLZmdrO/fieUn7YTNYALQcBh67OYtvjjowSfJ+GqZ4Zpn63568y69
zyFt+EVtiaF7omrgoduRx/inI/8Lz41AEd1iHLbqKxV+2bVn2VA=
=J1oT
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 20 Jan 2021 22:56
(name . Kei Kebreau)(address . kkebreau@posteo.net)
YAim/SHxKTxzmRZY@jasmine.lan
On Wed, Jan 20, 2021 at 03:21:36PM -0500, Kei Kebreau wrote:
Toggle quote (5 lines)
> Good thing I happened to see this message! I packaged Avogadro, and it
> looks like Avogadro 2 uses QT 5 as its default GUI toolkit [0]. I can
> add packaging Avogadro 2 to my Guix to-do list to make the removal of
> the original avogadro package a non-issue.

Okay, let us know how it goes!

My plan is to contact the people that added or maintained packages
depending on Qt 4, giving them a few months to chime in.
K
(name . Leo Famulari)(address . leo@famulari.name)
ce1d97984e66a32358df20c2d13e8075539e3b4c.camel@posteo.net
On Wed, 2021-01-20 at 16:56 -0500, Leo Famulari wrote:
Toggle quote (11 lines)
> On Wed, Jan 20, 2021 at 03:21:36PM -0500, Kei Kebreau wrote:
> > Good thing I happened to see this message! I packaged Avogadro, and it
> > looks like Avogadro 2 uses QT 5 as its default GUI toolkit [0]. I can
> > add packaging Avogadro 2 to my Guix to-do list to make the removal of
> > the original avogadro package a non-issue.
>
> Okay, let us know how it goes!
>
> My plan is to contact the people that added or maintained packages
> depending on Qt 4, giving them a few months to chime in.

Hello all,

Please see Guix issue 46107 for a draft of the Avogadro 2 package!


Thanks,
Kei
L
L
Leo Famulari wrote on 29 Jan 2021 01:56
Proposed removal of qucs and qucs-s from Guix due to Qt 4 removal
(name . Theodoros Foradis)(address . theodoros.for@openmailbox.org)(address . 45704@debbugs.gnu.org)
YBNdUw5hU+RSHXUO@jasmine.lan
Hello,

This message is to notify you that some packages you contributed to Guix
(qucs and qucs-s) are going to be removed in the near-ish future due to
proposed removal of their dependency, Qt 4:


We hope that it will not be too difficult to update these packages to
work with Qt 5.

Sincerely,
Leo
L
L
Leo Famulari wrote on 29 Jan 2021 02:00
Proposed removal of pybitmessage from Guix due to Qt 4 removal
(name . nikita)(address . nikita@n0.is)(address . 45704@debbugs.gnu.org)
YBNeEu1rQoBP3N7S@jasmine.lan
Hello,

This message is to notify you that a package you contributed to Guix
(pybitmessage) is going to be removed in the near-ish future due to
proposed removal of its dependency, python2-pyqt-4.


We hope that it will not be too difficult to update this package to work
with Qt 5.

Sincerely,
Leo
L
L
Leo Famulari wrote on 29 Jan 2021 02:04
Re: [bug#45704] [PATCH] gnu: Remove QT 4.
(name . Efraim Flashner)(address . efraim@flashner.co.il)
YBNfBfgsLkeoeIl7@jasmine.lan
On Sun, Jan 10, 2021 at 02:53:40PM +0200, Efraim Flashner wrote:
Toggle quote (5 lines)
> > * gnu/packages/education.scm (tipp10): Remove variable.
>
> Debian has built this with qt-5
> (https://sources.debian.org/src/tipp10/2.1.0-5/debian/)

Thanks for updating this package to use Qt 5, Efraim!

The only packages remaining without replacements are qucs / qucs-s and
pybitmessage, and I've CC-ed their authors to this thread.

I propose we remove Qt 4 in the next release (CC-ing the maintainers).

Leo
L
L
Leo Famulari wrote on 7 Mar 2021 00:23
(address . 45704@debbugs.gnu.org)
YEQPBBR3kLVO4mKs@jasmine.lan
On Thu, Jan 28, 2021 at 08:04:05PM -0500, Leo Famulari wrote:
Toggle quote (2 lines)
> I propose we remove Qt 4 in the next release (CC-ing the maintainers).

I've pushed an updated Qt 4 removal patch (attached) to the
wip-next-release branch.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmBEDwMACgkQJkb6MLrK
fwjrgxAAjxrX3QejW507u6lZKLVOuz6SDi5U/1eekM3ancxsPn5R6rlAtc4bOvsv
kr2fqp3bpTOZ8cco0kj34Csi82AL0qSR13z3N8+HC9WVcKcXVl+2vuM00Lu1bHpB
JiHdTkx9G9xdB7n3GCS2b9qSjHmEUSNdsLSNDrYZw8V5beV3AlKQ2oJr2Se2Wg80
gbapztHwWMX9OVzKM1fmjcXvPNy5m8sJBOvkLOIOs8eOnLOIQtV91eMCgI7KbXP2
BDlK1MUU/TgJUZln/FmuM6V8UVU+T5gcDSowP/AVnfzj+AqfPlzKXe6romPRx6kK
ZDuh7EmkT3+xnjIo5lmSR/Td7FGy9gduqWS/UPkmJxXFYTUEf81QGIi8gkw62227
Xh6pz2+WkR5FddWW/IsI5Owaq4oZZUnXkjDWakqbsoQGSdJ3x7U1H1986RRVt0CR
UJGmMx87MofbLv9wQtiAeVhANOptQpse5RGn8sxgTMHYLmnT/HdaezM3fg6hf++w
TjsEQDoc2V2R0P7TPz0/rq9qmVCA1qoncSV+ir/1bzQmUzIzLuMlivrH29gYLHkQ
xZt2QZxF/d8/nYCkn2H+bRnXgL1/QtqDFSoZrPkkyF2E27xSWI3Nf9AMjGsT0/kf
X3uKr4iUfHJchckBOyi4xqc9K/8iY225It5ES6lpytq660q3Tu0=
=g8/m
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 21 Mar 2021 18:41
(no subject)
(address . control@debbugs.gnu.org)
YFeFRnzVjbTujStB@jasmine.lan
block 47297 with 46871
block 47297 with 45704
L
L
Leo Famulari wrote on 26 Mar 2021 00:20
Re: [bug#45704] [PATCH] gnu: Remove QT 4.
(address . 45704-done@debbugs.gnu.org)
YF0a2uo23hI1aTbf@jasmine.lan
On Sat, Mar 06, 2021 at 06:23:48PM -0500, Leo Famulari wrote:
Toggle quote (11 lines)
> On Thu, Jan 28, 2021 at 08:04:05PM -0500, Leo Famulari wrote:
> > I propose we remove Qt 4 in the next release (CC-ing the maintainers).
>
> I've pushed an updated Qt 4 removal patch (attached) to the
> wip-next-release branch.

> From 2d977b43f333dec1e82703ceae4e692d46a5a2fb Mon Sep 17 00:00:00 2001
> From: Leo Famulari <leo@famulari.name>
> Date: Sat, 6 Mar 2021 18:06:21 -0500
> Subject: [PATCH] gnu: Remove QT 4.

Pushed as a801c7379a534a2896a03a1a6f8b47eb92691b00
-----BEGIN PGP SIGNATURE-----

iQIyBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmBdGtoACgkQJkb6MLrK
fwg+2w/4wccb75CS5wVoUhSt3A0fBRwMYVS5yITlGSV6V4FFagYcw7UH8SaxDLM7
oopMlzZFUaw+00SstREMzEKhY8TUGkLS76bcC6cBwqx4YzhA3BJ1nDrAYVBDrItR
/HDxcwhzVL8MCyFQp3o382V1trYz4TXGWdqP0kkK64sZ8QnSyiifYES7jWsJMz5D
dgB7mfGSEHEx4ggp4G8AJYB9GuPMgxmeYGsPco+d2vpEKzGJ5QnfWYz5xQNxW0ef
0Qyb0Ko7Fu0OI/9n5A+Q9yYNz/x47a0h0cGhPhSTnRNl0JZ3DIndagioxZ4NUn0w
PDDbhV86ugIGQC6MKaHXg+fJZwvZnCxe08G/Bm4oUMdXSxwmjBKN5sLPhtj7DETq
FhRPEY+vallpM3sQMcONfPk+rCWU3Q36OqNpLP9HosvHe/7J2zC6PNbZfdAlQaNY
glp84DPP/qld6DrfF/8GhQqkp0W6jkulEmXkuLlxo+HPRCE19tUmJRnMV2yH+enc
PUsyCBCjeuIHAjM17ha0GWYdgys1LNxVq2blxIzn+jS+gklk8uBzxHWf2kvubcMr
qfAhlnlGEva+mcrjAIdyMTr+4oSaugrkgZzc0pC9ZvGYL2jH7R5LApyxqvAAAMR+
bUfcykIzb+M9W/pkS0kmNMIMaQzgC0yCEFdZxWUNFLgnF0YlMg==
=9fIY
-----END PGP SIGNATURE-----


Closed
?