[PATCH] gnu: ppp: Update to 2.4.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20210106120600.3282-1-vincent.legoll@gmail.com
* gnu/packages/samba.scm (ppp): Update to 2.4.9.
---
gnu/packages/samba.scm | 87 ++++++++++++++++++++----------------------
1 file changed, 42 insertions(+), 45 deletions(-)

Toggle diff (100 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 679e2ab869..13e03d7ac7 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -443,51 +443,48 @@ key-value pair databases and a real LDAP database.")
(license lgpl3+)))
(define-public ppp
- ;; This git commit contains unreleased fixes for CVE-2020-8597.
- (let ((revision "1")
- (commit "8d45443bb5c9372b4c6a362ba2f443d41c5636af"))
- (package
- (name "ppp")
- (version (git-version "2.4.8" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/paulusmack/ppp")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06cf8fb84l3h2zy5da4j7k2j1qjv2gfqn986sf43xgj75605aks2"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no check target
- #:make-flags '("CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-Makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (openssl (assoc-ref inputs "openssl"))
- (libpcap (assoc-ref inputs "libpcap")))
- (substitute* "pppd/Makefile.linux"
- (("/usr/include/crypt\\.h")
- (string-append libc "/include/crypt.h"))
- (("/usr/include/openssl")
- (string-append openssl "/include/openssl"))
- (("/usr/include/pcap-bpf.h")
- (string-append libpcap "/include/pcap-bpf.h")))
- #t))))))
- (inputs
- `(("libpcap" ,libpcap)
- ("openssl" ,(@ (gnu packages tls) openssl))))
- (synopsis "Implementation of the Point-to-Point Protocol")
- (home-page "https://ppp.samba.org/")
- (description
- "The Point-to-Point Protocol (PPP) provides a standard way to establish
+ (package
+ (name "ppp")
+ (version "2.4.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/paulusmack/ppp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-Makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc"))
+ (openssl (assoc-ref inputs "openssl"))
+ (libpcap (assoc-ref inputs "libpcap")))
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/crypt\\.h")
+ (string-append libc "/include/crypt.h"))
+ (("/usr/include/openssl")
+ (string-append openssl "/include/openssl"))
+ (("/usr/include/pcap-bpf.h")
+ (string-append libpcap "/include/pcap-bpf.h")))
+ #t))))))
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("openssl" ,(@ (gnu packages tls) openssl))))
+ (synopsis "Implementation of the Point-to-Point Protocol")
+ (home-page "https://ppp.samba.org/")
+ (description
+ "The Point-to-Point Protocol (PPP) provides a standard way to establish
a network connection over a serial link. At present, this package supports IP
and IPV6 and the protocols layered above them, such as TCP and UDP.")
- ;; pppd, pppstats and pppdump are under BSD-style notices.
- ;; some of the pppd plugins are GPL'd.
- ;; chat is public domain.
- (license (list bsd-3 bsd-4 gpl2+ public-domain)))))
+ ;; pppd, pppstats and pppdump are under BSD-style notices.
+ ;; some of the pppd plugins are GPL'd.
+ ;; chat is public domain.
+ (license (list bsd-3 bsd-4 gpl2+ public-domain))))
--
2.30.0
Vincent Legoll wrote 4 years ago
Re: bug#45689: Acknowledgement ([PATCH] gnu: ppp: Update to 2.4.9.)
(address . 45689@debbugs.gnu.org)
CAEwRq=q_JEObJ3q1uMveFGQJT4_ZLyy8zrWDeU9NW3eeZOpRBQ@mail.gmail.com
I forgot to mention that this version contains:
Fixes for CVE-2020-8597 and CVE-2015-3310.

--
Vincent Legoll
Efraim Flashner wrote 4 years ago
Re: [bug#45689] [PATCH] gnu: ppp: Update to 2.4.9.
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45689-done@debbugs.gnu.org)
X/wswlZq1pEUYRwD@3900XT
Looks good. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/8LL8ACgkQQarn3Mo9
g1FivhAAqJwAGJEfV9o3cBobS8iqlKqzRcBq7daOlXphbFaeTGTCVuyNBEjsYXSk
hakmXzR4Rll800ZNQMi6yTL3gMoExApY7O9UGNFz3PQNfog0y/JigU2rs64nTzxb
Od8nNROVbhofu9bw9Y9JQNB//bvSGJka5zb4ziEf16Cv6YFTzuHWEQHagCsRCO+D
V0SkzFkJH1ZGwemzMbWAn4gY2QWELipnndMhTOuEig57PO3qN6ofqKgv25rOi28Z
CmyUlelXu5aw+nxuQOgL7UnqN/57Rnp0mL5WUG4Lz3tro9FdVm+jrda/A4ziI+7I
eUy6WNjbfTzFKlARlvYH7VBS2TG91bSv3wpQ/trR18orvb/vitFY5J7FqLQo1eJN
WWoccS5IuXv9GDDmhsiJppBKD4IIJgUcd9aPCwaObkRCUHdFSIxHJQzLAqpAMsQW
JPHp50EeGzoB38U3/DVMU9RPpGVzQDxysRpe41U+qkOaZcx05nnaVkGRrMrpSbtR
mNyl4RFuWlMTPR3Q6a8xQaDa3nD27SSjfrxYBrIhM/QYLPCb2LvPKDJizTxZzeLD
zkKl9rn0A6RJ7B1yvE8l5FOTS3h5hi966USLXkPqCdMFiK3wwZRMHjVkSnuk1ROu
CW1HJ3N8epU8TdlLre7yXqp3NvN2yXXjA45xsr7hM5cffyF39FI=
=B3Gu
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45689@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45689
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help