[PATCH 0/2] Update guile-curl

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 4 Jan 2021 16:11
(address . guix-patches@gnu.org)
112cba58b6931b336fce201041fc6e21954de261.camel@student.tugraz.at
Hello Guix,

As has been announced by spk121 in #guile earlier today, guile-curl has
a new major version, that comes with Guile 3 support. The update is
sadly not trivial, though, so I'll let y'all verify it ahead of time.

Regards,
Leo
L
L
Leo Prikler wrote on 4 Jan 2021 16:13
[PATCH 2/2] gnu: Add guile2.2-curl.
(address . 45653@debbugs.gnu.org)
20210104151351.18675-2-leo.prikler@student.tugraz.at
* gnu/packages/curl.scm (guile2.2-curl): New variable.
---
gnu/packages/curl.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 451c517ee1..5bc96ef7cc 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -312,6 +312,14 @@ Guile to do client-side URL transfers, like requesting documents from HTTP or
FTP servers. It is based on the curl library.")
(license license:gpl3+)))
+(define-public guile2.2-curl
+ (package
+ (inherit guile-curl)
+ (name "guile2.2-curl")
+ (inputs
+ `(("curl" ,curl)
+ ("guile" ,guile-2.2)))))
+
(define-public curlpp
(package
(name "curlpp")
--
2.30.0
L
L
Leo Prikler wrote on 4 Jan 2021 16:13
[PATCH 1/2] gnu: guile-curl: Update to 0.7.
(address . 45653@debbugs.gnu.org)
20210104151351.18675-1-leo.prikler@student.tugraz.at
* gnu/packages/curl.scm (guile-curl): Update to 0.7.
[#:modules, #:imported-modules]: Load guile-build-system for
target-guile-effective-version.
[#:configure-flags]: Use target-guile-effective-version.
[#:phases]: Add 'patch-undefined-references.
Use target-guile-effective-version.
[inputs]: Use guile-3.0.
---
gnu/packages/curl.scm | 59 ++++++++++++++++++++++++++++++-------------
1 file changed, 42 insertions(+), 17 deletions(-)

Toggle diff (92 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 33a2188d70..451c517ee1 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -243,43 +243,68 @@ not offer a replacement for libcurl.")
(define-public guile-curl
(package
(name "guile-curl")
- (version "0.6")
+ (version "0.7")
(source (origin
(method url-fetch)
(uri (string-append "http://www.lonelycactus.com/tarball/"
"guile_curl-" version ".tar.gz"))
(sha256
(base32
- "1pxdhnk288ky6gkpad8i60m0p6404rdvls43lr1b5d3csrklyc70"))))
+ "1zk0ijx6bj212k0j0ma84cpvpvn0x6raaxnby3wdx3w4wnhnscn7"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags (list (string-append
+ `(#:modules (((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules ((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:configure-flags (list (string-append
"--with-guilesitedir="
(assoc-ref %outputs "out")
- "/share/guile/site/2.2")
+ "/share/guile/site/"
+ (target-guile-effective-version
+ (assoc-ref %build-inputs "guile")))
(string-append
"-with-guileextensiondir="
(assoc-ref %outputs "out")
- "/lib/guile/2.2/extensions"))
+ "/lib/guile/"
+ (target-guile-effective-version
+ (assoc-ref %build-inputs "guile"))
+ "/extensions"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-undefined-references
+ (lambda* _
+ (substitute* "src/curl.scm"
+ ;; The following #defines are missing from our curl package
+ ;; and therefore result in the evaluation of undefined symbols.
+ ((",CURLOPT_HAPROXYPROTOCOL") "#f")
+ ((",CURLOPT_DISALLOW_USERNAME_IN_URL") "#f")
+ ((",CURLOPT_TIMEVALUE_LARGE") "#f")
+ ((",CURLOPT_DNS_SHUFFLE_ADDRESSES") "#f")
+ ((",CURLOPT_HAPPY_EYEBALLS_TIMEOUT_MS") "#f"))))
(add-after 'install 'patch-extension-path
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (curl.scm (string-append
- out "/share/guile/site/2.2/curl.scm"))
- (curl.go (string-append
- out "/lib/guile/2.2/site-ccache/curl.go"))
- (ext (string-append out "/lib/guile/2.2/"
- "extensions/libguile-curl")))
- (substitute* curl.scm (("libguile-curl") ext))
- ;; The build system does not actually compile the Scheme module.
- ;; So we can compile it and put it in the right place in one go.
- (invoke "guild" "compile" curl.scm "-o" curl.go)))))))
+ (let* ((out (assoc-ref outputs "out"))
+ (curl.scm (string-append
+ out "/share/guile/site/"
+ (target-guile-effective-version)
+ "/curl.scm"))
+ (curl.go (string-append
+ out "/lib/guile/"
+ (target-guile-effective-version)
+ "/site-ccache/curl.go"))
+ (ext (string-append out "/lib/guile/"
+ (target-guile-effective-version)
+ "/extensions/libguile-curl")))
+ (substitute* curl.scm (("libguile-curl") ext))
+ ;; The build system does not actually compile the Scheme module.
+ ;; So we can compile it and put it in the right place in one go.
+ (invoke "guild" "compile" curl.scm "-o" curl.go)))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("curl" ,curl)
- ("guile" ,guile-2.2)))
+ ("guile" ,guile-3.0)))
(home-page "http://www.lonelycactus.com/guile-curl.html")
(synopsis "Curl bindings for Guile")
(description "@code{guile-curl} is a project that has procedures that allow
--
2.30.0
M
M
Mathieu Othacehe wrote on 6 Jan 2021 10:32
Re: [bug#45653] [PATCH 0/2] Update guile-curl
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 45653@debbugs.gnu.org)
87k0sqpg05.fsf@gnu.org
Hello Leo,

Toggle quote (4 lines)
> As has been announced by spk121 in #guile earlier today, guile-curl has
> a new major version, that comes with Guile 3 support. The update is
> sadly not trivial, though, so I'll let y'all verify it ahead of time.

This patchset seems fine to me.

Thanks,

Mathieu
L
L
Leo Prikler wrote on 6 Jan 2021 22:32
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 45653-done@debbugs.gnu.org)
1dfabafa9378b6f631576ced1a3e7001b8977c98.camel@student.tugraz.at
Hi Mathieu,
Am Mittwoch, den 06.01.2021, 10:32 +0100 schrieb Mathieu Othacehe:
Toggle quote (14 lines)
> Hello Leo,
>
> > As has been announced by spk121 in #guile earlier today, guile-curl
> > has
> > a new major version, that comes with Guile 3 support. The update
> > is
> > sadly not trivial, though, so I'll let y'all verify it ahead of
> > time.
>
> This patchset seems fine to me.
>
> Thanks,
>
> Mathieu
Thanks for the review, I've pushed it now.

Regards,
Leo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45653@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45653
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch