environment: gracefully handle unsupported system.

  • Done
  • quality assurance status badge
Details
3 participants
  • guy fleury iteriteka
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 4 years ago
(address . guix-patches@gnu.org)
87v9chx71n.fsf@disroot.org
hi guix,

if this patch looks good, feel free to change message diagnostic.
From d9b4727885744abda8afc179182a2cc975122487 Mon Sep 17 00:00:00 2001
From: guy fleury iteriteka <gfleury@disroot.org>
Date: Fri, 1 Jan 2021 11:01:49 +0200
Subject: [PATCH] environment: gracefully handle unsupported system.

* guix/scripts/environment.scm(guix-environment): Add a test
to ensure that the system is supported.
---
guix/scripts/environment.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/guix/scripts/environment.scm b/guix/scripts/environment.scm
index e435bf0..40af012 100644
--- a/guix/scripts/environment.scm
+++ b/guix/scripts/environment.scm
@@ -719,6 +719,10 @@ message if any test fails."
(mappings (pick-all opts 'file-system-mapping))
(white-list (pick-all opts 'inherit-regexp)))
+ (when (not (member system '("armhf-linux" "aarch64-linux"
+ "i686-linux" "x86_64-linux" "i586-gnu")))
+ (leave (G_ "guix does not support ~A system~%") system))
+
(when container? (assert-container-features))
(when (and (not container?) link-prof?)
--
2.20.1
Ludovic Courtès wrote 4 years ago
(name . guy fleury iteriteka)(address . gfleury@disroot.org)(address . 45591@debbugs.gnu.org)
87lfcwaon2.fsf@gnu.org
Hi,

guy fleury iteriteka <gfleury@disroot.org> skribis:

Toggle quote (12 lines)
> diff --git a/guix/scripts/environment.scm b/guix/scripts/environment.scm
> index e435bf0..40af012 100644
> --- a/guix/scripts/environment.scm
> +++ b/guix/scripts/environment.scm
> @@ -719,6 +719,10 @@ message if any test fails."
> (mappings (pick-all opts 'file-system-mapping))
> (white-list (pick-all opts 'inherit-regexp)))
>
> + (when (not (member system '("armhf-linux" "aarch64-linux"
> + "i686-linux" "x86_64-linux" "i586-gnu")))
> + (leave (G_ "guix does not support ~A system~%") system))

The system list should not be hardcoded (there’s already such a list in
(guix packages)).

Currently the error one gets is:

$ guix environment -s does-not-exist --ad-hoc coreutils
guix environment: error: could not find bootstrap binary 'tar' for system 'does-not-exist'

I suppose that’s what you intended to improve, right?

Ludo’.
Ludovic Courtès wrote 4 years ago
control message for bug #45591
(address . control@debbugs.gnu.org)
8735wnw1b2.fsf@gnu.org
tags 45591 + moreinfo
quit
Maxim Cournoyer wrote 2 years ago
Re: bug#45591: environment: gracefully handle unsupported system.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 45591-done@debbugs.gnu.org)(name . guy fleury iteriteka)(address . gfleury@disroot.org)
87tu0q4agf.fsf_-_@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (26 lines)
> Hi,
>
> guy fleury iteriteka <gfleury@disroot.org> skribis:
>
>> diff --git a/guix/scripts/environment.scm b/guix/scripts/environment.scm
>> index e435bf0..40af012 100644
>> --- a/guix/scripts/environment.scm
>> +++ b/guix/scripts/environment.scm
>> @@ -719,6 +719,10 @@ message if any test fails."
>> (mappings (pick-all opts 'file-system-mapping))
>> (white-list (pick-all opts 'inherit-regexp)))
>>
>> + (when (not (member system '("armhf-linux" "aarch64-linux"
>> + "i686-linux" "x86_64-linux" "i586-gnu")))
>> + (leave (G_ "guix does not support ~A system~%") system))
>
> The system list should not be hardcoded (there’s already such a list in
> (guix packages)).
>
> Currently the error one gets is:
>
> $ guix environment -s does-not-exist --ad-hoc coreutils
> guix environment: error: could not find bootstrap binary 'tar' for system 'does-not-exist'
>
> I suppose that’s what you intended to improve, right?

Thanks to the recent work of Mathieu, we now get:

guix environment: error: 'does-not-exist' is not a supported system
hint: Try `--list-systems' to view available system types.

Closing.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45591@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45591
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help