[PATCH] gnu: Add guile2.0-pg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20201231214716.22623-1-mail@cbaines.net
* gnu/packages/guile-xyz.scm (guile2.0-pg): New variable.
---
gnu/packages/guile-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 437d5b77bb..c023d7abd8 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -887,6 +887,43 @@ Vicare Scheme and IronScheme. Right now it contains:
@end itemize\n")
(license license:bsd-3)))
+(define-public guile2.0-pg
+ (package
+ (name "guile2.0-pg")
+ (version "0.49")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/guile-pg/guile-pg-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1fizcqga96p9n2jjhi9nprhry20hg9wvcl5b8gya4vhzwz6qhysp"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-src/Makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/Makefile"
+ (("\\/share\\/guile\\/site") "/share/guile/site/2.0"))
+ #t)))))
+ (native-inputs
+ `(("procps" ,procps) ; fake-cluster-control uses ps
+ ("guile" ,guile-2.0)
+ ("postgresql" ,postgresql)))
+ (inputs
+ `(("guile" ,guile-2.0)
+ ("postgresql" ,postgresql)))
+ (home-page "https://www.nongnu.org/guile-pg/")
+ (synopsis "Guile modules for accessing PostgreSQL")
+ (description
+ "Guile-PG is a collection of modules for Guile allowing access to the
+PostgreSQL RDBMS from Scheme programs.
+
+This has been tested against PostgreSQL 10 through 13, but currently only
+works with Guile 1.4.x to 2.0.x.")
+ (license license:gpl3+)))
+
(define-public guile-prometheus
(let ((commit "35dc26c0ea44c3d70f1819f240d84e2cbb4b7b4c")
(revision "5"))
--
2.29.2
Ludovic Courtès wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 45579@debbugs.gnu.org)
874kjy2hqf.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile2.0-pg): New variable.

LGTM!

(Guile 2.0 though…)

Ludo’.
Christopher Baines wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 45579-done@debbugs.gnu.org)
87o8i598zx.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/guile-xyz.scm (guile2.0-pg): New variable.
>
> LGTM!

Thanks, I've pushed this to master as
d944f10ddd921a15e6cd17a968ca57f0109a1c36.

Toggle quote (2 lines)
> (Guile 2.0 though…)

Yeah, I missed this when I started packaging it. I can't remember for
sure, but I wonder if this is why I ended up using squee for the Guix
Data Service.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/yCzJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeG/g//VjfPARPkEpiPHM01SQz/FQ2RKe1vZKDU
aXkWmjpQr2LSmvEryvUSvHlG2j13r4ZLyJrLb9hhyzUsqvaHObgxYPomz8WkQVwn
45jM/Qgv68vDjZ/lOCLAG0d8Q+jfxMSrCYAf6nTF5+a0IwZrO14BUvc84gtV33Ch
OAU4Yp6Qnf3n4Dee+o/r4NpFzhj+q5fg8odYOxC2yNd4bqo8D98WGsSabA6MoO1W
9xaOilqV6sqveh3zKW6hEIfYaXLQ1UaI0/SWPh72+szn9D1xM20NCQxQ/iEgmcgi
mvBkJLdx5vS3TplBoRTQlTIqiBkBUeScnNE6AXA4UKucUSPw80hJO4BFHAFbUbVU
HzSoKOY0mzPnNJABIUMpwoUB/8uXaqmjH9ueoz+RcKO2/DATwTxqldOe/OCCfjD6
QfHQN72ccg2py1s4f5seBxmMXvovFXv/KTOT8v7uPLdqg+t2UXJnT5242BlPd+EP
ozDiHTtbh3kCP0uv76SwUgE646LonHRofBFus3da+/J1zglMJJN+Q2HglJVaLi2s
mT1B+byAt8Ywrz6BwFl36KpbXmyIF7p0vJhyVNd2WNmHkp9fD6NitrfkEVl5T/Cr
lIvyXBLx+s26uCHUIcGgh6lE/wVSIVd53pb5qzB6iEO2CuENRUPAeL7S9p3N02F9
XQ6gJqX2kBk=
=0MzS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45579@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45579
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help