[PATCH] gnu: Add wyhash.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal

Debbugs page

Ryan Prior wrote 4 years ago
(address . guix-patches@gnu.org)
20201230041228.17076-1-rprior@protonmail.com
* gnu/packages/datastructures.scm (wyhash): New variable.
---
gnu/packages/datastructures.scm | 34 ++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 2911a0c550..49e363d09e 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,38 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system meson))
+ #:use-module (guix build-system meson)
+ #:use-module (guix build-system trivial))
+
+(define-public wyhash
+ (package
+ (name "wyhash")
+ (version "5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wangyi-fudan/wyhash")
+ (commit (string-append "wyhash_v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03ljs5iw9zrm3bydwggjvpwrcwmsd75h3dv1j4am4hw3h22cjdjc"))))
+ (build-system trivial-build-system) ;; source-only package
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((dest (string-append (assoc-ref %outputs "out") "/include")))
+ (mkdir-p dest)
+ (chdir (assoc-ref %build-inputs "source"))
+ (install-file "wyhash.h" dest))
+ #t)))
+ (home-page "https://github.com/wangyi-fudan/wyhash")
+ (synopsis "Embeddable hash function and random number generator.")
+ (description "This package provides a portable hash function and random
+number generator suitable for use in data structures. Provided by default in
+Zig, V, and Nim programming language standard libraries.")
+ (license license:unlicense)))
(define-public gdsl
(package
--
2.29.2
Ryan Prior wrote 4 years ago
[PATCH] gnu: zrythm: Update to 1.0.0-alpha.6.0.1.
(address . guix-patches@gnu.org)
20201230041228.17076-3-rprior@protonmail.com
* gnu/packages/music.scm (zrythm): Update to 1.0.0-alpha.6.0.1.
---
gnu/packages/music.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3c8d3c5881..f889d571c1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5782,7 +5783,7 @@ and as an LV2 plugin.")
;; distros to make necessary changes to integrate the software into the
;; distribution.
(name "zrythm")
- (version "1.0.0-alpha.3.0.1")
+ (version "1.0.0-alpha.6.0.1")
(source
(origin
(method url-fetch)
@@ -5790,7 +5791,7 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "06025367x08y4g9grhcn35bk1dsrpgm04c8l8j50i3p49dl3s1n0"))))
+ "1zfky3yj0k0rmbxighlk9sp4fsgw8rj7viv44yv626kldfvc04ab"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
--
2.29.2
Leo Famulari wrote 4 years ago
Re: [bug#45547] [PATCH] gnu: Add wyhash.
(name . Ryan Prior via Guix-patches via)(address . guix-patches@gnu.org)(address . 45547@debbugs.gnu.org)
X+0HetfSiu4GMT7u@jasmine.lan
On Wed, Dec 30, 2020 at 04:12:32AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/datastructures.scm (wyhash): New variable.

Thanks!

Can you move it to digest.scm and make it install the license file in
"$out/share/doc/wyhash-5"?

You can construct that path like this:

(let* ((out ...)
(doc (string-append out "/share/doc/" ,name "-" ,version))))

Toggle quote (3 lines)
> + (arguments
> + '(#:modules ((guix build utils))

The body of arguments will have to be quasiquoted for this to work. That
is, ` instead of '
Leo Famulari wrote 4 years ago
Re: [bug#45547] [PATCH] gnu: zrythm: Update to 1.0.0-alpha.6.0.1.
(name . Ryan Prior via Guix-patches via)(address . guix-patches@gnu.org)(address . 45547-done@debbugs.gnu.org)
X+0QOtbPilRIvg1P@jasmine.lan
On Wed, Dec 30, 2020 at 04:12:52AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (zrythm): Update to 1.0.0-alpha.6.0.1.

Thanks! Pushed as 0492cc2f5078d78d2adfaa1c2cd38dff964b579d
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45547@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45547
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help