Ryan Prior wrote 4 years ago
(address . guix-patches@gnu.org)
* gnu/packages/datastructures.scm (wyhash): New variable.
---
gnu/packages/datastructures.scm | 34 ++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)
Toggle diff (54 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 2911a0c550..49e363d09e 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,38 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system meson))
+ #:use-module (guix build-system meson)
+ #:use-module (guix build-system trivial))
+
+(define-public wyhash
+ (package
+ (name "wyhash")
+ (version "5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wangyi-fudan/wyhash")
+ (commit (string-append "wyhash_v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03ljs5iw9zrm3bydwggjvpwrcwmsd75h3dv1j4am4hw3h22cjdjc"))))
+ (build-system trivial-build-system) ;; source-only package
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((dest (string-append (assoc-ref %outputs "out") "/include")))
+ (mkdir-p dest)
+ (chdir (assoc-ref %build-inputs "source"))
+ (install-file "wyhash.h" dest))
+ #t)))
+ (home-page "https://github.com/wangyi-fudan/wyhash")
+ (synopsis "Embeddable hash function and random number generator.")
+ (description "This package provides a portable hash function and random
+number generator suitable for use in data structures. Provided by default in
+Zig, V, and Nim programming language standard libraries.")
+ (license license:unlicense)))
(define-public gdsl
(package
--
2.29.2