[PATCH] gnu: borg: Install shell completions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201228133622.13253-1-mike@rohleder.de
* gnu/packages/backup.scm (borg)[arguments]: Add phase to install shell completions.
---
gnu/packages/backup.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 892b92dc2f..0db2c47b2d 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -670,6 +671,19 @@ detection, and lossless compression.")
"docs/misc/internals-picture.txt"
"docs/misc/prune-example.txt"))
(copy-recursively "docs/man" man)
+ #t)))
+ (add-after 'install-docs 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc"))
+ (share (string-append out "/share")))
+ (with-directory-excursion "scripts/shell_completions"
+ (install-file "bash/borg"
+ (string-append etc "/bash_completion.d"))
+ (install-file "zsh/_borg"
+ (string-append share "/zsh/site-functions"))
+ (install-file "fish/borg.fish"
+ (string-append share "/fish/vendor_completions.d")))
#t))))))
(native-inputs
`(("python-cython" ,python-cython)
--
2.29.2
Leo Famulari wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45500-done@debbugs.gnu.org)
X+0FZSqz/j6l+7px@jasmine.lan
On Mon, Dec 28, 2020 at 02:36:22PM +0100, Michael Rohleder wrote:
Toggle quote (2 lines)
> * gnu/packages/backup.scm (borg)[arguments]: Add phase to install shell completions.

Thanks! Pushed as 9d6863de245fc061f24693b58ce87e73fe299d31
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45500@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45500
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help